]> git.pld-linux.org Git - packages/wordpress.git/blob - wordpress.spec
- updated to 2.0.4 (fixes CVE-2006-3389, CVE-2006-3390)
[packages/wordpress.git] / wordpress.spec
1 # TODO
2 # - put config files to %{_sysconfdir}!
3 Summary:        Personal publishing system
4 Summary(pl):    Osobisty system publikacji
5 Name:           wordpress
6 Version:        2.0.4
7 Release:        1
8 License:        GPL
9 Group:          Applications/Publishing
10 Source0:        http://wordpress.org/latest.tar.gz
11 # Source0-md5:  0de8e4b2051ce9313a23d7726210d5e3
12 Source1:        wp-secure.sh
13 Source2:        wp-setup.sh
14 Source3:        wp-setup.txt
15 Source4:        %{name}.conf
16 URL:            http://wordpress.org/
17 Requires:       php >= 3:4.1
18 Requires:       php-gettext >= 4:5.0
19 Requires:       php-mysql >= 4:5.0
20 Requires:       php-pcre >= 4:5.0
21 Requires:       php-xml >= 4:5.0
22 Requires:       php-xmlrpc >= 4:5.0
23 Requires:       webapps
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _appdir         %{_datadir}/%{name}
28 %define         _webapps        /etc/webapps
29 %define         _webapp         %{name}
30 %define         _sysconfdir     %{_webapps}/%{_webapp}
31
32 %description
33 WordPress is a state-of-the-art semantic personal publishing platform
34 with a focus on aesthetics, web standards, and usability. WordPress
35 was born out of a desire for an elegant, well-architectured personal
36 publishing system (also called blog or weblog) built on PHP and MySQL
37 and licensed under the GPL. It is the official successor of
38 b2/cafelog. WordPress is fresh software, but its roots and development
39 go back to 2001.
40
41 %description -l pl
42 WordPress jest technologicznie dopracowan±, semantyczn±, osobist±
43 platform± do publikacji k³ad±c± nacisk na standardy WWW oraz
44 u¿yteczno¶æ. WordPress zosta³ stworzony w wyniku potrzeby
45 eleganckiego, dobrze zaprojektowanego, osobistego systemu publikacji
46 (nazywanego równie¿ blogiem czy weblogiem). Jest to system oparty o
47 PHP i MySQL oraz na licencji GPL. Jest oficjalnym nastêpc± b2/cafelog.
48 WordPress jest nowym oprogramowaniem, ale jego korzenie i rozwój
49 siêgaj± 2001 roku.
50
51 %prep
52 %setup -q -n %{name}
53 cp %{SOURCE1} %{SOURCE2} %{SOURCE3} .
54 rm -f license.txt
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT{%{_appdir},%{_bindir},%{_sysconfdir}}
59
60 cp -R * $RPM_BUILD_ROOT%{_appdir}
61 rm -f $RPM_BUILD_ROOT%{_appdir}/readme.html
62 rm -f $RPM_BUILD_ROOT%{_appdir}/wp-setup.txt
63 ln -sf %{_appdir}/wp-setup.sh $RPM_BUILD_ROOT%{_bindir}/wp-setup
64 ln -sf %{_appdir}/wp-secure.sh $RPM_BUILD_ROOT%{_bindir}/wp-secure
65
66 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
67 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post
73 if [ ! -f %{_appdir}/wp-config.php ]; then
74         install -uroot -ghttp -m640 %{_appdir}/wp-config-sample.php > %{_appdir}/wp-config.php
75
76         %banner -e %{name} <<-EOF
77         To finish your configuration DO NOT FORGET to:
78
79         1) Create some MySQL database owned by some user
80         2) Edit the file: %{_appdir}/wp-config.php
81         3) Run a browser and visit: http://`hostname`/wordpress/wp-admin/install.php
82 EOF
83 fi
84
85 %triggerin -- apache1
86 %webapp_register apache %{_webapp}
87
88 %triggerun -- apache1
89 %webapp_unregister apache %{_webapp}
90
91 %triggerin -- apache < 2.2.0, apache-base
92 %webapp_register httpd %{_webapp}
93
94 %triggerun -- apache < 2.2.0, apache-base
95 %webapp_unregister httpd %{_webapp}
96
97 %files
98 %defattr(644,root,root,755)
99 %doc readme.html wp-setup.txt
100 %dir %attr(750,root,http) %{_sysconfdir}
101 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
102 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
103
104 %dir %{_appdir}
105 %dir %attr(750,root,http) %{_appdir}/wp-content
106 %dir %attr(750,root,http) %{_appdir}/wp-content/plugins
107 %dir %attr(750,root,http) %{_appdir}/wp-content/themes
108 %dir %attr(750,root,http) %{_appdir}/wp-content/themes/classic
109 %dir %attr(750,root,http) %{_appdir}/wp-content/themes/default
110 %attr(640,root,http) %{_appdir}/wp-content/plugins/*.php
111 %attr(640,root,http) %{_appdir}/wp-content/plugins/akismet
112 %attr(640,root,http) %{_appdir}/wp-content/themes/classic/*
113 %attr(640,root,http) %{_appdir}/wp-content/themes/default/*.php
114 %attr(640,root,http) %{_appdir}/wp-content/themes/default/*.css
115 %attr(640,root,http) %{_appdir}/wp-content/themes/default/images/*
116 %{_appdir}/wp-admin
117 %{_appdir}/wp-includes
118 %{_appdir}/*.php
119 %{_appdir}/wp-secure.sh
120 %{_appdir}/wp-setup.sh
121 %attr(755,root,root) %{_bindir}/wp-secure
122 %attr(755,root,root) %{_bindir}/wp-setup
This page took 0.053785 seconds and 4 git commands to generate.