]> git.pld-linux.org Git - packages/wordpress.git/blob - wordpress.spec
- subpackage for plugins
[packages/wordpress.git] / wordpress.spec
1 # TODO
2 # - gettext mo to system dir, add all possible languages?
3 # - merge changes from wpmu.spec
4 Summary:        Personal publishing system
5 Summary(pl.UTF-8):      Osobisty system publikacji
6 Name:           wordpress
7 Version:        3.0.1
8 Release:        0.6
9 License:        GPL v2
10 Group:          Applications/Publishing
11 Source0:        http://wordpress.org/%{name}-%{version}.tar.gz
12 # Source0-md5:  8fa5373ed805fb9a6ee56dfd236dcb64
13 Source1:        wp-secure.sh
14 Source2:        wp-setup.sh
15 Source3:        wp-setup.txt
16 Source4:        apache.conf
17 Source5:        lighttpd.conf
18 Source6:        http://svn.automattic.com/wordpress-i18n/et/tags/%{version}/messages/et.po
19 # Source6-md5:  7ee698806091573a534a4889f88d6d97
20 Source7:        http://svn.automattic.com/wordpress-i18n/pl_PL/tags/%{version}/messages/pl_PL.po
21 # Source7-md5:  795864c6eeeadcc74b8ea70d45f22e9f
22 # MagpieRSS upgrade (version 0.8a) from feedwordpress plugin: http://feedwordpress.radgeek.com/
23 Source10:       rss.php
24 Source11:       rss-functions.php
25 Patch0:         %{name}.patch
26 Patch1:         configpath.patch
27 URL:            http://www.wordpress.org/
28 BuildRequires:  gettext-devel
29 BuildRequires:  rpmbuild(macros) >= 1.553
30 Requires:       php-gettext
31 Requires:       php-mysql
32 Requires:       php-pcre
33 Requires:       php-xml
34 Requires:       php-xmlrpc
35 Requires:       webapps
36 Requires:       webserver(php) >= 5.0
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         _appdir         %{_datadir}/%{name}
41 %define         _webapps        /etc/webapps
42 %define         _webapp         %{name}
43 %define         _sysconfdir     %{_webapps}/%{_webapp}
44
45 %description
46 WordPress is a state-of-the-art semantic personal publishing platform
47 with a focus on aesthetics, web standards, and usability. WordPress
48 was born out of a desire for an elegant, well-architectured personal
49 publishing system (also called blog or weblog) built on PHP and MySQL
50 and licensed under the GPL. It is the official successor of
51 b2/cafelog. WordPress is fresh software, but its roots and development
52 go back to 2001.
53
54 %description -l pl.UTF-8
55 WordPress jest technologicznie dopracowaną, semantyczną, osobistą
56 platformą do publikacji kładącą nacisk na standardy WWW oraz
57 użyteczność. WordPress został stworzony w wyniku potrzeby
58 eleganckiego, dobrze zaprojektowanego, osobistego systemu publikacji
59 (nazywanego również blogiem czy weblogiem). Jest to system oparty o
60 PHP i MySQL oraz na licencji GPL. Jest oficjalnym następcą b2/cafelog.
61 WordPress jest nowym oprogramowaniem, ale jego korzenie i rozwój
62 sięgają 2001 roku.
63
64 %package setup
65 Summary:        Wordpress setup package
66 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Wordpress
67 Group:          Applications/WWW
68 Requires:       %{name} = %{version}-%{release}
69
70 %description setup
71 Install this package to configure initial WordPress installation. You
72 should uninstall this package when you're done, as it considered
73 insecure to keep the setup files in place.
74
75 %description setup -l pl.UTF-8
76 Ten pakiet należy zainstalować w celu wstępnej konfiguracji WordPress
77 po pierwszej instalacji. Potem należy go odinstalować, jako że
78 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
79
80 %package plugin-akismet
81 Summary:        Wordpress Akismet Plugin
82 Group:          Applications/WWW
83 Requires:       %{name} = %{version}-%{release}
84
85 %description plugin-akismet
86 Akismet checks your comments against the Akismet web service to see if
87 they look like spam or not and lets you review the spam it catches
88 under your blog's "Comments" admin screen.
89
90 %package theme-twentyten
91 Summary:        Wordpress MU default theme
92 Group:          Applications/WWW
93 URL:            http://wordpress.org/extend/themes/twentyten
94 Requires:       %{name} = %{version}-%{release}
95
96 %description theme-twentyten
97 The 2010 theme for WordPress is stylish, customizable, simple, and
98 readable.
99
100 Make it yours with a custom menu, header image, and background. Twenty
101 Ten supports six widgetized areas (two in the sidebar, four in the
102 footer) and featured images (thumbnails for gallery posts and custom
103 header images for posts and pages). It includes stylesheets for print
104 and the admin Visual Editor, special styles for posts in the "Asides"
105 and "Gallery" categories, and has an optional one-column page template
106 that removes the sidebar.
107
108 %prep
109 %setup -qc
110 mv %{name}/* . && rmdir %{name}
111 %undos -f php,js,html
112 cp -a wp-config{-sample,}.php
113 %patch0 -p1
114 %patch1 -p1
115 cp -a %{SOURCE3} .
116 rm -f license.txt
117
118 rm wp-content/themes/index.php
119 rm wp-content/plugins/index.php
120 rm wp-content/index.php
121
122 # sample plugin
123 rm wp-content/plugins/hello.php
124
125 # Install new MagpieRSS
126 # NOTE: this is deprecated, simplepie should be used instead
127 cp -a %{SOURCE10} wp-includes/rss.php
128 cp -a %{SOURCE11} wp-includes/rss-functions.php
129
130 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
131
132 %build
133 install -d wp-content/languages
134 msgfmt --statistics %{SOURCE6} -o wp-content/languages/et.mo
135 msgfmt --statistics %{SOURCE7} -o wp-content/languages/pl_PL.mo
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139 install -d $RPM_BUILD_ROOT{%{_appdir},%{_bindir},%{_sysconfdir},%{_appdir}/wp-content/{languages,mu-plugins}}
140
141 cp -a . $RPM_BUILD_ROOT%{_appdir}
142 mv $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir}}/wp-config.php
143 rm -f $RPM_BUILD_ROOT%{_appdir}/readme.html
144 rm -f $RPM_BUILD_ROOT%{_appdir}/wp-setup.txt
145
146 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/wp-secure
147 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/wp-setup
148 ln -s %{_bindir}/wp-setup $RPM_BUILD_ROOT%{_appdir}/wp-setup.sh
149 ln -s %{_bindir}/wp-secure $RPM_BUILD_ROOT%{_appdir}/wp-secure.sh
150
151 cp -a %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
152 cp -a %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
153 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %post
159 if [ "$1" = 1 ]; then
160         %banner -e %{name} <<-EOF
161         To finish your configuration DO NOT FORGET to:
162
163         1) Create some MySQL database owned by some user
164         2) Edit the file: %{_sysconfdir}/wp-config.php
165         3) Install %{name}-setup
166         4) Run a browser and visit: http://`hostname`/wordpress/wp-admin/install.php
167 EOF
168 fi
169
170 %post setup
171 chmod 660 %{_sysconfdir}/wp-config.php
172 chown root:http %{_sysconfdir}/wp-config.php
173
174 %postun setup
175 if [ "$1" = "0" ]; then
176         chmod 640 %{_sysconfdir}/wp-config.php
177         chown root:http %{_sysconfdir}/wp-config.php
178 fi
179
180 %triggerin -- apache1 < 1.3.37-3, apache1-base
181 %webapp_register apache %{_webapp}
182
183 %triggerin -- lighttpd
184 %webapp_register lighttpd %{_webapp}
185
186 %triggerun -- apache1 < 1.3.37-3, apache1-base
187 %webapp_unregister apache %{_webapp}
188
189 %triggerin -- apache < 2.2.0, apache-base
190 %webapp_register httpd %{_webapp}
191
192 %triggerun -- apache < 2.2.0, apache-base
193 %webapp_unregister httpd %{_webapp}
194
195 %triggerun -- lighttpd
196 %webapp_unregister lighttpd %{_webapp}
197
198 %files
199 %defattr(644,root,root,755)
200 %doc readme.html wp-setup.txt
201 %dir %attr(750,root,http) %{_sysconfdir}
202 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
203 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
204 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
205 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/wp-config.php
206
207 %dir %{_appdir}
208 %{_appdir}/*.php
209 %{_appdir}/wp-includes
210 %dir %{_appdir}/wp-content
211 %dir %{_appdir}/wp-content/languages
212 %lang(et) %{_appdir}/wp-content/languages/et.mo
213 %lang(pl) %{_appdir}/wp-content/languages/pl_PL.mo
214 %dir %{_appdir}/wp-content/plugins
215 %dir %{_appdir}/wp-content/mu-plugins
216 %dir %{_appdir}/wp-content/themes
217
218 %files setup
219 %defattr(644,root,root,755)
220 %attr(755,root,root) %{_bindir}/wp-secure
221 %attr(755,root,root) %{_bindir}/wp-setup
222 %{_appdir}/wp-secure.sh
223 %{_appdir}/wp-setup.sh
224 %{_appdir}/wp-admin
225
226 %files plugin-akismet
227 %defattr(644,root,root,755)
228 %dir %{_appdir}/wp-content/plugins/akismet
229 %doc %{_appdir}/wp-content/plugins/akismet/readme.txt
230 %{_appdir}/wp-content/plugins/akismet/*.php
231 %{_appdir}/wp-content/plugins/akismet/*.gif
232
233 %files theme-twentyten
234 %defattr(644,root,root,755)
235 %{_appdir}/wp-content/themes/twentyten
This page took 0.073997 seconds and 3 git commands to generate.