]> git.pld-linux.org Git - SPECS.git/blob - wmapp.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / wmapp.spec
1 Summary:        WMApp graphics library
2 Summary(pl.UTF-8):      WMApp - biblioteka graficzna
3 Name:           wmapp
4 Version:        0.0.4.2
5 Release:        1
6 License:        GPL
7 Group:          Libraries
8 Source0:        http://savannah.nongnu.org/download/fetchmailmon/stable.pkg/0.3/%{name}-%{version}.tar.gz
9 # Source0-md5:  4bf473fdcacce60a3e1d5fbe945e9e9d
10 URL:            http://www.princeton.edu/~kmccarty/wmapp.html
11 BuildRequires:  XFree86-devel
12 BuildRequires:  libstdc++-devel
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 This is WMApp, a C++ graphics library written exclusively for
17 developing WindowMaker dockapps. If you like dockapps, but you also
18 like C++ and you are tired of trying to work with the code in
19 wmgeneral.c, this library is for you!
20
21 %description -l pl.UTF-8
22 WMApp jest graficzną biblioteką napisaną wyłącznie dla celów
23 rozwijania dokowalnych aplikacji Window Makera. Jeśli lubisz takie
24 aplikacje a także C++ i jesteś zmęczony pracą z kodem wmgeneral.c, ta
25 biblioteka jest właśnie dla Ciebie!
26
27 %package devel
28 Summary:        Header files for WMApp
29 Summary(pl.UTF-8):      Pliki nagłówkowe dla WMApp
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}-%{release}
32 Requires:       XFree86-devel
33 Requires:       libstdc++-devel
34
35 %description devel
36 The header files are only needed for development of programs using the
37 WMApp library.
38
39 %description devel -l pl.UTF-8
40 Pliki nagłówkowe, które są potrzebne tylko dla programistów używająch
41 biblioteki WMApp.
42
43 %package static
44 Summary:        Static version of WMApp library
45 Summary(pl.UTF-8):      Statyczna wersja biblioteki WMApp
46 Group:          Development/Libraries
47 Requires:       %{name}-devel = %{version}-%{release}
48
49 %description static
50 Static version of WMApp library.
51
52 %description static -l pl.UTF-8
53 Statyczna wersja biblioteki WMApp.
54
55 %prep
56 %setup -q
57
58 %build
59 %{__make} \
60         CFLAGS="%{rpmcflags} -fPIC -Wall -pedantic"
61
62 %{__cxx} %{rpmldflags} -shared *.o -o libwmapp.so.1.0 \
63         -Wl,-soname=libwmapp.so.1 -L/usr/X11R6/lib -lXpm -lXext -lX11
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name},%{_libdir},%{_examplesdir}/%{name}-%{version}/example{1,2}}
68
69 install libwmapp* $RPM_BUILD_ROOT%{_libdir}
70 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
71 install xpm/*.xpm $RPM_BUILD_ROOT%{_includedir}/%{name}
72 ln -s libwmapp.so.1 $RPM_BUILD_ROOT%{_libdir}/libwmapp.so
73
74 install example1/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/example1
75 install example2/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/example2
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post   -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files
84 %defattr(644,root,root,755)
85 %doc Changelog Changelog.Jason README
86 %attr(755,root,root) %{_libdir}/lib*.so.*.*
87
88 %files devel
89 %defattr(644,root,root,755)
90 %attr(755,root,root) %{_libdir}/lib*.so
91 %{_includedir}/%{name}
92 %{_examplesdir}/%{name}-%{version}
93
94 %files static
95 %defattr(644,root,root,755)
96 %{_libdir}/lib*.a
This page took 0.215198 seconds and 3 git commands to generate.