]> git.pld-linux.org Git - packages/wireshark.git/blob - wireshark.spec
4d98c6c947fc0bfee65f89210f36bd99c8e1e6c1
[packages/wireshark.git] / wireshark.spec
1 #
2 # WARNING: ethereal.spec and tethereal.spec are using the same source
3 # file, so they should be keeped in sync!
4 # I found it easier to do it that way (two separate specs)
5 # If you know how to do it better feel free to do so.
6 #
7 # ethereal an ethereal-common are built from this spec
8 Summary:        Network traffic and protocol analyzer
9 Summary(es):    Analizador de tráfico de red
10 Summary(pl):    Analizator ruchu i protoko³ów sieciowych
11 Summary(pt_BR): Analisador de tráfego de rede
12 Name:           ethereal
13 Version:        0.9.8
14 Release:        1
15 License:        GPL
16 Group:          Networking
17 Source0:        http://www.ethereal.com/distribution/%{name}-%{version}.tar.gz
18 Source1:        %{name}.desktop
19 Source2:        %{name}.su-start-script
20 URL:            http://www.ethereal.com/
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  flex
24 BuildRequires:  gtk+-devel >= 1.2
25 BuildRequires:  libpcap-devel >= 0.4
26 BuildRequires:  libtool
27 BuildRequires:  openssl-devel
28 BuildRequires:  perl-devel
29 BuildRequires:  ucd-snmp-devel >= 4.2.6
30 BuildRequires:  zlib-devel
31 Requires:       libpcap >= 0.4
32 Requires:       ethereal-common = %{version}
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _sysconfdir     /usr/share/misc
36
37 %description
38 Ethereal is the name for powerful graphical network sniffer, traffic
39 and protocol analyzer based on GTK+ and libpcap libraries. It lets you
40 capture and interactively browse the contents of network frames with
41 vast knowledge of more than 100 network protocols. Ethereal has
42 severeal useful features, including a rich display filter language,
43 the ability to view the ASCII contents of a TCP connection and plug-in
44 capabilities.
45
46 %description -l es
47 Analizador de tráfico de red.
48
49 %description -l pl
50 Ethereal jest potê¿nym, graficznym snifferem, analizatorem ruchu oraz
51 protoko³ów sieciowych opartym na bibliotekach GTK+ oraz libpcap.
52 Umo¿liwia on przechwytywanie oraz intereaktywn± analizê zawarto¶ci
53 ramek oraz ponad stu protoko³ów sieciowych. Ethereal posiada wiele
54 u¿ytecznych cech, takich jak rozbudowany jêzyk filtrów wy¶wietlania,
55 mo¿liwo¶æ ogl±dania przebiegu sesji TCP oraz mo¿liwo¶æ do³±czania
56 wtyczek (plug-ins).
57
58 %description -l pt_BR
59 O Ethereal é um analisador de protocolo de rede baseado no GTK+.
60
61 %package common
62 Summary:        Network traffic and protocol analyzer - common files
63 Summary(pl):    Analizator ruchu i protoko³ów sieciowych - wspólne pliki
64 Group:          Networking
65
66 %description common
67 Ethereal is the name for powerful graphical network sniffer, traffic
68 and protocol analyzer based on GTK+ and libpcap libraries. It lets you
69 capture and interactively browse the contents of network frames with
70 vast knowledge of more than 100 network protocols. Ethereal has
71 severeal useful features, including a rich display filter language,
72 the ability to view the ASCII contents of a TCP connection and plug-in
73 capabilities.
74
75 %description common -l pl
76 Ethereal jest potê¿nym, graficznym snifferem, analizatorem ruchu oraz
77 protoko³ów sieciowych opartym na bibliotekach GTK+ oraz libpcap.
78 Umo¿liwia on przechwytywanie oraz intereaktywn± analizê zawarto¶ci
79 ramek oraz ponad stu protoko³ów sieciowych. Ethereal posiada wiele
80 u¿ytecznych cech, takich jak rozbudowany jêzyk filtrów wy¶wietlania,
81 mo¿liwo¶æ ogl±dania przebiegu sesji TCP oraz mo¿liwo¶æ do³±czania
82 wtyczek (plug-ins).
83
84 %prep
85 %setup -q
86
87 %build
88 rm -f missing
89 %{__libtoolize}
90 %{__aclocal}
91 %{__autoconf}
92 %{__automake}
93 cd epan
94 rm -f missing
95 %{__aclocal}
96 %{__autoconf}
97 automake -a -c --foreign
98 cd ../wiretap
99 %{__aclocal}
100 %{__autoconf}
101 automake -a -c --foreign
102 cd ..
103 %configure \
104         --disable-static \
105         --disable-editcap \
106         --disable-mergecap \
107         --disable-tethereal \
108         --disable-idl2eth \
109         --enable-ipv6 \
110         --disable-randpkt \
111         --disable-text2pcap \
112         --enable-zlib \
113         --with-pcap \
114         --with-plugindir=%{_libdir}/ethereal \
115         --with-ssl \
116         --with-ucdsnmp
117
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122 install -d $RPM_BUILD_ROOT{%{_applnkdir}/Network/Misc,%{_datadir}/pixmaps}
123
124 %{__make} DESTDIR=$RPM_BUILD_ROOT install
125
126 install %{SOURCE1} $RPM_BUILD_ROOT%{_applnkdir}/Network/Misc
127 install image/ethereal48x48-trans.png $RPM_BUILD_ROOT%{_datadir}/pixmaps/ethereal.png
128 install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/ethereal_su
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %files common
134 %defattr(644,root,root,755)
135 %doc AUTHORS NEWS README README.linux README.vmware FAQ ChangeLog
136 %doc doc/randpkt.txt doc/README.*
137
138 %files 
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_bindir}/*
141 %{_applnkdir}/Network/Misc/ethereal.desktop
142 %{_sysconfdir}/manuf
143 %{_mandir}/man1/*
144 %{_pixmapsdir}/*
145 %dir %{_libdir}/ethereal
146 %attr(755,root,root) %{_libdir}/ethereal/*
This page took 0.049609 seconds and 2 git commands to generate.