]> git.pld-linux.org Git - SPECS.git/blob - winexe.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / winexe.spec
1 #
2 # Conditional build:
3 %bcond_with     python
4 %bcond_with     sqlite3
5 %bcond_with     pthreads
6 %bcond_with     setproctitle
7 %bcond_with     incpopt
8 %bcond_with     wmic
9 %bcond_with     wmis
10 #
11 Summary:        winexe - remotely executes commands on WindowsNT/2000/XP/2003 systems from GNU/Linux
12 Summary(pl.UTF-8):      winexe - zdalne wywoływanie poleceń na WindowsNT/2000/XP/2003 spod Linuksa
13 Name:           winexe
14 Version:        071026
15 Release:        6
16 Epoch:          0
17 License:        GPL v2
18 Group:          Applications
19 Source0:        http://eol.ovh.org/winexe/%{name}-source-%{version}.tar.bz2
20 # Source0-md5:  4eb7bc95014e6db7cd930513139f915f
21 URL:            http://eol.ovh.org/winexe/
22 BuildRequires:  autoconf >= 2.53
23 BuildRequires:  crossmingw32-binutils
24 BuildRequires:  crossmingw32-gcc
25 BuildRequires:  crossmingw32-gcc-c++
26 BuildRequires:  crossmingw32-w32api
27 BuildRequires:  dmapi-devel
28 BuildRequires:  libnscd-devel
29 BuildRequires:  openssl-devel >= 0.9.7d
30 BuildRequires:  openldap-devel >= 2.4.6
31 BuildRequires:  pam-devel >= 0.99.8.1
32 BuildRequires:  popt-devel
33 %if %{with python}
34 BuildRequires:  python-devel >= 2.3
35 BuildRequires:  rpm-pythonprov
36 BuildRequires:  swig >= 1.3
37 %endif
38 BuildRequires:  rpmbuild(macros) >= 1.304
39 BuildRequires:  readline-devel >= 4.2
40 BuildRequires:  samba-devel
41 Requires:       samba
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 This implementation of DCOM/WMI client is based on Samba4 sources. It
46 uses RPC/DCOM mechanism to interact with WMI services on Windows
47 2000/XP/2003 machines. It contains also winexe - program to remote
48 execution Windows commands remotely from Linux box.
49
50 %description -l pl.UTF-8
51 Implementacja klienta DCOM/WMI na bazie kodu Samba4. Używa mechanizmu
52 RPC/DCOM do komunikacji z usługą WMI na komputerach z
53 Windows 2000/XP/2003. Zawiera program winexe, ktory zdalnie wywołuje
54 polecenia na WindowsNT/2000/XP/2003 spod systemu GNU/Linux,
55 będąc odpowiednikiem psexec.
56
57 %prep
58 %setup -q -n %{name}-source-%{version}
59
60 %build
61 #http://dev.zenoss.com/trac/browser/trunk/wmi/README
62 ./autogen.sh
63 %configure \
64         --with-fhs \
65         %{?with_sqlite3:--with-sqlite3} \
66         %{?with_pthreads:--with-pthreads} \
67         %{?with_setproctitle:--with-pthreads} \
68         %{?with_python:--with-python} \
69         %{?with_incpopt:--with-included-popt} \
70
71 #       --enable-reg-gconf
72
73 %{__make} proto \
74         bin/winexe \
75         %{?with_wmic: bin/wmic} \
76         %{?with_wmis: bin/wmis} \
77         %{?with_python: wmi/_pywmi.dylib}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT%{_bindir}
82 install bin/winexe $RPM_BUILD_ROOT%{_bindir}
83 %{?with_wmic: install bin/wmic $RPM_BUILD_ROOT%{_bindir} }
84 %{?with_wmis: install bin/wmis $RPM_BUILD_ROOT%{_bindir} }
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files
90 %defattr(644,root,root,755)
91 %attr(755,root,root) %{_bindir}/*
This page took 0.263107 seconds and 3 git commands to generate.