]> git.pld-linux.org Git - SPECS.git/blob - wine-doors.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / wine-doors.spec
1 Summary:        Wine-Doors - Windows application management for the GNOME desktop
2 Summary(pl.UTF-8):      Wine-Doors - zarządzanie aplikacjami Windows dla środowiska GNOME
3 Name:           wine-doors
4 Version:        0.1.4
5 %define _rc     a2
6 Release:        0.%{_rc}.0.9
7 License:        GPL (application), Creative Commons (artwork)
8 Group:          Applications/Emulators
9 Source0:        http://sourceforge.net/projects/winedoors/files/%{name}-%{version}%{_rc}.tar.gz
10 # Source0-md5:  78d5acd1b65bee9cd08b0a2b31ad8d45
11 Patch0:         %{name}-runtime-deps.patch
12 #URL:           http://www.wine-doors.org/      Dead URL
13 URL:            http://sourceforge.net/projects/winedoors/
14 BuildRequires:  synce-orange
15 Requires:       cabextract
16 Requires:       cairo >= 1.2.4
17 Requires:       python
18 Requires:       python-gnome-desktop-librsvg >= 2.16
19 Requires:       python-libxml2
20 Requires:       python-pycairo >= 1.2.0
21 Requires:       python-pygtk-glade
22 Requires:       synce-orange
23 Requires:       which
24 Requires:       wine
25 Requires:       wine-programs
26 Requires:       xorg-app-setxkbmap
27 #BuildArch:     noarch
28 ExclusiveArch:  %{ix86}
29 ExcludeArch:    i386
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 # no binary contents
33 %define         _enable_debug_packages  0
34
35 %description
36 Wine-doors provides a replacement for winetools which adds apt/yum
37 functionality to wine, doing away with the bad aspects of winetools
38 whilst keeping the good ones and extending on the origninal idea with
39 a more modern design approach.
40
41 Wine-Doors is licensed under the GNU General Public License and
42 utilises resources from the Tango Project.
43
44 %description -l pl.UTF-8
45 Wine-doors dostarcza zamiennik winetools dodający funkcjonalność
46 apt/yum do wine, unikając złych aspektów winetools, a zachowując dobre
47 i rozszerzając oryginalny pomysł o bardziej współczesne podejście.
48
49 Wine-Doors jest udostępniany na Powszechnej Licencji Publicznej GNU
50 (General Public License) i wykorzystuje zasoby z projektu Tango.
51
52 %prep
53 %setup -q -c -n %{name}-%{version}%{_rc}
54 #patch0 -p1
55
56 cat <<'EOF' > %{name}.sh
57 #!/bin/sh
58 exec %{__python} %{_datadir}/%{name}/src/winedoors.pyo
59 EOF
60
61 %{__sed} -i -e '1s,#.*python,#!%{__python},' src/winedoors.py
62
63 # cleanup backups after patching
64 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 export USER=root
69 %{__python} setup.py install \
70         --temp=$RPM_BUILD_ROOT \
71         --config=%{_sysconfdir}/%{name} \
72         -S
73
74 rm -f $RPM_BUILD_ROOT%{_bindir}/%{name}
75 install -D %{name}.sh $RPM_BUILD_ROOT%{_bindir}/%{name}
76
77 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}/src
78 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}/src
79 %py_postclean %{_datadir}/%{name}/src
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %doc INSTALL LICENSE README
87 %dir %{_sysconfdir}/wine-doors
88 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/preferences.xml
89 %attr(755,root,root) %{_bindir}/*
90 %{_desktopdir}/wine-doors.desktop
91 %{_pixmapsdir}/wine-doors.*
92 %dir %{_datadir}/%{name}
93 %{_datadir}/%{name}/dtd
94 %{_datadir}/%{name}/pixmaps
95 %{_datadir}/%{name}/registry
96 %dir %{_datadir}/%{name}/src
97 %{_datadir}/%{name}/src/*.png
98 %{_datadir}/%{name}/src/*.sh
99 %{_datadir}/%{name}/src/*.svg
100 %{_datadir}/%{name}/src/winedoors.glade
101 %{_datadir}/%{name}/src/winedoors.gladep
102 %{_datadir}/%{name}/src/*.py[co]
103 ## Repositories should be as separate package?
104 %dir %{_datadir}/%{name}/applications.repo
105 %dir %{_datadir}/%{name}/base.repo
106 %dir %{_datadir}/%{name}/games.repo
107 %dir %{_datadir}/%{name}/libraries.repo
108 %{_datadir}/%{name}/applications.repo/*.wdi
109 %{_datadir}/%{name}/base.repo/*.wdi
110 %{_datadir}/%{name}/games.repo/*.wdi
111 %{_datadir}/%{name}/libraries.repo/*.wdi
112 %{_datadir}/%{name}/applications.repo/*.xml.gz
113 %{_datadir}/%{name}/base.repo/*.xml.gz
114 %{_datadir}/%{name}/games.repo/*.xml.gz
115 %{_datadir}/%{name}/libraries.repo/*.xml.gz
This page took 0.168067 seconds and 3 git commands to generate.