]> git.pld-linux.org Git - packages/wimlib.git/blob - wimlib.spec
615e9c404b2c006debe187be8de2540ad31e795b
[packages/wimlib.git] / wimlib.spec
1 # Conditional build:
2 %bcond_without  ntfs_3g         # build without ntfs-3g (avoid GPLv2 dependency)
3 %bcond_without  static_libs     # static library
4
5 Summary:        Open source Windows Imaging (WIM) library
6 Name:           wimlib
7 Version:        1.14.4
8 Release:        1
9 License:        GPL v3+ or LGPL v3+
10 Group:          Libraries
11 Source0:        https://wimlib.net/downloads/%{name}-%{version}.tar.gz
12 # Source0-md5:  6a54e53d20d524d139e5f60e4604b1a3
13 URL:            https://wimlib.net/
14 BuildRequires:  libfuse3-devel
15 %{?with_ntfs_3g:BuildRequires:  ntfs-3g-devel >= 1:2011.4.12}
16 BuildRequires:  pkgconfig
17 BuildRequires:  rpmbuild(macros) >= 1.527
18 Requires:       libfuse3-tools
19 %{?with_ntfs_3g:Requires:       ntfs-3g-libs >= 1:2011.4.12}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 wimlib is an open source, cross-platform library for creating,
24 extracting, and modifying Windows Imaging (WIM) archives. WIM is a
25 file archiving format, somewhat comparable to ZIP (and many other file
26 archiving formats); but unlike ZIP, it allows storing various
27 Windows-specific metadata, allows storing multiple "images" in a
28 single archive, automatically deduplicates all file contents, and
29 supports optional solid compression to get a better compression ratio.
30 wimlib and its command-line frontend wimlib-imagex provide a free and
31 cross-platform alternative to Microsoft's WIMGAPI, ImageX, and DISM.
32
33 %package devel
34 Summary:        Development files for wimlib
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37
38 %description devel
39 Development files for wimlib.
40
41 %package static
42 Summary:        Static wimlib library
43 Group:          Development/Libraries
44 Requires:       %{name}-devel = %{version}-%{release}
45
46 %description static
47 Static wimlib library.
48
49 %package tools
50 Summary:        Tools for creating, modifying, extracting, and mounting WIM files
51 Group:          Applications/System
52 Requires:       %{name} = %{version}-%{release}
53 Suggests:       mkisofs
54
55 %description tools
56 Tools for creating, modifying, extracting, and mounting WIM files.
57
58 %prep
59 %setup -q
60
61 %{__sed} -i -e '1s,/usr/bin/env bash,%{__bash},' programs/mkwinpeimg.in
62
63 %build
64 %configure \
65         --disable-silent-rules \
66         %{__enable_disable static_libs static} \
67         %{!?with_ntfs_3g:--without-ntfs-3g}
68 %{__make}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %{__make} install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libwim.la
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post   -p /sbin/ldconfig
82 %postun -p /sbin/ldconfig
83
84 %files
85 %defattr(644,root,root,755)
86 %doc COPYING NEWS.md README.md
87 %attr(755,root,root) %{_libdir}/libwim.so.*.*.*
88 %attr(755,root,root) %ghost %{_libdir}/libwim.so.15
89
90 %files devel
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_libdir}/libwim.so
93 %{_includedir}/wimlib.h
94 %{_pkgconfigdir}/wimlib.pc
95
96 %if %{with static_libs}
97 %files static
98 %defattr(644,root,root,755)
99 %{_libdir}/libwim.a
100 %endif
101
102 %files tools
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{_bindir}/mkwinpeimg
105 %attr(755,root,root) %{_bindir}/wimappend
106 %attr(755,root,root) %{_bindir}/wimapply
107 %attr(755,root,root) %{_bindir}/wimcapture
108 %attr(755,root,root) %{_bindir}/wimdelete
109 %attr(755,root,root) %{_bindir}/wimdir
110 %attr(755,root,root) %{_bindir}/wimexport
111 %attr(755,root,root) %{_bindir}/wimextract
112 %attr(755,root,root) %{_bindir}/wiminfo
113 %attr(755,root,root) %{_bindir}/wimjoin
114 %attr(755,root,root) %{_bindir}/wimlib-imagex
115 %attr(755,root,root) %{_bindir}/wimmount
116 %attr(755,root,root) %{_bindir}/wimmountrw
117 %attr(755,root,root) %{_bindir}/wimoptimize
118 %attr(755,root,root) %{_bindir}/wimsplit
119 %attr(755,root,root) %{_bindir}/wimunmount
120 %attr(755,root,root) %{_bindir}/wimupdate
121 %attr(755,root,root) %{_bindir}/wimverify
122 %{_mandir}/man1/mkwinpeimg.1*
123 %{_mandir}/man1/wimappend.1*
124 %{_mandir}/man1/wimapply.1*
125 %{_mandir}/man1/wimcapture.1*
126 %{_mandir}/man1/wimdelete.1*
127 %{_mandir}/man1/wimdir.1*
128 %{_mandir}/man1/wimexport.1*
129 %{_mandir}/man1/wimextract.1*
130 %{_mandir}/man1/wiminfo.1*
131 %{_mandir}/man1/wimjoin.1*
132 %{_mandir}/man1/wimlib-imagex-append.1*
133 %{_mandir}/man1/wimlib-imagex-apply.1*
134 %{_mandir}/man1/wimlib-imagex-capture.1*
135 %{_mandir}/man1/wimlib-imagex-delete.1*
136 %{_mandir}/man1/wimlib-imagex-dir.1*
137 %{_mandir}/man1/wimlib-imagex-export.1*
138 %{_mandir}/man1/wimlib-imagex-extract.1*
139 %{_mandir}/man1/wimlib-imagex-info.1*
140 %{_mandir}/man1/wimlib-imagex-join.1*
141 %{_mandir}/man1/wimlib-imagex-mount.1*
142 %{_mandir}/man1/wimlib-imagex-mountrw.1*
143 %{_mandir}/man1/wimlib-imagex-optimize.1*
144 %{_mandir}/man1/wimlib-imagex-split.1*
145 %{_mandir}/man1/wimlib-imagex-unmount.1*
146 %{_mandir}/man1/wimlib-imagex-update.1*
147 %{_mandir}/man1/wimlib-imagex-verify.1*
148 %{_mandir}/man1/wimlib-imagex.1*
149 %{_mandir}/man1/wimmount.1*
150 %{_mandir}/man1/wimmountrw.1*
151 %{_mandir}/man1/wimoptimize.1*
152 %{_mandir}/man1/wimsplit.1*
153 %{_mandir}/man1/wimunmount.1*
154 %{_mandir}/man1/wimupdate.1*
155 %{_mandir}/man1/wimverify.1*
This page took 0.057013 seconds and 3 git commands to generate.