]> git.pld-linux.org Git - packages/wicd.git/blob - wicd.spec
- resort translations
[packages/wicd.git] / wicd.spec
1 # TODO
2 # - fix pm-utils to store addons in non-arch dependant path so we could make this pkg noarch
3 # - package (acpid-XXX):
4 #   /etc/acpi/resume.d/80-wicd-connect.sh
5 #   /etc/acpi/suspend.d/50-wicd-suspend.sh
6 # - notes about translations:
7 #   - duplicate fr and fr_FR exist, we prefer fr_FR
8 #   - ar_PS (Palestine) isn't in glibc yet.
9 #   - ar_EG (Egypt) isn't in glibc yet. using ar instead
10 Summary:        wired and wireless network manager
11 Summary(pl.UTF-8):      Zarządca sieci przewodowych i bezprzewodowych
12 Name:           wicd
13 Version:        1.7.0
14 Release:        0.1
15 License:        GPL v2
16 Group:          X11/Applications/Networking
17 Source0:        http://dl.sourceforge.net/wicd/%{name}-%{version}.tar.gz
18 # Source0-md5:  003d2e67240989db55934553437ba32a
19 Source1:        %{name}.init
20 Patch0:         %{name}-init_status.patch
21 Patch1:         bashism.patch
22 URL:            http://www.wicd.net/
23 # /etc/pld-release used to detect platform
24 BuildRequires:  issue
25 BuildRequires:  python-devel
26 BuildRequires:  python-modules
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  rpmbuild(macros) >= 1.228
29 BuildRequires:  sed >= 4.0
30 Requires(post,preun):   /sbin/chkconfig
31 Requires:       dbus(org.freedesktop.Notifications)
32 Requires:       python-dbus
33 Requires:       python-iwscan
34 Requires:       python-pygobject
35 Requires:       python-pygtk-glade >= 2:2.0
36 Requires:       python-pygtk-gtk >= 2:2.0
37 Requires:       python-wpactrl
38 # not noarch due pm-utils packaging stupidity
39 #BuildArch:     noarch
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Wicd is an open source wired and wireless network manager for Linux
44 which aims to provide a simple interface to connect to networks with a
45 wide variety of settings.
46
47 %description -l pl.UTF-8
48 Wicd jest zarządcą sieci przewodowych i bezprzewodowych dla Linuksa,
49 mającym zapewnić prosty interfejs do podłączania do sieci z
50 różnorakimi opcjami.
51
52 %package client-cli
53 Summary:        wicd CLI client
54 Summary(pl.UTF-8):      klient wicd CLI
55 Group:          Applications/System
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       python-urwid
58
59 %description client-cli
60 Wicd command line interface (ncurses) client.
61
62 %description client-cli -l pl.UTF-8
63 Klient wicd z międzymordziem wiersza poleceń (ncurses).
64
65 %package client-curses
66 Summary:        wicd TUI client
67 Summary(pl.UTF-8):      klient wicd z TUI
68 Group:          Applications/System
69 Requires:       %{name} = %{version}-%{release}
70
71 %description client-curses
72 Wicd text user interface (ncurses) client.
73
74 %description client-curses -l pl.UTF-8
75 Klient Wicd z tesktowym międzymordziem uzytkownika (ncurses).
76
77 %package client-gtk
78 Summary:        wicd GUI client
79 Summary(pl.UTF-8):      klient wicd z GUI
80 Group:          Applications/System
81 Requires:       %{name} = %{version}-%{release}
82
83 %description client-gtk
84 Wicd graphical user interface (GTK+2) client.
85
86 %description client-gtk -l pl.UTF-8
87 Klient Wicd z graficznym międzymordziem użytkownika (GTK+2).
88
89 %package -n pm-utils-wicd
90 Summary:        wicd script for pm-utils
91 Summary(pl.UTF-8):      Skrypt wicd dla pm-utils
92 Group:          Applications/System
93 Requires:       %{name} = %{version}-%{release}
94 Requires:       pm-utils
95
96 %description -n pm-utils-wicd
97 Wicd script for pm-utils.
98
99 %description -n pm-utils-wicd -l pl.UTF-8
100 Skrypt wicd dla pm-utils.
101
102 %prep
103 %setup -q
104 %patch0 -p1
105 %patch1 -p1
106
107 mv translations/{ar_EG,ar}
108 rm -rf translations/ar_PS
109 mv translations/{de_DE,de}
110 mv translations/{es_ES,es}
111 rm -rf translations/fr
112 mv translations/{fr_FR,fr}
113 mv translations/{hr_HR,hr}
114 mv translations/{it_IT,it}
115 mv translations/{nl_NL,nl}
116 mv translations/{no,nb}
117 mv translations/{ru_RU,ru}
118
119 grep -r bin/env.*python -l . | xargs sed -i -e '1s,^#!.*env python,#!%{__python},'
120
121 %build
122 %{__python} setup.py configure \
123         --pidfile /var/run/wicd.pid \
124         --pmutils %{_libdir}/pm-utils/sleep.d
125
126 %{__python} setup.py build
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 %{__python} setup.py install \
131         --optimize=2 \
132         --root=$RPM_BUILD_ROOT
133
134 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/wicd
135
136 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
137 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
138 %py_postclean
139
140 %find_lang %{name}
141
142 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
143 rm -f $RPM_BUILD_ROOT/var/lib/%{name}/configurations/.empty_on_purpose
144 rm -f $RPM_BUILD_ROOT/var/log/%{name}/.empty_on_purpose
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post
150 /sbin/chkconfig --add %{name}
151 %service %{name} restart
152
153 %preun
154 if [ "$1" = "0" ]; then
155         %service -q %{name} stop
156         /sbin/chkconfig --del %{name}
157 fi
158
159 %files -f %{name}.lang
160 %defattr(644,root,root,755)
161 %doc AUTHORS CHANGES INSTALL README
162 %attr(755,root,root) %{_bindir}/wicd-client
163 %attr(755,root,root) %{_sbindir}/wicd
164 %attr(754,root,root) /etc/rc.d/init.d/%{name}
165 %{_mandir}/man5/wicd-manager-settings.conf.5*
166 %lang(nl) %{_mandir}/nl/man5/wicd-manager-settings.conf.5*
167 %{_mandir}/man5/wicd-wired-settings.conf.5*
168 %lang(nl) %{_mandir}/nl/man5/wicd-wired-settings.conf.5*
169 %{_mandir}/man5/wicd-wireless-settings.conf.5*
170 %lang(nl) %{_mandir}/nl/man5/wicd-wireless-settings.conf.5*
171 %{_mandir}/man8/wicd.8*
172 %lang(nl) %{_mandir}/nl/man8/wicd.8*
173 /etc/dbus-1/system.d/wicd.conf
174 %{_sysconfdir}/wicd
175 %{_sysconfdir}/xdg/autostart/wicd-tray.desktop
176 %dir %{_datadir}/%{name}
177 %dir %{_datadir}/%{name}/backends
178 %attr(755,root,root) %{_datadir}/%{name}/backends/*.py
179 %dir %{_datadir}/%{name}/daemon
180 %attr(755,root,root) %{_datadir}/%{name}/daemon/*.py
181 %dir %{py_sitescriptdir}/wicd
182 %{py_sitescriptdir}/wicd/*.py[co]
183 %{py_sitescriptdir}/Wicd-*.egg-info
184 %dir /var/lib/%{name}
185 %dir /var/lib/%{name}/configurations
186 /var/lib/%{name}/WHEREAREMYFILES
187 %dir /var/log/%{name}
188
189 %files client-cli
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_bindir}/wicd-cli
192 %dir %{_datadir}/%{name}/cli
193 %attr(755,root,root) %{_datadir}/%{name}/cli/*.py
194 %{_mandir}/man8/wicd-cli.8*
195
196 %files client-curses
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_bindir}/wicd-curses
199 %dir %{_datadir}/%{name}/curses
200 %attr(755,root,root) %{_datadir}/%{name}/curses/*.py
201 %{_mandir}/man8/wicd-curses.8*
202 %lang(nl) %{_mandir}/nl/man8/wicd-curses.8*
203
204 %files client-gtk
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{_bindir}/wicd-gtk
207 %dir %{_datadir}/%{name}/gtk
208 %{_datadir}/%{name}/gtk/%{name}.glade
209 %attr(755,root,root) %{_datadir}/%{name}/gtk/*.py
210 %{_datadir}/autostart/wicd-tray.desktop
211 %{_desktopdir}/wicd.desktop
212 %{_iconsdir}/hicolor/*/apps/wicd-gtk.*
213 %{_pixmapsdir}/%{name}
214 %{_pixmapsdir}/wicd-gtk.xpm
215 %{_mandir}/man1/wicd-client.1*
216 %lang(nl) %{_mandir}/nl/man1/wicd-client.1*
217
218 %files -n pm-utils-wicd
219 %defattr(644,root,root,755)
220 %attr(755,root,root) %{_libdir}/pm-utils/sleep.d/*wicd
This page took 0.052116 seconds and 4 git commands to generate.