]> git.pld-linux.org Git - packages/wicd.git/blob - wicd.spec
- pldize; rel 3
[packages/wicd.git] / wicd.spec
1 Summary:        wired and wireless network manager
2 Summary(pl.UTF-8):      Zarządca sieci przewodowych i bezprzewodowych
3 Name:           wicd
4 Version:        1.6.2.2
5 Release:        3
6 License:        GPL v2
7 Group:          X11/Applications/Networking
8 Source0:        http://dl.sourceforge.net/wicd/%{name}-%{version}.tar.gz
9 # Source0-md5:  acbbe695abf7ff83161c62317dfc7509
10 Source1:        %{name}.init
11 Patch0:         %{name}-init_status.patch
12 URL:            http://www.wicd.net/
13 # /etc/pld-release used to detect platform
14 BuildRequires:  issue
15 BuildRequires:  libiw-devel
16 BuildRequires:  python-devel
17 BuildRequires:  python-modules
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.228
20 Requires(post,preun):   /sbin/chkconfig
21 Requires:       dbus(org.freedesktop.Notifications)
22 Requires:       python-dbus
23 Requires:       python-pygobject
24 Requires:       python-pygtk-glade >= 2:2.0
25 Requires:       python-pygtk-gtk >= 2:2.0
26 Obsoletes:      wicd < 1.6.0
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Wicd is an open source wired and wireless network manager for Linux
31 which aims to provide a simple interface to connect to networks with a
32 wide variety of settings.
33
34 %description -l pl.UTF-8
35 Wicd jest zarządcą sieci przewodowych i bezprzewodowych dla Linuksa,
36 mającym zapewnić prosty interfejs do podłączania do sieci z
37 różnorakimi opcjami.
38
39 %package client-curses
40 Summary:        wicd console client
41 Summary(pl.UTF-8):      klient wicd dla konsoli
42 Group:          Applications/System
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       python-urwid
45
46 %description client-curses
47 wicd curses client.
48
49 %description client-curses -l pl.UTF-8
50 Klient wicd dla konsoli.
51
52 %package -n pm-utils-wicd
53 Summary:        wicd script for pm-utils
54 Summary(pl.UTF-8):      Skrypt wicd dla pm-utils
55 Group:          Applications/System
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       pm-utils
58
59 %description -n pm-utils-wicd
60 wicd script for pm-utils.
61
62 %description -n pm-utils-wicd -l pl.UTF-8
63 Skrypt wicd dla pm-utils.
64
65 %prep
66 %setup -q
67 %patch0 -p1
68
69 mv translations/{ar_EG,ar}
70 mv translations/{de_DE,de}
71 mv translations/{es_ES,es}
72 mv translations/{it_IT,it}
73 mv translations/{nl_NL,nl}
74 mv translations/{no,nb}
75 mv translations/{ru_RU,ru}
76
77 %build
78 %{__python} setup.py configure \
79         --backends %{_libdir}/%{name}/backends \
80         --lib %{_libdir}/%{name} \
81         --pidfile /var/run/wicd.pid \
82         --pmutils %{_libdir}/pm-utils/sleep.d
83
84 %{__python} setup.py build
85
86 cd depends/python-iwscan
87 %{__python} setup.py build
88 cd ../python-wpactrl
89 %{__python} setup.py build
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__python} setup.py install \
95         --optimize=2 \
96         --root=$RPM_BUILD_ROOT
97
98 cd depends/python-iwscan
99 %{__python} setup.py install \
100         --optimize=2 \
101         --root=$RPM_BUILD_ROOT
102
103 cd ../python-wpactrl
104 %{__python} setup.py install \
105         --optimize=2 \
106         --root=$RPM_BUILD_ROOT
107
108 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/wicd
109
110 cd ../..
111
112 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
113 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
114 %py_postclean
115
116 %find_lang %{name}
117
118 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post
124 /sbin/chkconfig --add %{name}
125 %service %{name} restart
126
127 %preun
128 if [ "$1" = "0" ]; then
129         %service -q %{name} stop
130         /sbin/chkconfig --del %{name}
131 fi
132
133 %files -f %{name}.lang
134 %defattr(644,root,root,755)
135 %doc AUTHORS CHANGES INSTALL README
136 %attr(755,root,root) %{_bindir}/wicd-client
137 %attr(755,root,root) %{_sbindir}/wicd
138 %attr(754,root,root) /etc/rc.d/init.d/%{name}
139 %{_mandir}/man1/wicd-client.1*
140 %{_mandir}/man5/wicd-manager-settings.conf.5*
141 %{_mandir}/man5/wicd-wired-settings.conf.5*
142 %{_mandir}/man5/wicd-wireless-settings.conf.5*
143 %{_mandir}/man8/wicd.8*
144 /etc/dbus-1/system.d/wicd.conf
145 %{_sysconfdir}/wicd
146 %{_sysconfdir}/xdg/autostart/wicd-tray.desktop
147
148 %dir %{_libdir}/%{name}
149 %dir %{_libdir}/%{name}/backends
150 %attr(755,root,root) %{_libdir}/%{name}/*.py
151 %attr(755,root,root) %{_libdir}/%{name}/backends/*.py
152 %exclude %{_libdir}/%{name}/*curses*.py
153
154 %{_datadir}/%{name}
155 %{_datadir}/autostart/wicd-tray.desktop
156
157 %{_desktopdir}/wicd.desktop
158 %{_iconsdir}/hicolor/*/apps/wicd-client.*
159 %{_pixmapsdir}/%{name}
160
161 %dir %{py_sitescriptdir}/wicd
162 %{py_sitescriptdir}/wicd/*.py[co]
163 %{py_sitescriptdir}/Wicd-*.egg-info
164
165 %{py_sitedir}/iwscan.so
166 %{py_sitedir}/wpactrl.so
167
168 %if "%{py_ver}" > "2.4"
169 %{py_sitedir}/iwscan-*.egg-info
170 %{py_sitedir}/wpactrl-*.egg-info
171 %endif
172
173 %dir /var/lib/%{name}
174 /var/lib/%{name}/WHEREAREMYFILES
175
176 %dir /var/log/%{name}
177
178 %files client-curses
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_bindir}/wicd-curses
181 %attr(755,root,root) %{_libdir}/%{name}/*curses*.py
182 %{_mandir}/man8/wicd-curses.8*
183
184 %files -n pm-utils-wicd
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_libdir}/pm-utils/sleep.d/*wicd
This page took 0.604247 seconds and 4 git commands to generate.