]> git.pld-linux.org Git - packages/wicd.git/blob - wicd.spec
- X11 Group, unified sf URL, pygtk version
[packages/wicd.git] / wicd.spec
1 # TODO: Needs review
2 # TODO: Fix daemon status and stop (wicd dead but subsys locked but daemon running)
3 Summary:        wired and wireless network manager
4 Summary(pl.UTF-8):      Zarządca sieci przewodowych i bezprzewodowych
5 Name:           wicd
6 Version:        1.5.1
7 Release:        5
8 License:        GPL v2
9 Group:          X11/Applications
10 Source0:        http://dl.sourceforge.net/wicd/%{name}-%{version}.tar.gz
11 # Source0-md5:  dda372b0778de24552850d3d877d1b65
12 URL:            http://wicd.net/
13 BuildRequires:  issue
14 BuildRequires:  python-modules
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  rpmbuild(macros) >= 1.228
17 Requires(post,preun):   /sbin/chkconfig
18 Requires:       python-dbus
19 Requires:       python-pygobject
20 Requires:       python-pygtk-glade >= 2:2.0
21 Requires:       python-pygtk-gtk >= 2:2.0
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Wicd is an open source wired and wireless network manager for Linux
27 which aims to provide a simple interface to connect to networks with a
28 wide variety of settings.
29
30 %description -l pl.UTF-8
31 Wicd jest zarządcą sieci który stara się dostarczyć prosty
32 interfejs do podłączania do sieci z różnorakimi opcjami.
33
34 %prep
35 %setup -q
36 %{__python} setup.py configure
37
38 %build
39 %{__python} setup.py build
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 %{__python} setup.py install \
44         --optimize=2 \
45         --root=$RPM_BUILD_ROOT
46
47 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
48 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
49 %py_postclean
50
51 %find_lang %{name}
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 /sbin/chkconfig --add %{name}
58 %service %{name} restart
59
60 %preun
61 if [ "$1" = "0" ]; then
62         %service -q %{name} stop
63         /sbin/chkconfig --del %{name}
64 fi
65
66 %files -f %{name}.lang
67 %defattr(644,root,root,755)
68 %doc AUTHORS README
69 %attr(755,root,root) %{_bindir}/wicd-client
70 %attr(755,root,root) %{_sbindir}/wicd
71 # NOTE: must be in /usr/lib even on 64bit systems
72 %{_prefix}/lib/%{name}
73 %attr(755,root,root) %{_prefix}/lib/%{name}/*.py
74 %dir %{py_sitescriptdir}/wicd
75 %{py_sitescriptdir}/wicd*.py[co]
76 %{py_sitescriptdir}/*.egg-info
77 %{_datadir}/%{name}
78 %{_datadir}/autostart/wicd-tray.desktop
79 %{_desktopdir}/wicd.desktop
80 %{_iconsdir}/hicolor/*/apps/wicd-client.*
81 %{_pixmapsdir}/%{name}
82 %{_sysconfdir}/wicd
83 %{_sysconfdir}/xdg/autostart/wicd-tray.desktop
84 /etc/dbus-1/system.d/wicd.conf
85 %attr(754,root,root) /etc/rc.d/init.d/%{name}
86 /var/lib/%{name}
87 /var/log/%{name}
88 %{_mandir}/man5/wicd-manager-settings.conf.5*
89 %{_mandir}/man5/wicd-wired-settings.conf.5*
90 %{_mandir}/man5/wicd-wireless-settings.conf.5*
91 %{_mandir}/man8/wicd.8*
This page took 0.036365 seconds and 4 git commands to generate.