]> git.pld-linux.org Git - packages/wicd.git/blob - wicd.spec
941010f1319829080fc15c7dc470f421f7a61cf8
[packages/wicd.git] / wicd.spec
1 Summary:        wired and wireless network manager
2 Summary(pl.UTF-8):      Zarządca sieci przewodowych i bezprzewodowych
3 Name:           wicd
4 Version:        1.6.2
5 Release:        3
6 License:        GPL v2
7 Group:          X11/Applications
8 Source0:        http://dl.sourceforge.net/wicd/%{name}-%{version}.tar.gz
9 # Source0-md5:  29c418355610574e35490e340198ce08
10 Patch0:         %{name}-init_status.patch
11 URL:            http://wicd.net/
12 # /etc/pld-release used to detect platform
13 BuildRequires:  issue
14 BuildRequires:  python-devel
15 BuildRequires:  python-modules
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.228
18 Requires(post,preun):   /sbin/chkconfig
19 Requires:       python-dbus
20 Requires:       python-pygobject
21 Requires:       python-pygtk-glade >= 2:2.0
22 Requires:       python-pygtk-gtk >= 2:2.0
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Wicd is an open source wired and wireless network manager for Linux
27 which aims to provide a simple interface to connect to networks with a
28 wide variety of settings.
29
30 %description -l pl.UTF-8
31 Wicd jest zarządcą sieci przewodowych i bezprzewodowych dla Linuksa,
32 mającym zapewnić prosty interfejs do podłączania do sieci z
33 różnorakimi opcjami.
34
35 %package client-curses
36 Summary:        wicd console client
37 Summary(pl.UTF-8):      klient wicd dla konsoli
38 Group:          Applications/System
39 Requires:       %{name} = %{version}-%{release}
40 Requires:       python-urwid
41
42 %description client-curses
43 wicd curses client.
44
45 %description client-curses -l pl.UTF-8
46 Klient wicd dla konsoli.
47
48 %package -n pm-utils-wicd
49 Summary:        wicd script for pm-utils
50 Summary(pl.UTF-8):      Skrypt wicd dla pm-utils
51 Group:          Applications/System
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       pm-utils
54
55 %description -n pm-utils-wicd
56 wicd script for pm-utils.
57
58 %description -n pm-utils-wicd -l pl.UTF-8
59 Skrypt wicd dla pm-utils.
60
61 %prep
62 %setup -q
63 %patch0 -p1
64
65 mv -f translations/{ar_EG,ar}
66 mv -f translations/{de_DE,de}
67 mv -f translations/{es_ES,es}
68 mv -f translations/{it_IT,it}
69 mv -f translations/{nl_NL,nl}
70 mv -f translations/{no,nb}
71 mv -f translations/{ru_RU,ru}
72
73 %{__python} setup.py configure \
74         --backends %{_libdir}/%{name}/backends \
75         --lib %{_libdir}/%{name} \
76         --pidfile /var/run/wicd.pid \
77         --pmutils %{_libdir}/pm-utils/sleep.d
78
79 %build
80 %{__python} setup.py build
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 %{__python} setup.py install \
85         --optimize=2 \
86         --root=$RPM_BUILD_ROOT
87
88 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
89 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
90 %py_postclean
91
92 %find_lang %{name}
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post
98 /sbin/chkconfig --add %{name}
99 %service %{name} restart
100
101 %preun
102 if [ "$1" = "0" ]; then
103         %service -q %{name} stop
104         /sbin/chkconfig --del %{name}
105 fi
106
107 %files -f %{name}.lang
108 %defattr(644,root,root,755)
109 %doc AUTHORS README
110 %attr(755,root,root) %{_bindir}/wicd-client
111 %attr(755,root,root) %{_sbindir}/wicd
112 #% {_sysconfdir}/acpi/resume.d/80-wicd-connect.sh
113 #% {_sysconfdir}/acpi/suspend.d/50-wicd-suspend.sh
114
115 %{_sysconfdir}/dbus-1/system.d/wicd.conf
116 %{_sysconfdir}/wicd
117 %{_sysconfdir}/xdg/autostart/wicd-tray.desktop
118 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
119
120 %dir %{_libdir}/%{name}
121 %dir %{_libdir}/%{name}/backends
122 %attr(755,root,root) %{_libdir}/%{name}/*.py
123 %attr(755,root,root) %{_libdir}/%{name}/backends/*.py
124 %exclude %{_libdir}/%{name}/*curses*.py
125
126 %dir %{py_sitescriptdir}/wicd
127 %{py_sitescriptdir}/wicd/*.py[co]
128 %{py_sitescriptdir}/Wicd-*.egg-info
129
130 %{_datadir}/%{name}
131 %{_datadir}/autostart/wicd-tray.desktop
132
133 %{_desktopdir}/wicd.desktop
134 %{_iconsdir}/hicolor/*/apps/wicd-client.*
135 %{_pixmapsdir}/%{name}
136
137 /var/log/%{name}
138
139 %{_mandir}/man1/wicd-client.1*
140 %{_mandir}/man5/wicd-manager-settings.conf.5*
141 %{_mandir}/man5/wicd-wired-settings.conf.5*
142 %{_mandir}/man5/wicd-wireless-settings.conf.5*
143 %{_mandir}/man8/wicd.8*
144
145 %files client-curses
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_bindir}/wicd-curses
148 %attr(755,root,root) %{_libdir}/%{name}/*curses*.py
149 %{_mandir}/man8/wicd-curses.8*
150
151 %files -n pm-utils-wicd
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_libdir}/pm-utils/sleep.d/*wicd
This page took 0.039993 seconds and 3 git commands to generate.