]> git.pld-linux.org Git - SPECS.git/blob - wget.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / wget.spec
1 # TODO
2 # - add --delete-remote patches:
3 #  - http://wget-bugs.ferrara.linux.it/issue9
4 #  - or http://osdir.com/ml/web.wget.patches/2005-09/msg00006.html
5 # - add http://article.gmane.org/gmane.comp.web.wget.patches/2333
6 #
7 # Conditional build:
8 %bcond_without  tests   # check target
9 %bcond_without  metalink # build without metalink support
10 %bcond_with     gnutls  # use GnuTLS (wget default) instead of OpenSSL
11
12 Summary:        A utility for retrieving files using the HTTP or FTP protocols
13 Summary(es.UTF-8):      Cliente en línea de comando para bajar archivos WWW/FTP con recursión opcional
14 Summary(fr.UTF-8):      Un utilitaire pour recuperer des fichiers en utilisant les protocoles HTTP ou FTP
15 Summary(pl.UTF-8):      Wsadowy klient HTTP/FTP
16 Summary(pt_BR.UTF-8):   Cliente na linha de comando para baixar arquivos WWW/FTP com recursão opcional
17 Summary(ru.UTF-8):      Утилита для получения файлов по протоколам HTTP и FTP
18 Summary(uk.UTF-8):      Утиліта для отримання файлів по протоколам HTTP та FTP
19 Summary(zh_CN.UTF-8):   [通讯]功能强大的下载程序,支持断点续传
20 Name:           wget
21 Version:        1.21.1
22 Release:        2
23 License:        GPL v3+ with OpenSSL exception
24 Group:          Networking/Utilities
25 Source0:        http://ftp.gnu.org/gnu/wget/%{name}-%{version}.tar.lz
26 # Source0-md5:  727157baf52b0071eaa353e6ff1c8269
27 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
28 # Source1-md5:  d8b2b56ec7461606c22edbafaf8a418f
29 Patch0:         %{name}-info.patch
30 Patch1:         %{name}-wgetrc_path.patch
31 Patch2:         %{name}-home_etc.patch
32 Patch3:         %{name}-ssl-certs.patch
33 Patch4:         user.xdg.origin.url.patch
34 Patch5:         %{name}-largefile_32bit.patch
35 URL:            http://www.gnu.org/software/wget/
36 BuildRequires:  autoconf >= 2.64
37 BuildRequires:  automake >= 1:1.9
38 BuildRequires:  gettext-tools >= 0.19.8
39 # >= 3.6.3 for TLSv1.3
40 %{?with_gnutls:BuildRequires:   gnutls-devel >= 3.0.16}
41 %{?with_metalink:BuildRequires: gpgme-devel >= 0.4.2}
42 BuildRequires:  libidn2-devel
43 %{?with_metalink:BuildRequires: libmetalink-devel}
44 BuildRequires:  libpsl-devel >= 0.16.0
45 BuildRequires:  libuuid-devel
46 # >= 1.1.0 for TLSv1.3
47 %{!?with_gnutls:BuildRequires:  openssl-devel >= 1.0.1}
48 BuildRequires:  pcre2-8-devel
49 BuildRequires:  perl-devel
50 BuildRequires:  pkgconfig
51 BuildRequires:  tar >= 1:1.22
52 BuildRequires:  texinfo
53 BuildRequires:  xz
54 BuildRequires:  zlib-devel
55 %if %{with tests}
56 BuildRequires:  perl-HTTP-Daemon
57 BuildRequires:  perl-HTTP-Message
58 BuildRequires:  perl-IO-Socket-SSL
59 BuildRequires:  python3-modules >= 1:3.0
60 %endif
61 Provides:       webclient
62 %{?with_gnutls:Requires:        gnutls-libs >= 3.0.16}
63 %{!?with_gnutls:Requires:       openssl >= 1.0.1}
64 Requires:       libpsl >= 0.16.0
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %define         _noautoreqfiles         %{_bindir}/rmold
68
69 %description
70 GNU Wget is a file retrieval utility which can use either the HTTP or
71 FTP protocols. Wget features include the ability to work in the
72 background while you're logged out, recursive retrieval of
73 directories, file name wildcard matching, remote file timestamp
74 storage and comparison, use of Rest with FTP servers and Range with
75 HTTP servers to retrieve files over slow or unstable connections,
76 support for Proxy servers, and configurability.
77
78 %description -l es.UTF-8
79 GNU wget es una herramienta de red para bajar archivos usando HTTP y
80 FTP. Funciona en modo no interactivo, pudiendo trabajar en background.
81 Funciona muy bien, incluso en conexiones lentas o inestables, bajando
82 el archivo hasta que sea completamente recibido.
83
84 %description -l fr.UTF-8
85 GNU Wget est un utilitaire pour récupérer des fichiers qui peut
86 utiliser indifféremment les protocoles HTTP ou FTP. Parmi les
87 caractéristiques de Wget, citons la capacité à récupérer des fichiers
88 en arrière-plan alors que vous n'êtes pas connecté, la récupération
89 récursive de répertoires, la capacité de récupérer des fichiers en
90 appliquant un filtre sur le nom ou sur la date, la gestion de Rest
91 avec les serveurs FTP et de Range avec les serveurs HTTP pour
92 récupérer des fichiers avec une connexion lente ou instable, le
93 support des serveurs Proxy... Wget est particulièrement configurable.
94
95 %description -l ja.UTF-8
96 GNU wget は HTTP か FTP プロトコルのどちらかを使用することができる
97 ファイルを取得するユーティリティです。wget はログアウトしている
98 間にバックグラウンドで働く特徴をもっていること、ディレクトリの再帰的
99 取得、ファイルネームのワイルドカードマッチング、ファイルのタイムスタンプの
100 保存と比較、遅く不安定な接続で FTP サーバの Rest と HTTP サーバの
101 Range の使用、プロキシーサーバのサポートと設定の容易さを含んだ特徴を
102 もっています。
103
104 %description -l pl.UTF-8
105 Wget jest klientem FTP/HTTP przeznaczonym do ściągania zasobów
106 wsadowo. Umożliwia ściąganie zasobów z podkatalogami, a także ma opcje
107 umożliwiające wykonanie lokalnej kopii zasobów (mirror). W razie
108 niemożności dostania się do zasobów lub gdy połączenie z serwerem
109 FTP/HTTP zostanie zerwane, może automatycznie ponawiać próby
110 kopiowania. Jest także dobrze przystosowany do tego, żeby uruchamiać
111 go jako zadanie z crona.
112
113 %description -l pt_BR.UTF-8
114 O GNU wget é uma ferramenta de rede para baixar arquivos usando HTTP e
115 FTP. Ele funciona em modo não interativo, podendo trabalhar em
116 background. Funciona muito bem, mesmo em conexões lentas ou instáveis,
117 baixando o arquivo até que ele seja completamente recebido.
118
119 %description -l ru.UTF-8
120 GNU Wget - это утилита командной строки для получения файлов по
121 протоколам FTP и HTTP. Среди возможностей Wget - работа в фоновом
122 режиме когда вы выходите из системы, рекурсивное извлечение каталогов,
123 выбор файлов по шаблону, сравнение времени удаленных и локальных
124 файлов, сохранение времени удаленных файлов при загрузке,
125 использование REST с FTP серверами и Range с HTTP серверами для
126 загрузки файлов по медленным или нестабильным каналам, поддержка Proxy
127 серверов, конфигурируемость.
128
129 %description -l uk.UTF-8
130 GNU Wget - це утиліта командного рядка для отримання файлів по
131 протоколам FTP та HTTP. Серед можливостей Wget - робота в фоновому
132 режимі коли ви виходите із системи, рекурсивне отримання каталогів,
133 вибір файлів по шаблону, порівняння часу віддалених та локальних
134 файлів, збереження часу віддалених файлів при завантаженні,
135 використання REST з FTP серверами та Range з HTTP серверами для
136 завантаження файлів по повільним чи нестабільним каналам, підтримка
137 Proxy серверів, настроюваність.
138
139 %prep
140 %setup -q
141 %patch0 -p1
142 %patch1 -p1
143 %patch2 -p1
144 %patch3 -p1
145 %patch4 -p1
146 %patch5 -p1
147
148 %{__rm} doc/wget.info doc/sample.wgetrc.munged_for_texi_inclusion po/stamp-po
149
150 # temp hack for 1.13.4
151 test -e build-aux/bzr-version-gen || cat <<EOF > build-aux/bzr-version-gen
152 #!/bin/sh
153 echo -n %{version}
154 EOF
155 chmod +x build-aux/bzr-version-gen
156
157 %{__sed} -i -e '1s,/usr/bin/env perl,%{__perl},' util/rmold.pl
158
159 %build
160 %{__gettextize}
161 %{__aclocal} -I m4
162 %{__autoheader}
163 %{__autoconf}
164 %{__automake}
165 %configure \
166         --enable-digest \
167         --enable-ipv6 \
168         --enable-iri \
169         --enable-largefile \
170         --enable-nls \
171         --enable-ntlm \
172         --enable-opie \
173         --enable-pcre \
174         --disable-silent-rules \
175         --with-libpsl \
176         %{__with_without metalink} \
177         --with-ssl%{!?with_gnutls:=openssl} \
178         --with-zlib \
179         %{nil}
180 %{__make}
181 tail -n 6 util/README >rmold.README
182
183 # 1.13.4 tarball was buggy and produced empty version.
184 grep %{version} src/version.c
185
186 %{?with_tests:%{__make} check}
187
188 %install
189 rm -rf $RPM_BUILD_ROOT
190 install -d $RPM_BUILD_ROOT%{_sysconfdir}
191
192 %{__make} install \
193         DESTDIR=$RPM_BUILD_ROOT \
194         GETTEXT_PACKAGE=wget
195
196 install -p util/rmold.pl $RPM_BUILD_ROOT%{_bindir}/rmold
197 cp -a doc/sample.wgetrc $RPM_BUILD_ROOT%{_sysconfdir}/wgetrc
198
199 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
200 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README*
201 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
202
203 # "wget" and "wget-gnulib" domains
204 %find_lang %{name} --all-name
205
206 %clean
207 rm -rf $RPM_BUILD_ROOT
208
209 %post   -p /sbin/postshell
210 -/usr/sbin/fix-info-dir -c %{_infodir}
211
212 %postun -p /sbin/postshell
213 -/usr/sbin/fix-info-dir -c %{_infodir}
214
215 %files -f %{name}.lang
216 %defattr(644,root,root,755)
217 %doc AUTHORS ChangeLog NEWS README MAILING-LIST rmold.README
218 %verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/wgetrc
219 %attr(755,root,root) %{_bindir}/rmold
220 %attr(755,root,root) %{_bindir}/wget
221 %{_mandir}/man1/wget.1*
222 %{_mandir}/hu/man1/wget.1*
223 %{_mandir}/pl/man1/wget.1*
224 %{_infodir}/wget.info*
This page took 1.409306 seconds and 3 git commands to generate.