]> git.pld-linux.org Git - packages/weston.git/blob - weston.spec
a92e090314b6db13c279a0652a89de38415d3033
[packages/weston.git] / weston.spec
1 #
2 # Conditional build:
3 %bcond_without  drm             # DRM compositor
4 %bcond_without  rdp             # RDP compositor (needs freerdp2 or freerdp >= 1.1.0)
5 %bcond_without  wayland         # wayland (nested) compositor
6 %bcond_without  x11             # X11 compositor
7 %bcond_without  libunwind       # libunwind usage for backtraces
8 %bcond_without  vaapi           # vaapi recorder
9 %bcond_without  wlaunch         # weston launch
10 %bcond_without  xwayland        # X server launcher
11 %bcond_without  sclients        # simple clients
12 %bcond_without  clients         # non-simple clients
13 %bcond_with     glclients       # full GL clients [require cairo-gl/cairo-egl]
14
15 Summary:        Weston - Wayland demos
16 Summary(pl.UTF-8):      Weston - programy demonstracyjne dla protokołu Wayland
17 Name:           weston
18 Version:        3.0.0
19 Release:        1
20 License:        MIT
21 Group:          Applications
22 Source0:        https://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
23 # Source0-md5:  9c42a4c51a1b9f35d040fa9d45ada36d
24 URL:            https://wayland.freedesktop.org/
25 BuildRequires:  Mesa-libEGL-devel >= 7.10
26 # GLESv2
27 BuildRequires:  Mesa-libGLES-devel
28 # for wayland and sclients, but also desktop-shell, which is always enabled
29 BuildRequires:  Mesa-libwayland-egl-devel >= 9.0-2
30 BuildRequires:  autoconf >= 2.64
31 BuildRequires:  automake >= 1:1.11
32 BuildRequires:  cairo-devel >= 1.10.0
33 BuildRequires:  colord-devel >= 0.1.27
34 BuildRequires:  dbus-devel >= 1.6
35 BuildRequires:  doxygen
36 # or freerdp >= 1.1.0
37 %{?with_rdp:BuildRequires:      freerdp2-devel >= 2.0.0}
38 BuildRequires:  lcms2-devel >= 2
39 BuildRequires:  libinput-devel >= 0.8.0
40 BuildRequires:  libjpeg-devel
41 BuildRequires:  libpng-devel
42 BuildRequires:  libtool >= 2:2.2
43 %{?with_libunwind:BuildRequires:        libunwind-devel}
44 BuildRequires:  libwebp-devel
45 BuildRequires:  pixman-devel >= 0.26
46 BuildRequires:  pkgconfig
47 BuildRequires:  tar >= 1:1.22
48 # wayland-server always; wayland-client if with_wayland || with_sclients || with_clients; wayland-cursor if with_clients
49 BuildRequires:  wayland-devel >= 1.12.0
50 BuildRequires:  wayland-protocols >= 1.8
51 BuildRequires:  xorg-lib-libxkbcommon-devel >= 0.5.0
52 BuildRequires:  xz
53 %if %{with drm}
54 BuildRequires:  Mesa-libgbm-devel >= 10.2
55 BuildRequires:  libdrm-devel >= 2.4.30
56 BuildRequires:  mtdev-devel >= 1.1.0
57 BuildRequires:  udev-devel >= 1:136
58 %endif
59 %if %{with vaapi}
60 BuildRequires:  libva-devel >= 1.2.0
61 BuildRequires:  libva-drm-devel >= 1.2.0
62 # API versions
63 BuildRequires:  pkgconfig(libva) >= 0.34.0
64 BuildRequires:  pkgconfig(libva-drm) >= 0.34.0
65 %endif
66 %if %{with x11}
67 BuildRequires:  libxcb-devel >= 1.8
68 BuildRequires:  xorg-lib-libX11-devel
69 %endif
70 %if %{with wlaunch}
71 BuildRequires:  libdrm-devel
72 BuildRequires:  pam-devel
73 BuildRequires:  systemd-devel >= 1:209
74 %endif
75 %if %{with xwayland}
76 BuildRequires:  glib2-devel >= 1:2.36
77 # xcb xcb-composite xcb-xfixes
78 BuildRequires:  libxcb-devel
79 BuildRequires:  pango-devel >= 1:1.10
80 BuildRequires:  pkgconfig(cairo-xcb)
81 BuildRequires:  xorg-lib-libXcursor-devel
82 %endif
83 %if %{with clients}
84 BuildRequires:  OpenGL-GLU-devel
85 BuildRequires:  cairo-devel >= 1.11.3
86 %if %{with glclients}
87 BuildRequires:  pkgconfig(cairo-egl) >= 1.11.3
88 BuildRequires:  pkgconfig(cairo-gl)
89 %endif
90 %endif
91 Requires:       %{name}-libs = %{version}-%{release}
92 %if %{with clients}
93 Requires:       cairo >= 1.11.3
94 %endif
95 Requires:       colord-libs >= 0.1.27
96 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
97
98 %description
99 Weston contains a few demo application for the Wayland project.
100 There's a sample compositor that can run on KMS, under X11 or under
101 another Wayland compositor and there's a handful of simple clients
102 that demonstrate various aspects of Wayland.
103
104 %description -l pl.UTF-8
105 Weston zawiera kilka aplikacji demonstracyjnych dla projektu Wayland.
106 Jest przykładowy serwer składający, który można uruchomić pod KMS, pod
107 X11 lub pod innym serwerem składającym Wayland; są także proste
108 programy klienckie demonstrujące różne aspekty protokołu Wayland.
109
110 %package devel
111 Summary:        Header files for Weston plugin development
112 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia wtyczek dla Westona
113 Group:          Development/Libraries
114 Requires:       %{name}-libs-devel = %{version}-%{release}
115 Requires:       Mesa-libEGL-devel >= 7.10
116 # GLESv2
117 Requires:       Mesa-libGLES-devel
118
119 %description devel
120 Header files for Weston plugin development.
121
122 %description devel -l pl.UTF-8
123 Pliki nagłówkowe do tworzenia wtyczek dla Westona.
124
125 %package libs
126 Summary:        Weston compositor libraries
127 Summary(pl.UTF-8):      Biblioteki serwera składania Weston
128 Group:          Libraries
129 Requires:       wayland >= 1.12.0
130 Requires:       pixman >= 0.26
131 Requires:       xorg-lib-libxkbcommon >= 0.5.0
132 # the rest is for modules:
133 Requires:       Mesa-libEGL >= 7.10
134 %{?with_drm:Requires:   Mesa-libgbm >= 10.2}
135 Requires:       Mesa-libwayland-egl >= 9.0-2
136 Requires:       cairo >= 1.10.0
137 Requires:       dbus-libs >= 1.6
138 %{?with_drm:Requires:   libdrm >= 2.4.30}
139 Requires:       libinput >= 0.8.0
140 %if %{with vaapi}
141 Requires:       libva >= 1.2.0
142 Requires:       libva-drm >= 1.2.0
143 %endif
144 %{?with_x11:Requires:   libxcb >= 1.8}
145 %{?with_drm:Requires:   mtdev >= 1.1.0}
146 %{?with_wlaunch:Requires:       systemd-libs >= 1:209}
147 %{?with_drm:Requires:   udev-libs >= 1:136}
148
149 %description libs
150 Weston compositor libraries.
151
152 %description libs -l pl.UTF-8
153 Biblioteki serwera składania Weston.
154
155 %package libs-devel
156 Summary:        Header files for libweston compositors development
157 Summary(pl.UTF-8):      Pliki nagłówkowe do rozwijania modułów składających biblioteki libweston
158 Group:          Development/Libraries
159 Requires:       %{name}-libs = %{version}-%{release}
160 Requires:       pixman-devel >= 0.26 
161 # wayland-server
162 Requires:       wayland-devel >= 1.12.0
163 Requires:       xorg-lib-libxkbcommon-devel >= 0.5.0
164
165 %description libs-devel
166 Header files for libweston compositors development.
167
168 %description libs-devel -l pl.UTF-8
169 Pliki nagłówkowe do rozwijania modułów składających biblioteki
170 libweston.
171
172 %package compositor-rdp
173 Summary:        RDP compositor plugin for Weston
174 Summary(pl.UTF-8):      Wtyczka składająca RDP dla Westona
175 Group:          Libraries
176 Requires:       %{name} = %{version}-%{release}
177 Requires:       freerdp2 >= 2.0.0
178
179 %description compositor-rdp
180 RDP compositor plugin for Weston.
181
182 %description compositor-rdp -l pl.UTF-8
183 Wtyczka składająca RDP dla Westona.
184
185 %prep
186 %setup -q
187
188 %build
189 %{__libtoolize}
190 %{__aclocal} -I m4
191 %{__autoconf}
192 %{__autoheader}
193 %{__automake}
194 %configure \
195         %{!?with_clients:--disable-clients} \
196         %{!?with_drm:--disable-drm-compositor} \
197         %{!?with_libunwind:--disable-libunwind} \
198         %{?with_rdp:--enable-rdp-compositor} \
199         %{!?with_sclients:--disable-simple-clients} \
200         --disable-setuid-install \
201         --disable-silent-rules \
202         %{!?with_vaapi:--disable-vaapi-recorder} \
203         %{!?with_wlaunch:--disable-weston-launch} \
204         %{!?with_x11:--disable-x11-compositor} \
205         %{!?with_xwayland:--disable-xwayland} \
206         %{?with_glclients:--with-cairo=gl}
207 %{__make}
208
209 %install
210 rm -rf $RPM_BUILD_ROOT
211
212 %{__make} install \
213         DESTDIR=$RPM_BUILD_ROOT
214
215 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libweston-*.la
216 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libweston-3/*.la \
217         $RPM_BUILD_ROOT%{_libdir}/weston/*.la
218
219 %clean
220 rm -rf $RPM_BUILD_ROOT
221
222 %post   libs -p /sbin/ldconfig
223 %postun libs -p /sbin/ldconfig
224
225 %files
226 %defattr(644,root,root,755)
227 %doc README
228 %attr(755,root,root) %{_bindir}/wcap-decode
229 # composer
230 %attr(755,root,root) %{_bindir}/weston
231 %if %{with wlaunch}
232 %attr(755,root,root) %{_bindir}/weston-launch
233 %endif
234 %if %{with clients}
235 %attr(755,root,root) %{_bindir}/weston-info
236 %attr(755,root,root) %{_bindir}/weston-terminal
237 %attr(755,root,root) %{_libexecdir}/weston-desktop-shell
238 %attr(755,root,root) %{_libexecdir}/weston-keyboard
239 %attr(755,root,root) %{_libexecdir}/weston-screenshooter
240 %attr(755,root,root) %{_libexecdir}/weston-simple-im
241 %endif
242 %dir %{_libdir}/weston
243 %attr(755,root,root) %{_libdir}/weston/cms-colord.so
244 %attr(755,root,root) %{_libdir}/weston/cms-static.so
245 %attr(755,root,root) %{_libdir}/weston/desktop-shell.so
246 %attr(755,root,root) %{_libdir}/weston/fullscreen-shell.so
247 # ivi shell
248 %if %{with clients}
249 %attr(755,root,root) %{_libexecdir}/weston-ivi-shell-user-interface
250 %endif
251 %attr(755,root,root) %{_libdir}/weston/hmi-controller.so
252 %attr(755,root,root) %{_libdir}/weston/ivi-shell.so
253 %{_datadir}/weston
254 %dir %{_datadir}/wayland-sessions
255 %{_datadir}/wayland-sessions/weston.desktop
256 %{_mandir}/man1/weston.1*
257 %{_mandir}/man5/weston.ini.5*
258 %{_mandir}/man7/weston-drm.7*
259
260 # noinst by default - --enable-demo-clients and package in %{name}-demos?
261 # "simple clients"
262 #%attr(755,root,root) %{_bindir}/weston-multi-resource
263 #%attr(755,root,root) %{_bindir}/weston-simple-egl
264 #%attr(755,root,root) %{_bindir}/weston-simple-shm
265 #%attr(755,root,root) %{_bindir}/weston-simple-touch
266 %if %{with clients}
267 #%attr(755,root,root) %{_bindir}/weston-calibrator
268 #%attr(755,root,root) %{_bindir}/weston-clickdot
269 #%attr(755,root,root) %{_bindir}/weston-cliptest
270 #%attr(755,root,root) %{_bindir}/weston-dnd
271 #%attr(755,root,root) %{_bindir}/weston-editor
272 #%attr(755,root,root) %{_bindir}/weston-eventdemo
273 #%attr(755,root,root) %{_bindir}/weston-flower
274 #%attr(755,root,root) %{_bindir}/weston-fullscreen
275 #%attr(755,root,root) %{_bindir}/weston-image
276 #%attr(755,root,root) %{_bindir}/weston-resizor
277 #%attr(755,root,root) %{_bindir}/weston-scaler
278 #%attr(755,root,root) %{_bindir}/weston-smoke
279 #%attr(755,root,root) %{_bindir}/weston-stacking
280 #%attr(755,root,root) %{_bindir}/weston-transformed
281 %if %{with glclients}
282 # "full GL" clients
283 #%attr(755,root,root) %{_bindir}/weston-gears
284 %endif
285 %endif
286
287 %files devel
288 %defattr(644,root,root,755)
289 %{_includedir}/weston
290 %{_pkgconfigdir}/weston.pc
291
292 %files libs
293 %defattr(644,root,root,755)
294 %attr(755,root,root) %{_libdir}/libweston-3.so.*.*.*
295 %attr(755,root,root) %ghost %{_libdir}/libweston-3.so.0
296 %attr(755,root,root) %{_libdir}/libweston-desktop-3.so.*.*.*
297 %attr(755,root,root) %ghost %{_libdir}/libweston-desktop-3.so.0
298 %dir %{_libdir}/libweston-3
299 %if %{with drm}
300 %attr(755,root,root) %{_libdir}/libweston-3/drm-backend.so
301 %endif
302 %attr(755,root,root) %{_libdir}/libweston-3/fbdev-backend.so
303 %attr(755,root,root) %{_libdir}/libweston-3/gl-renderer.so
304 %attr(755,root,root) %{_libdir}/libweston-3/headless-backend.so
305 %if %{with wayland}
306 %attr(755,root,root) %{_libdir}/libweston-3/wayland-backend.so
307 %endif
308 %if %{with x11}
309 %attr(755,root,root) %{_libdir}/libweston-3/x11-backend.so
310 %endif
311 %if %{with xwayland}
312 %attr(755,root,root) %{_libdir}/libweston-3/xwayland.so
313 %endif
314
315 %files libs-devel
316 %defattr(644,root,root,755)
317 %attr(755,root,root) %{_libdir}/libweston-3.so
318 %attr(755,root,root) %{_libdir}/libweston-desktop-3.so
319 %{_includedir}/libweston-3
320 %{_pkgconfigdir}/libweston-3.pc
321 %{_pkgconfigdir}/libweston-desktop-3.pc
322
323 %if %{with rdp}
324 %files compositor-rdp
325 %defattr(644,root,root,755)
326 %attr(755,root,root) %{_libdir}/libweston-3/rdp-backend.so
327 %endif
This page took 0.073154 seconds and 3 git commands to generate.