]> git.pld-linux.org Git - projects/template-specs.git/blob - webapp.spec
- mention webserver(rewrite)
[projects/template-specs.git] / webapp.spec
1 Summary:        Package that uses webapps configuration
2 Summary(pl.UTF-8):      Pakiet używający konfiguracji aplikacji WWW
3 Name:           template-webapp
4 Version:        0.3
5 Release:        0.3
6 License:        GPL
7 Group:          Applications/WWW
8 #Source0:       %{name}-%{version}.tar.gz
9 # Source0-md5:  -
10 Source1:        apache.conf
11 Source2:        lighttpd.conf
12 #URL:           -
13 BuildRequires:  rpmbuild(macros) >= 1.268
14 Requires:       webapps
15 # see packages/webapps/webapps.README for description and complete listing
16 #Requires:      webserver(access)
17 #Requires:      webserver(alias)
18 #Requires:      webserver(auth)
19 #Requires:      webserver(cgi)
20 #Requires:      webserver(indexfile)
21 #Requires:      webserver(php)
22 #Requires:      webserver(rewrite)
23 #Requires:      webserver(setenv)
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _webapps        /etc/webapps
28 %define         _webapp         %{name}
29 %define         _sysconfdir     %{_webapps}/%{_webapp}
30 #%define                _appdir         %{_datadir}/%{_webapp}
31
32 # in case _sysconfdir is not in webapps dir, run this replace pattern
33 # before copy-pasting to your spec: :%s#%{_sysconfdir}#%{_webapps}/%{_webapp}#g
34
35 %description
36 This .spec is for demonstrating triggers used for linking webapp
37 configuration to webserver config dir.
38
39 %description -l pl.UTF-8
40 Ten plik .spec służy do pokazania triggerów służących do podłączania
41 konfiguracji aplikacji WWW do katalogu konfiguracyjnego serwera WWW.
42
43 %prep
44 %setup -q
45
46 cat > apache.conf <<'EOF'
47 Alias /%{name} %{_appdir}
48 <Directory %{_appdir}>
49         Allow from all
50 </Directory>
51 EOF
52
53 cat > lighttpd.conf <<'EOF'
54 alias.url += (
55     "/%{name}" => "%{_appdir}",
56 )
57 EOF
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT%{_sysconfdir}
62 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
63
64 cp -p apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
65 cp -p apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
66 cp -p lighttpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
67
68 mv $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir}}/apache.conf
69 mv $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir}}/lighttpd.conf
70 cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
71
72 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
73 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
74 cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
75
76 # %webapp_* macros usage extracted from /usr/lib/rpm/macros.build:
77 #
78 # Usage:
79 #   %%webapp_register HTTPD WEBAPP
80 #   %%webapp_unregister HTTPD WEBAPP
81
82 %triggerin -- apache1 < 1.3.37-3, apache1-base
83 %webapp_register apache %{_webapp}
84
85 %triggerun -- apache1 < 1.3.37-3, apache1-base
86 %webapp_unregister apache %{_webapp}
87
88 %triggerin -- apache < 2.2.0, apache-base
89 %webapp_register httpd %{_webapp}
90
91 %triggerun -- apache < 2.2.0, apache-base
92 %webapp_unregister httpd %{_webapp}
93
94 %triggerin -- lighttpd
95 %webapp_register lighttpd %{_webapp}
96
97 %triggerun -- lighttpd
98 %webapp_unregister lighttpd %{_webapp}
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %files
104 %defattr(644,root,root,755)
105 %dir %attr(750,root,http) %{_sysconfdir}
106 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
107 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
108 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
109 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
110 %{_appdir}
This page took 0.108589 seconds and 4 git commands to generate.