]> git.pld-linux.org Git - packages/wayland.git/blob - wayland.spec
- fix building without apidocs (documentation is disabled too so there
[packages/wayland.git] / wayland.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # don't build API documentation
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        Wayland - protocol for a compositor to talk to its clients
7 Summary(pl.UTF-8):      Wayland - protokół między serwerem składającym a klientami
8 Name:           wayland
9 Version:        1.12.0
10 Release:        2
11 License:        MIT
12 Group:          Libraries
13 Source0:        https://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
14 # Source0-md5:  ee615e2d1e205eec48b02f069327eb96
15 Patch1:         %{name}-man.patch
16 URL:            https://wayland.freedesktop.org/
17 BuildRequires:  autoconf >= 2.64
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  expat-devel >= 1.95
20 BuildRequires:  libffi-devel >= 3
21 BuildRequires:  libtool >= 2:2.2
22 # for DTD valudation
23 BuildRequires:  libxml2-devel >= 2.0
24 BuildRequires:  pkgconfig
25 %if %{with apidocs}
26 BuildRequires:  docbook-style-xsl
27 BuildRequires:  doxygen >= 1.6.0
28 BuildRequires:  graphviz >= 2.26.0
29 BuildRequires:  libxslt-progs
30 BuildRequires:  xmlto
31 %endif
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Wayland is a project to define a protocol for a compositor to talk to
36 its clients as well as a library implementation of the protocol. The
37 compositor can be a standalone display server running on Linux kernel
38 modesetting and evdev input devices, an X application, or a Wayland
39 client itself. The clients can be traditional applications, X servers
40 (rootless or fullscreen) or other display servers.
41
42 %description -l pl.UTF-8
43 Wayland to projekt definiujący protokół między serwerem składającym a
44 klientami, a także biblioteki implementujące ten protokół. Serwer
45 składający może być samodzielnym serwerem wyświetlającym działającym
46 na linuksowym kernel modesetting oraz urządzeniach wejściowych evdev,
47 aplikacją X lub klientem Wayland. Klientami mogą być tradycyjne
48 aplikacje, serwery X (rootless lub pełnoekranowe) lub inne serwery
49 wyświetlające.
50
51 %package devel
52 Summary:        Header files for Wayland libraries
53 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Wayland
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       libffi-devel
57
58 %description devel
59 Header files for Wayland libraries.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe bibliotek Wayland.
63
64 %package static
65 Summary:        Static Wayland libraries
66 Summary(pl.UTF-8):      Statyczne biblioteki Wayland
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description static
71 Static Wayland libraries.
72
73 %description static -l pl.UTF-8
74 Statyczne biblioteki Wayland.
75
76 %package apidocs
77 Summary:        Wayland API and protocol documentation
78 Summary(pl.UTF-8):      Dokumentacja API biblioteki oraz protokołu Wayland
79 Group:          Documentation
80 %if "%{_rpmversion}" >= "5"
81 BuildArch:      noarch
82 %endif
83
84 %description apidocs
85 Wayland API and protocol documentation.
86
87 %description apidocs -l pl.UTF-8
88 Dokumentacja API biblioteki oraz protokołu Wayland.
89
90 %prep
91 %setup -q
92 %patch1 -p1
93
94 # force regeneration (.so link is broken, double man3/)
95 %{__rm} doc/man/*.3
96
97 %build
98 %{__libtoolize}
99 %{__aclocal} -I m4
100 %{__autoconf}
101 %{__autoheader}
102 %{__automake}
103 %configure \
104         %{!?with_apidocs:--disable-documentation} \
105         --disable-silent-rules \
106         %{!?with_static_libs:--disable-static}
107
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 %if %{with apidocs}
117 # referenced by some installed wl_*.3 man pages
118 cp -p doc/doxygen/man/man3/wayland-{client-core,server,server-core,util}.h.3 \
119         doc/doxygen/man/man3/wayland-{client,server,shm,util}.c.3 $RPM_BUILD_ROOT%{_mandir}/man3
120 %endif
121
122 # obsoleted by pkg-config
123 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libwayland-*.la
124 %if %{with apidocs}
125 # packaged as %doc in -devel
126 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/wayland
127 %endif
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %files
136 %defattr(644,root,root,755)
137 %doc COPYING README TODO
138 %attr(755,root,root) %{_libdir}/libwayland-client.so.*.*.*
139 %attr(755,root,root) %ghost %{_libdir}/libwayland-client.so.0
140 %attr(755,root,root) %{_libdir}/libwayland-cursor.so.*.*.*
141 %attr(755,root,root) %ghost %{_libdir}/libwayland-cursor.so.0
142 %attr(755,root,root) %{_libdir}/libwayland-server.so.*.*.*
143 %attr(755,root,root) %ghost %{_libdir}/libwayland-server.so.0
144
145 %files devel
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_bindir}/wayland-scanner
148 %attr(755,root,root) %{_libdir}/libwayland-client.so
149 %attr(755,root,root) %{_libdir}/libwayland-cursor.so
150 %attr(755,root,root) %{_libdir}/libwayland-server.so
151 %{_includedir}/wayland-*.h
152 %dir %{_datadir}/wayland
153 %{_datadir}/wayland/wayland.dtd
154 %{_datadir}/wayland/wayland.xml
155 %{_datadir}/wayland/wayland-scanner.mk
156 %{_pkgconfigdir}/wayland-client.pc
157 %{_pkgconfigdir}/wayland-cursor.pc
158 %{_pkgconfigdir}/wayland-scanner.pc
159 %{_pkgconfigdir}/wayland-server.pc
160 %{_aclocaldir}/wayland-scanner.m4
161 %if %{with apidocs}
162 %{_mandir}/man3/wayland-*.c.3*
163 %{_mandir}/man3/wayland-*.h.3*
164 %{_mandir}/man3/wl_*.3*
165 %endif
166
167 %if %{with static_libs}
168 %files static
169 %defattr(644,root,root,755)
170 %{_libdir}/libwayland-client.a
171 %{_libdir}/libwayland-cursor.a
172 %{_libdir}/libwayland-server.a
173 %endif
174
175 %if %{with apidocs}
176 %files apidocs
177 %defattr(644,root,root,755)
178 %doc doc/publican/Wayland/en-US/html/*
179 %endif
This page took 0.045945 seconds and 4 git commands to generate.