]> git.pld-linux.org Git - packages/wayland.git/blob - wayland.spec
- updated to 1.7.0
[packages/wayland.git] / wayland.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # don't build API documentation
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        Wayland - protocol for a compositor to talk to its clients
7 Summary(pl.UTF-8):      Wayland - protokół między serwerem składającym a klientami
8 Name:           wayland
9 Version:        1.7.0
10 Release:        1
11 License:        MIT
12 Group:          Libraries
13 Source0:        http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
14 # Source0-md5:  6f46ac47c3a18c6503a40b5fa58a1066
15 Patch1:         %{name}-man.patch
16 URL:            http://wayland.freedesktop.org/
17 BuildRequires:  autoconf >= 2.64
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  expat-devel >= 1.95
20 BuildRequires:  libffi-devel >= 3
21 BuildRequires:  libtool >= 2:2.2
22 BuildRequires:  pkgconfig
23 %if %{with apidocs}
24 BuildRequires:  docbook-style-xsl
25 BuildRequires:  doxygen >= 1.6.0
26 BuildRequires:  graphviz >= 2.26.0
27 BuildRequires:  libxslt-progs
28 BuildRequires:  xmlto
29 %endif
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Wayland is a project to define a protocol for a compositor to talk to
34 its clients as well as a library implementation of the protocol. The
35 compositor can be a standalone display server running on Linux kernel
36 modesetting and evdev input devices, an X application, or a Wayland
37 client itself. The clients can be traditional applications, X servers
38 (rootless or fullscreen) or other display servers.
39
40 %description -l pl.UTF-8
41 Wayland to projekt definiujący protokół między serwerem składającym a
42 klientami, a także biblioteki implementujące ten protokół. Serwer
43 składający może być samodzielnym serwerem wyświetlającym działającym
44 na linuksowym kernel modesetting oraz urządzeniach wejściowych evdev,
45 aplikacją X lub klientem Wayland. Klientami mogą być tradycyjne
46 aplikacje, serwery X (rootless lub pełnoekranowe) lub inne serwery
47 wyświetlające.
48
49 %package devel
50 Summary:        Header files for Wayland libraries
51 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Wayland
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       libffi-devel
55
56 %description devel
57 Header files for Wayland libraries.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe bibliotek Wayland.
61
62 %package static
63 Summary:        Static Wayland libraries
64 Summary(pl.UTF-8):      Statyczne biblioteki Wayland
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Static Wayland libraries.
70
71 %description static -l pl.UTF-8
72 Statyczne biblioteki Wayland.
73
74 %package apidocs
75 Summary:        Wayland API and protocol documentation
76 Summary(pl.UTF-8):      Dokumentacja API biblioteki oraz protokołu Wayland
77 Group:          Documentation
78
79 %description apidocs
80 Wayland API and protocol documentation.
81
82 %description apidocs -l pl.UTF-8
83 Dokumentacja API biblioteki oraz protokołu Wayland.
84
85 %prep
86 %setup -q
87 %patch1 -p1
88
89 # force regeneration (.so link is broken, double man3/)
90 %{__rm} doc/man/*.3
91 # force doxygen man regeneration
92 %{__rm} -r doc/doxygen/man
93
94 %build
95 %{__libtoolize}
96 %{__aclocal} -I m4
97 %{__autoconf}
98 %{__autoheader}
99 %{__automake}
100 %configure \
101         %{!?with_apidocs:--disable-documentation} \
102         --disable-silent-rules \
103         %{!?with_static_libs:--disable-static}
104
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 # referenced by some installed wl_*.3 man pages
114 cp -p doc/doxygen/man/man3/wayland-util.h.3 $RPM_BUILD_ROOT%{_mandir}/man3
115
116 # obsoleted by pkg-config
117 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libwayland-*.la
118 %if %{with apidocs}
119 # packaged as %doc in -devel
120 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/wayland
121 %endif
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %files
130 %defattr(644,root,root,755)
131 %doc COPYING README TODO
132 %attr(755,root,root) %{_libdir}/libwayland-client.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libwayland-client.so.0
134 %attr(755,root,root) %{_libdir}/libwayland-cursor.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/libwayland-cursor.so.0
136 %attr(755,root,root) %{_libdir}/libwayland-server.so.*.*.*
137 %attr(755,root,root) %ghost %{_libdir}/libwayland-server.so.0
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_bindir}/wayland-scanner
142 %attr(755,root,root) %{_libdir}/libwayland-client.so
143 %attr(755,root,root) %{_libdir}/libwayland-cursor.so
144 %attr(755,root,root) %{_libdir}/libwayland-server.so
145 %{_includedir}/wayland-*.h
146 %dir %{_datadir}/wayland
147 %{_datadir}/wayland/wayland.dtd
148 %{_datadir}/wayland/wayland.xml
149 %{_datadir}/wayland/wayland-scanner.mk
150 %{_pkgconfigdir}/wayland-client.pc
151 %{_pkgconfigdir}/wayland-cursor.pc
152 %{_pkgconfigdir}/wayland-scanner.pc
153 %{_pkgconfigdir}/wayland-server.pc
154 %{_aclocaldir}/wayland-scanner.m4
155 %if %{with apidocs}
156 %{_mandir}/man3/wayland-util.h.3*
157 %{_mandir}/man3/wl_*.3*
158 %endif
159
160 %if %{with static_libs}
161 %files static
162 %defattr(644,root,root,755)
163 %{_libdir}/libwayland-client.a
164 %{_libdir}/libwayland-cursor.a
165 %{_libdir}/libwayland-server.a
166 %endif
167
168 %if %{with apidocs}
169 %files apidocs
170 %defattr(644,root,root,755)
171 %doc doc/publican/Wayland/en-US/html/*
172 %endif
This page took 0.071615 seconds and 4 git commands to generate.