]> git.pld-linux.org Git - packages/wayland.git/blob - wayland.spec
- updated to 1.15.0
[packages/wayland.git] / wayland.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # don't build API documentation
4 %bcond_without  static_libs     # don't build static libraries
5
6 # see wayland-egl.pc
7 %define wayland_egl_ver 18.1.0
8 Summary:        Wayland - protocol for a compositor to talk to its clients
9 Summary(pl.UTF-8):      Wayland - protokół między serwerem składającym a klientami
10 Name:           wayland
11 Version:        1.15.0
12 Release:        1
13 License:        MIT
14 Group:          Libraries
15 Source0:        https://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
16 # Source0-md5:  b7393c17fdce9a8d383edab656c92fd2
17 Patch0:         %{name}-missing.patch
18 Patch1:         %{name}-man.patch
19 URL:            https://wayland.freedesktop.org/
20 BuildRequires:  autoconf >= 2.64
21 BuildRequires:  automake >= 1:1.11
22 BuildRequires:  expat-devel >= 1.95
23 BuildRequires:  libffi-devel >= 3
24 BuildRequires:  libtool >= 2:2.2
25 # for DTD valudation
26 BuildRequires:  libxml2-devel >= 2.0
27 BuildRequires:  pkgconfig
28 %if %{with apidocs}
29 BuildRequires:  docbook-style-xsl-nons
30 BuildRequires:  doxygen >= 1.6.0
31 BuildRequires:  graphviz >= 2.26.0
32 BuildRequires:  libxslt-progs
33 BuildRequires:  xmlto
34 %endif
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Wayland is a project to define a protocol for a compositor to talk to
39 its clients as well as a library implementation of the protocol. The
40 compositor can be a standalone display server running on Linux kernel
41 modesetting and evdev input devices, an X application, or a Wayland
42 client itself. The clients can be traditional applications, X servers
43 (rootless or fullscreen) or other display servers.
44
45 %description -l pl.UTF-8
46 Wayland to projekt definiujący protokół między serwerem składającym a
47 klientami, a także biblioteki implementujące ten protokół. Serwer
48 składający może być samodzielnym serwerem wyświetlającym działającym
49 na linuksowym kernel modesetting oraz urządzeniach wejściowych evdev,
50 aplikacją X lub klientem Wayland. Klientami mogą być tradycyjne
51 aplikacje, serwery X (rootless lub pełnoekranowe) lub inne serwery
52 wyświetlające.
53
54 %package devel
55 Summary:        Header files for Wayland libraries
56 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Wayland
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       libffi-devel
60
61 %description devel
62 Header files for Wayland libraries.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe bibliotek Wayland.
66
67 %package static
68 Summary:        Static Wayland libraries
69 Summary(pl.UTF-8):      Statyczne biblioteki Wayland
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 Static Wayland libraries.
75
76 %description static -l pl.UTF-8
77 Statyczne biblioteki Wayland.
78
79 %package egl
80 Summary:        Wayland EGL library
81 Summary(pl.UTF-8):      Biblioteka Wayland EGL
82 Group:          Libraries
83 Obsoletes:      Mesa-libwayland-egl < %{wayland_egl_ver}
84
85 %description egl
86 Wayland EGL library.
87
88 %description egl -l pl.UTF-8
89 Biblioteka Wayland EGL.
90
91 %package egl-devel
92 Summary:        Header files for Wayland EGL library
93 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Wayland EGL
94 Group:          Development/Libraries
95 Requires:       %{name}-devel = %{version}-%{release}
96 Requires:       %{name}-egl = %{version}-%{release}
97 Obsoletes:      Mesa-libwayland-egl-devel < %{wayland_egl_ver}
98
99 %description egl-devel
100 Header files for Wayland EGL library.
101
102 %description egl-devel -l pl.UTF-8
103 Pliki nagłówkowe biblioteki Wayland EGL.
104
105 %package egl-static
106 Summary:        Static Wayland EGL library
107 Summary(pl.UTF-8):      Statyczna biblioteka Wayland EGL
108 Group:          Development/Libraries
109 Requires:       %{name}-egl-devel = %{version}-%{release}
110
111 %description egl-static
112 Static Wayland EGL library.
113
114 %description egl-static -l pl.UTF-8
115 Statyczna biblioteka Wayland EGL.
116
117 %package apidocs
118 Summary:        Wayland API and protocol documentation
119 Summary(pl.UTF-8):      Dokumentacja API biblioteki oraz protokołu Wayland
120 Group:          Documentation
121 %if "%{_rpmversion}" >= "5"
122 BuildArch:      noarch
123 %endif
124
125 %description apidocs
126 Wayland API and protocol documentation.
127
128 %description apidocs -l pl.UTF-8
129 Dokumentacja API biblioteki oraz protokołu Wayland.
130
131 %prep
132 %setup -q
133 %patch0 -p1
134 %patch1 -p1
135
136 # force regeneration (.so link is broken, double man3/)
137 %{__rm} doc/man/*.3
138
139 %build
140 %{__libtoolize}
141 %{__aclocal} -I m4
142 %{__autoconf}
143 %{__autoheader}
144 %{__automake}
145 %configure \
146         %{!?with_apidocs:--disable-documentation} \
147         --disable-silent-rules \
148         %{?with_static_libs:--enable-static}
149
150 %{__make}
151
152 %install
153 rm -rf $RPM_BUILD_ROOT
154
155 %{__make} install \
156         DESTDIR=$RPM_BUILD_ROOT
157
158 %if %{with apidocs}
159 # referenced by some installed wl_*.3 man pages
160 cp -p doc/doxygen/man/man3/wayland-{client,client-core,server,server-core,util}.h.3 \
161         doc/doxygen/man/man3/wayland-{client,server,shm,util}.c.3 $RPM_BUILD_ROOT%{_mandir}/man3
162 %endif
163
164 # obsoleted by pkg-config
165 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libwayland-*.la
166 %if %{with apidocs}
167 # packaged as %doc in -devel
168 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/wayland
169 %endif
170
171 %clean
172 rm -rf $RPM_BUILD_ROOT
173
174 %post   -p /sbin/ldconfig
175 %postun -p /sbin/ldconfig
176
177 %files
178 %defattr(644,root,root,755)
179 %doc COPYING README TODO
180 %attr(755,root,root) %{_libdir}/libwayland-client.so.*.*.*
181 %attr(755,root,root) %ghost %{_libdir}/libwayland-client.so.0
182 %attr(755,root,root) %{_libdir}/libwayland-cursor.so.*.*.*
183 %attr(755,root,root) %ghost %{_libdir}/libwayland-cursor.so.0
184 %attr(755,root,root) %{_libdir}/libwayland-server.so.*.*.*
185 %attr(755,root,root) %ghost %{_libdir}/libwayland-server.so.0
186
187 %files devel
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_bindir}/wayland-scanner
190 %attr(755,root,root) %{_libdir}/libwayland-client.so
191 %attr(755,root,root) %{_libdir}/libwayland-cursor.so
192 %attr(755,root,root) %{_libdir}/libwayland-server.so
193 %{_includedir}/wayland-client*.h
194 %{_includedir}/wayland-cursor.h
195 %{_includedir}/wayland-server*.h
196 %{_includedir}/wayland-util.h
197 %{_includedir}/wayland-version.h
198 %dir %{_datadir}/wayland
199 %{_datadir}/wayland/wayland.dtd
200 %{_datadir}/wayland/wayland.xml
201 %{_datadir}/wayland/wayland-scanner.mk
202 %{_pkgconfigdir}/wayland-client.pc
203 %{_pkgconfigdir}/wayland-cursor.pc
204 %{_pkgconfigdir}/wayland-scanner.pc
205 %{_pkgconfigdir}/wayland-server.pc
206 %{_aclocaldir}/wayland-scanner.m4
207 %if %{with apidocs}
208 %{_mandir}/man3/wayland-*.c.3*
209 %{_mandir}/man3/wayland-*.h.3*
210 %{_mandir}/man3/wl_*.3*
211 %endif
212
213 %if %{with static_libs}
214 %files static
215 %defattr(644,root,root,755)
216 %{_libdir}/libwayland-client.a
217 %{_libdir}/libwayland-cursor.a
218 %{_libdir}/libwayland-server.a
219 %endif
220
221 %if %{with apidocs}
222 %files apidocs
223 %defattr(644,root,root,755)
224 %doc doc/publican/Wayland/en-US/html/*
225 %endif
226
227 %files egl
228 %defattr(644,root,root,755)
229 %attr(755,root,root) %{_libdir}/libwayland-egl.so.*.*.*
230 %attr(755,root,root) %ghost %{_libdir}/libwayland-egl.so.1
231
232 %files egl-devel
233 %defattr(644,root,root,755)
234 %attr(755,root,root) %{_libdir}/libwayland-egl.so
235 %{_includedir}/wayland-egl*.h
236 %{_pkgconfigdir}/wayland-egl.pc
237 %{_pkgconfigdir}/wayland-egl-backend.pc
238
239 %if %{with static_libs}
240 %files egl-static
241 %defattr(644,root,root,755)
242 %{_libdir}/libwayland-egl.a
243 %endif
This page took 0.049491 seconds and 4 git commands to generate.