]> git.pld-linux.org Git - packages/wayland.git/blob - wayland.spec
- minimal expat version
[packages/wayland.git] / wayland.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # don't build API documentation
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        Wayland - protocol for a compositor to talk to its clients
7 Summary(pl.UTF-8):      Wayland - protokół między serwerem składającym a klientami
8 Name:           wayland
9 Version:        1.6.0
10 Release:        2
11 License:        MIT
12 Group:          Libraries
13 Source0:        http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
14 # Source0-md5:  d34c141c975084e4fb668e77b38f840e
15 Patch0:         %{name}-publican.patch
16 Patch1:         %{name}-man.patch
17 URL:            http://wayland.freedesktop.org/
18 BuildRequires:  autoconf >= 2.64
19 BuildRequires:  automake >= 1:1.11
20 BuildRequires:  docbook-style-xsl
21 BuildRequires:  doxygen
22 BuildRequires:  expat-devel >= 1.95
23 BuildRequires:  libffi-devel
24 BuildRequires:  libtool >= 2:2.2
25 BuildRequires:  libxslt-progs
26 BuildRequires:  pkgconfig
27 %{?with_apidocs:BuildRequires:  publican >= 3}
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Wayland is a project to define a protocol for a compositor to talk to
32 its clients as well as a library implementation of the protocol. The
33 compositor can be a standalone display server running on Linux kernel
34 modesetting and evdev input devices, an X application, or a Wayland
35 client itself. The clients can be traditional applications, X servers
36 (rootless or fullscreen) or other display servers.
37
38 %description -l pl.UTF-8
39 Wayland to projekt definiujący protokół między serwerem składającym a
40 klientami, a także biblioteki implementujące ten protokół. Serwer
41 składający może być samodzielnym serwerem wyświetlającym działającym
42 na linuksowym kernel modesetting oraz urządzeniach wejściowych evdev,
43 aplikacją X lub klientem Wayland. Klientami mogą być tradycyjne
44 aplikacje, serwery X (rootless lub pełnoekranowe) lub inne serwery
45 wyświetlające.
46
47 %package devel
48 Summary:        Header files for Wayland libraries
49 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Wayland
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       libffi-devel
53
54 %description devel
55 Header files for Wayland libraries.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe bibliotek Wayland.
59
60 %package static
61 Summary:        Static Wayland libraries
62 Summary(pl.UTF-8):      Statyczne biblioteki Wayland
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 Static Wayland libraries.
68
69 %description static -l pl.UTF-8
70 Statyczne biblioteki Wayland.
71
72 %package apidocs
73 Summary:        Wayland API and protocol documentation
74 Summary(pl.UTF-8):      Dokumentacja API biblioteki oraz protokołu Wayland
75 Group:          Documentation
76
77 %description apidocs
78 Wayland API and protocol documentation.
79
80 %description apidocs -l pl.UTF-8
81 Dokumentacja API biblioteki oraz protokołu Wayland.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86 %patch1 -p1
87
88 # force regeneration (.so link is broken, double man3/)
89 %{__rm} doc/man/*.3
90 # force doxygen man regeneration
91 %{__rm} -r doc/doxygen/man
92
93 %build
94 %{__libtoolize}
95 %{__aclocal} -I m4
96 %{__autoconf}
97 %{__autoheader}
98 %{__automake}
99 %configure \
100         --disable-silent-rules \
101         %{!?with_static_libs:--disable-static}
102
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 # referenced by some installed wl_*.3 man pages
112 cp -p doc/doxygen/man/man3/wayland-util.h.3 $RPM_BUILD_ROOT%{_mandir}/man3
113
114 # obsoleted by pkg-config
115 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libwayland-*.la
116 %if %{with apidocs}
117 # packaged as %doc in -devel
118 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/wayland
119 %endif
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post   -p /sbin/ldconfig
125 %postun -p /sbin/ldconfig
126
127 %files
128 %defattr(644,root,root,755)
129 %doc COPYING README TODO
130 %attr(755,root,root) %{_libdir}/libwayland-client.so.*.*.*
131 %attr(755,root,root) %ghost %{_libdir}/libwayland-client.so.0
132 %attr(755,root,root) %{_libdir}/libwayland-cursor.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libwayland-cursor.so.0
134 %attr(755,root,root) %{_libdir}/libwayland-server.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/libwayland-server.so.0
136
137 %files devel
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_bindir}/wayland-scanner
140 %attr(755,root,root) %{_libdir}/libwayland-client.so
141 %attr(755,root,root) %{_libdir}/libwayland-cursor.so
142 %attr(755,root,root) %{_libdir}/libwayland-server.so
143 %{_includedir}/wayland-*.h
144 %dir %{_datadir}/wayland
145 %{_datadir}/wayland/wayland.dtd
146 %{_datadir}/wayland/wayland.xml
147 %{_datadir}/wayland/wayland-scanner.mk
148 %{_pkgconfigdir}/wayland-client.pc
149 %{_pkgconfigdir}/wayland-cursor.pc
150 %{_pkgconfigdir}/wayland-scanner.pc
151 %{_pkgconfigdir}/wayland-server.pc
152 %{_aclocaldir}/wayland-scanner.m4
153 %{_mandir}/man3/wayland-util.h.3*
154 %{_mandir}/man3/wl_*.3*
155
156 %if %{with static_libs}
157 %files static
158 %defattr(644,root,root,755)
159 %{_libdir}/libwayland-client.a
160 %{_libdir}/libwayland-cursor.a
161 %{_libdir}/libwayland-server.a
162 %endif
163
164 %if %{with apidocs}
165 %files apidocs
166 %defattr(644,root,root,755)
167 %doc doc/publican/Wayland/en-US/html/*
168 %endif
This page took 0.0907249999999999 seconds and 4 git commands to generate.