]> git.pld-linux.org Git - packages/wayland.git/blob - wayland.spec
- updated to 1.9.0
[packages/wayland.git] / wayland.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # don't build API documentation
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        Wayland - protocol for a compositor to talk to its clients
7 Summary(pl.UTF-8):      Wayland - protokół między serwerem składającym a klientami
8 Name:           wayland
9 Version:        1.9.0
10 Release:        1
11 License:        MIT
12 Group:          Libraries
13 Source0:        http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
14 # Source0-md5:  5e141b3f2a7005d6c89d6f233c87c317
15 Patch1:         %{name}-man.patch
16 URL:            http://wayland.freedesktop.org/
17 BuildRequires:  autoconf >= 2.64
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  expat-devel >= 1.95
20 BuildRequires:  libffi-devel >= 3
21 BuildRequires:  libtool >= 2:2.2
22 BuildRequires:  pkgconfig
23 %if %{with apidocs}
24 BuildRequires:  docbook-style-xsl
25 BuildRequires:  doxygen >= 1.6.0
26 BuildRequires:  graphviz >= 2.26.0
27 BuildRequires:  libxslt-progs
28 BuildRequires:  xmlto
29 %endif
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Wayland is a project to define a protocol for a compositor to talk to
34 its clients as well as a library implementation of the protocol. The
35 compositor can be a standalone display server running on Linux kernel
36 modesetting and evdev input devices, an X application, or a Wayland
37 client itself. The clients can be traditional applications, X servers
38 (rootless or fullscreen) or other display servers.
39
40 %description -l pl.UTF-8
41 Wayland to projekt definiujący protokół między serwerem składającym a
42 klientami, a także biblioteki implementujące ten protokół. Serwer
43 składający może być samodzielnym serwerem wyświetlającym działającym
44 na linuksowym kernel modesetting oraz urządzeniach wejściowych evdev,
45 aplikacją X lub klientem Wayland. Klientami mogą być tradycyjne
46 aplikacje, serwery X (rootless lub pełnoekranowe) lub inne serwery
47 wyświetlające.
48
49 %package devel
50 Summary:        Header files for Wayland libraries
51 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Wayland
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       libffi-devel
55
56 %description devel
57 Header files for Wayland libraries.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe bibliotek Wayland.
61
62 %package static
63 Summary:        Static Wayland libraries
64 Summary(pl.UTF-8):      Statyczne biblioteki Wayland
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Static Wayland libraries.
70
71 %description static -l pl.UTF-8
72 Statyczne biblioteki Wayland.
73
74 %package apidocs
75 Summary:        Wayland API and protocol documentation
76 Summary(pl.UTF-8):      Dokumentacja API biblioteki oraz protokołu Wayland
77 Group:          Documentation
78 %if "%{_rpmversion}" >= "5"
79 BuildArch:      noarch
80 %endif
81
82 %description apidocs
83 Wayland API and protocol documentation.
84
85 %description apidocs -l pl.UTF-8
86 Dokumentacja API biblioteki oraz protokołu Wayland.
87
88 %prep
89 %setup -q
90 %patch1 -p1
91
92 # force regeneration (.so link is broken, double man3/)
93 %{__rm} doc/man/*.3
94
95 %build
96 %{__libtoolize}
97 %{__aclocal} -I m4
98 %{__autoconf}
99 %{__autoheader}
100 %{__automake}
101 %configure \
102         %{!?with_apidocs:--disable-documentation} \
103         --disable-silent-rules \
104         %{!?with_static_libs:--disable-static}
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 # referenced by some installed wl_*.3 man pages
115 cp -p doc/doxygen/man/man3/wayland-util.h.3 $RPM_BUILD_ROOT%{_mandir}/man3
116
117 # obsoleted by pkg-config
118 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libwayland-*.la
119 %if %{with apidocs}
120 # packaged as %doc in -devel
121 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/wayland
122 %endif
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 %doc COPYING README TODO
133 %attr(755,root,root) %{_libdir}/libwayland-client.so.*.*.*
134 %attr(755,root,root) %ghost %{_libdir}/libwayland-client.so.0
135 %attr(755,root,root) %{_libdir}/libwayland-cursor.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/libwayland-cursor.so.0
137 %attr(755,root,root) %{_libdir}/libwayland-server.so.*.*.*
138 %attr(755,root,root) %ghost %{_libdir}/libwayland-server.so.0
139
140 %files devel
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_bindir}/wayland-scanner
143 %attr(755,root,root) %{_libdir}/libwayland-client.so
144 %attr(755,root,root) %{_libdir}/libwayland-cursor.so
145 %attr(755,root,root) %{_libdir}/libwayland-server.so
146 %{_includedir}/wayland-*.h
147 %dir %{_datadir}/wayland
148 %{_datadir}/wayland/wayland.dtd
149 %{_datadir}/wayland/wayland.xml
150 %{_datadir}/wayland/wayland-scanner.mk
151 %{_pkgconfigdir}/wayland-client.pc
152 %{_pkgconfigdir}/wayland-cursor.pc
153 %{_pkgconfigdir}/wayland-scanner.pc
154 %{_pkgconfigdir}/wayland-server.pc
155 %{_aclocaldir}/wayland-scanner.m4
156 %if %{with apidocs}
157 %{_mandir}/man3/wayland-util.h.3*
158 %{_mandir}/man3/wl_*.3*
159 %endif
160
161 %if %{with static_libs}
162 %files static
163 %defattr(644,root,root,755)
164 %{_libdir}/libwayland-client.a
165 %{_libdir}/libwayland-cursor.a
166 %{_libdir}/libwayland-server.a
167 %endif
168
169 %if %{with apidocs}
170 %files apidocs
171 %defattr(644,root,root,755)
172 %doc doc/publican/Wayland/en-US/html/*
173 %endif
This page took 0.075165 seconds and 4 git commands to generate.