]> git.pld-linux.org Git - packages/wayland.git/blob - wayland.spec
- updated to 1.0.3
[packages/wayland.git] / wayland.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # don't build API documentation
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        Wayland - protocol for a compositor to talk to its clients
7 Summary(pl.UTF-8):      Wayland - protokół między serwerem składającym a klientami
8 Name:           wayland
9 Version:        1.0.3
10 Release:        1
11 License:        MIT
12 Group:          Libraries
13 Source0:        http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
14 # Source0-md5:  eebe23571fd4f9ceacc583238e5a8ae9
15 Patch0:         %{name}-publican.patch
16 URL:            http://wayland.freedesktop.org/
17 BuildRequires:  autoconf >= 2.64
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  doxygen
20 BuildRequires:  expat-devel
21 BuildRequires:  libffi-devel
22 BuildRequires:  libtool >= 2:2.2
23 BuildRequires:  libxslt-progs
24 BuildRequires:  pkgconfig
25 BuildRequires:  pkgconfig(libffi)
26 %{?with_apidocs:BuildRequires:  publican >= 3}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Wayland is a project to define a protocol for a compositor to talk to
31 its clients as well as a library implementation of the protocol. The
32 compositor can be a standalone display server running on Linux kernel
33 modesetting and evdev input devices, an X application, or a Wayland
34 client itself. The clients can be traditional applications, X servers
35 (rootless or fullscreen) or other display servers.
36
37 %description -l pl.UTF-8
38 Wayland to projekt definiujący protokół między serwerem składającym a
39 klientami, a także biblioteki implementujące ten protokół. Serwer
40 składający może być samodzielnym serwerem wyświetlającym działającym
41 na linuksowym kernel modesetting oraz urządzeniach wejściowych evdev,
42 aplikacją X lub klientem Wayland. Klientami mogą być tradycyjne
43 aplikacje, serwery X (rootless lub pełnoekranowe) lub inne serwery
44 wyświetlające.
45
46 %package devel
47 Summary:        Header files for Wayland libraries
48 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Wayland
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       libffi-devel
52
53 %description devel
54 Header files for Wayland libraries.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe bibliotek Wayland.
58
59 %package static
60 Summary:        Static Wayland libraries
61 Summary(pl.UTF-8):      Statyczne biblioteki Wayland
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static Wayland libraries.
67
68 %description static -l pl.UTF-8
69 Statyczne biblioteki Wayland.
70
71 %package apidocs
72 Summary:        Wayland API and protocol documentation
73 Summary(pl.UTF-8):      Dokumentacja API biblioteki oraz protokołu Wayland
74 Group:          Documentation
75
76 %description apidocs
77 Wayland API and protocol documentation.
78
79 %description apidocs -l pl.UTF-8
80 Dokumentacja API biblioteki oraz protokołu Wayland.
81
82 %prep
83 %setup -q
84
85 # this file is required by publican 3.0; publican patch adds it in en-US dir
86 test ! -f doc/Wayland/en_US/Revision_History.xml
87
88 %patch0 -p1
89
90 %build
91 %{__libtoolize}
92 %{__aclocal} -I m4
93 %{__autoconf}
94 %{__autoheader}
95 %{__automake}
96 %configure \
97         --disable-silent-rules \
98         %{!?with_static_libs:--disable-static}
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 # obsoleted by pkg-config
108 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libwayland-*.la
109 # packaged as %doc in -devel
110 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/wayland
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc COPYING README TODO
121 %attr(755,root,root) %{_libdir}/libwayland-client.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libwayland-client.so.0
123 %attr(755,root,root) %{_libdir}/libwayland-cursor.so.*.*.*
124 %attr(755,root,root) %ghost %{_libdir}/libwayland-cursor.so.0
125 %attr(755,root,root) %{_libdir}/libwayland-server.so.*.*.*
126 %attr(755,root,root) %ghost %{_libdir}/libwayland-server.so.0
127
128 %files devel
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_bindir}/wayland-scanner
131 %attr(755,root,root) %{_libdir}/libwayland-client.so
132 %attr(755,root,root) %{_libdir}/libwayland-cursor.so
133 %attr(755,root,root) %{_libdir}/libwayland-server.so
134 %{_includedir}/wayland-*.h
135 %{_pkgconfigdir}/wayland-client.pc
136 %{_pkgconfigdir}/wayland-cursor.pc
137 %{_pkgconfigdir}/wayland-server.pc
138 %{_aclocaldir}/wayland-scanner.m4
139 %{_aclocaldir}/wayland-scanner.mk
140 %{_mandir}/man3/wl_display_connect.3*
141 %{_mandir}/man3/wl_display_connect_to_fd*
142
143 %if %{with static_libs}
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/libwayland-client.a
147 %{_libdir}/libwayland-cursor.a
148 %{_libdir}/libwayland-server.a
149 %endif
150
151 %if %{with apidocs}
152 %files apidocs
153 %defattr(644,root,root,755)
154 %doc doc/Wayland/Wayland/en-US/html/*
155 %endif
This page took 0.040858 seconds and 3 git commands to generate.