]> git.pld-linux.org Git - packages/vtun.git/blob - vtun.spec
- spec adapterized.
[packages/vtun.git] / vtun.spec
1 Summary:        Virtual tunnel over TCP/IP networks
2 Name:           vtun
3 Version:        2.1b4
4 Release:        1
5 License:        GPL
6 Group:          Networking/Daemons
7 Group(pl):      Sieciowe/Serwery
8 Vendor:         Maxim Krasnyansky <max_mk@yahoo.com>
9 Source0:        http://vtun.netpedia.net/%{name}-%{version}.tar.gz
10 Source1:        %{name}.init
11 Patch0:         %{name}-makefile.patch
12 URL:            http://vtun.netpedia.net
13 BuildRequires:  openssl-devel
14 BuildRequires:  zlib-devel
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16 Obsoletes:      vppp
17
18 %define         _localstatedir  /var
19
20 %description
21 VTun provides the method for creating Virtual Tunnels over TCP/IP
22 networks and allows to shape, compress, encrypt traffic in that
23 tunnels. Supported type of tunnels are: PPP, IP, Ethernet and most of
24 other serial protocols and programs. VTun is easily and highly
25 configurable, it can be used for various network task like VPN, Mobil
26 IP, Shaped Internet access, IP address saving, etc. It is completely
27 user space implementation and does not require modification to any
28 kernel parts. You need SSLeay-devel and lzo-devel to build it.
29
30 %prep
31 %setup -q
32 %patch -p1
33 %build
34 LDFLAGS="-s"; export LDFLAGS
35 %configure \
36         --with-crypto-headers=%{_includedir}/openssl
37 make
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8} \
42         $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_localstatedir}/log/vtun}
43
44 make install DESTDIR=$RPM_BUILD_ROOT
45
46 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/vtund
47
48 gzip -9nf ChangeLog Credits README README.Setup README.Shaper FAQ TODO \
49         $RPM_BUILD_ROOT%{_mandir}/*/*
50
51 %post
52 /sbin/chkconfig --add vtund
53 if [ -f /var/lock/subsys/vtund ]; then
54         /etc/rc.d/init.d/vtund restart >&2
55 else
56         echo "Run \"/etc/rc.d/init.d/vtund start\" to start vtun daemons."
57 fi
58
59 %preun
60 if [ "$1" = "0" ]; then
61         if [ -f /var/lock/subsys/vtund ]; then
62                 /etc/rc.d/init.d/vtund stop >&2
63         fi
64         /sbin/chkconfig --del vtund
65 fi
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc {ChangeLog,Credits,README,README.Setup,README.Shaper,FAQ,TODO}.gz
73 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/vtund
74 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/vtund.conf
75 %attr(755,root,root) %{_sbindir}/vtund
76 %attr(755,root,root) %dir /var/log/vtund
77 %{_mandir}/man8/*
This page took 0.090633 seconds and 4 git commands to generate.