]> git.pld-linux.org Git - packages/vte.git/blob - vte.spec
- apply patch0
[packages/vte.git] / vte.spec
1 # TODO:
2 # - fix gtk-doc location
3 %define         gtk2_version            2.0.3
4 %define         glib2_version           2.0.3
5 %define         libart_lgpl_version     2.3.8
6
7 Summary:        VTE terminal widget library
8 Summary(pl):    Biblioteka z widgetem terminala VTE
9 Name:           vte
10 Version:        0.10.3
11 Release:        0.1
12 License:        LGPL
13 Group:          X11/Libraries
14 Source0:        ftp://ftp.gnome.org/pub/gnome/sources/%{name}/0.10/%{name}-%{version}.tar.bz2
15 Patch0:         %{name}-Xft2.patch
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  glib2-devel >= %{glib2_version}
19 BuildRequires:  gtk+2-devel >= %{gtk2_version}
20 BuildRequires:  libart_lgpl-devel >= %{libart_lgpl_version}
21 BuildRequires:  libtool
22 BuildRequires:  gnome-common
23 BuildRequires:  python-pygtk-devel >= 1.99.13
24 Requires(pre):  utempter
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _prefix         /usr/X11R6
28 %define         _mandir         %{_prefix}/man
29
30 %description
31 The vte package contains a terminal widget for GTK+. It's used by
32 gnome-terminal among other programs.
33
34 %description -l pl
35 Ten pakiet zawiera widget terminala dla GTK+. Jest u¿ywany przez
36 gnome-terminal oraz inne programy.
37
38 %package devel
39 Summary:        Headers for vte
40 Summary(pl):    Pliki nag³ówkowe vte
41 Group:          X11/Development/Libraries
42 Requires:       %{name} = %{version}
43 Requires:       glib2-devel >= %{glib2_version}
44 Requires:       gtk+2-devel >= %{gtk2_version}
45 Requires:       libart_lgpl-devel >= %{libart_lgpl_version}
46 Conflicts:      gnome-libs-devel < 1.4.1.2
47
48 %description devel
49 The vte package contains a terminal widget for GTK+. It's used by
50 gnome-terminal among other programs.
51
52 You should install the vte-devel package if you would like to
53 compile applications that use the vte terminal widget. You do not need
54 to install vte-devel if you just want to use precompiled
55 applications.
56
57 %description devel -l pl
58 Pliki nag³ówkowe potrzebne do kompilowania programów u¿ywaj±cych
59 vte.
60
61 %package static
62 Summary:        Static vte library
63 Summary(pl):    Statyczna biblioteka vte
64 Group:          X11/Development/Libraries
65 Requires:       %{name}-devel = %{version}
66 Conflicts:      gnome-libs-static < 1.4.1.2
67
68 %description static
69 Static version of vte libraries.
70
71 %description static -l pl
72 Statyczna wersja bibliotek vte.
73
74 %prep
75 %setup  -q
76 %patch0 -p1
77
78 %build
79 #rm -f missing
80 #%{__libtoolize}
81 #%{__aclocal} -I %{_aclocaldir}/gnome2-macros
82 #%{__autoconf}
83 #%{__automake}
84 %configure
85 %{__make}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %{__make} install \
91         DESTDIR=$RPM_BUILD_ROOT \
92         pkgconfigdir=%{_pkgconfigdir}
93
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post   -p /sbin/ldconfig
99 %postun -p /sbin/ldconfig
100
101 %files
102 %defattr(644,root,root,755)
103 %doc NEWS README AUTHORS
104 %attr(755,root,root) %{_bindir}/vte
105 %attr(755,root,root) %{_libdir}/lib*.so.*.*
106 # FIXME: move to proper place
107 #%{_libdir}/python*
108 %dir %{_libdir}/vte
109 %attr(755,root,root) %{_libdir}/vte/*
110 %attr(2755,root,utmp) %{_libdir}/gnome-pty-helper
111
112 %files devel
113 %defattr(644,root,root,755)
114 %{_libdir}/lib*.so
115 %{_libdir}/lib*.la
116 %{_includedir}/*
117 %{_pkgconfigdir}/*
118
119 %files static
120 %defattr(644,root,root,755)
121 %{_libdir}/lib*.a
This page took 0.029787 seconds and 3 git commands to generate.