]> git.pld-linux.org Git - packages/virt-manager.git/blob - virt-manager.spec
- BR: gettext-devel, perl-tools-pod
[packages/virt-manager.git] / virt-manager.spec
1
2 Summary:        Virtual Machine Manager
3 Name:           virt-manager
4 Version:        0.8.1
5 Release:        0.1
6 License:        GPL v2+
7 Group:          Applications/Emulators
8 URL:            http://virt-manager.et.redhat.com/
9 Source0:        http://virt-manager.et.redhat.com/download/sources/virt-manager/%{name}-%{version}.tar.gz
10 # Source0-md5:  6e461e91d679dc87d9fc506f34832d90
11 Patch0:         %{name}-close-nc-connection-on-EOF.patch
12 BuildRequires:  atk-devel
13 BuildRequires:  cairo-devel
14 BuildRequires:  gettext-devel
15 BuildRequires:  glib2-devel
16 #BuildRequires: gtk2-devel
17 BuildRequires:  intltool
18 BuildRequires:  pango-devel
19 BuildRequires:  perl-tools-pod
20 BuildRequires:  python-devel >= 2.14
21 BuildRequires:  python-pygobject-devel >= 2.14
22 BuildRequires:  python-pygtk-devel >= 2.14
23 BuildRequires:  scrollkeeper
24
25 # These two are just the oldest version tested
26 Requires:       python-gnome-gconf >= 1.99.11-7
27 Requires:       python-pygtk-gtk >= 1.99.12-6
28 # Absolutely require this version or newer
29 Requires:       python-libvirt >= 0.4.5
30 # Definitely does not work with earlier due to python API changes
31 Requires:       python-dbus >= 0.61
32 Requires:       python-gnome-vfs >= 2.15.4
33 # Minimum we've tested with
34 # Required for loading the glade UI
35 # Required for our graphics which are currently SVG format
36 # Required to install Xen & QEMU guests
37 Requires:       python-gnome-desktop-librsvg >= 2.14
38 Requires:       python-libxml2 >= 2.6.23
39 Requires:       python-pygtk-glade >= 2.12
40 Requires:       python-virtinst >= 0.500.1
41 # Earlier vte had broken python binding module
42 Requires:       vte >= 0.12.2
43 # For online help
44 Requires:       scrollkeeper
45 # For console widget
46 Requires:       python-gtk-vnc >= 0.3.4
47 # For local authentication against PolicyKit
48 Requires:       PolicyKit-gnome
49
50 Requires:       python-urlgrabber
51 Requires:       python-vte
52 Suggests:       gnome-keyring >= 0.4.9
53 Suggests:       python-gnome-desktop-keyring >= 2.15.4
54
55 ExclusiveArch:  %{ix86} x86_64 ia64
56
57 Requires(post): GConf2
58 Requires(pre):  GConf2
59 Requires(preun):        GConf2
60
61 %description
62 Virtual Machine Manager provides a graphical tool for administering
63 virtual machines for KVM, Xen, and QEmu. Start, stop, add or remove
64 virtual devices, connect to a graphical or serial console, and see
65 resource usage statistics for existing VMs on local or remote
66 machines. Uses libvirt as the backend management API.
67
68 %prep
69 %setup -q
70 %patch0
71
72 %build
73 %configure
74 %{__make}
75
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 %{__make} install  DESTDIR=$RPM_BUILD_ROOT
80 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/sparkline.a
81 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/sparkline.la
82 %find_lang %{name}
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %pre
88 if [ "$1" -gt 1 ]; then
89     export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
90     gconftool-2 --makefile-uninstall-rule \
91       %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
92 fi
93
94 %post
95 export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
96 gconftool-2 --makefile-install-rule \
97   %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
98
99 update-desktop-database %{_desktopdir}
100
101 if which scrollkeeper-update>/dev/null 2>&1; then scrollkeeper-update -q -o %{_datadir}/omf/%{name}; fi
102
103 %postun
104 update-desktop-database %{_desktopdir}
105
106 if which scrollkeeper-update>/dev/null 2>&1; then scrollkeeper-update -q; fi
107
108 %preun
109 if [ "$1" -eq 0 ]; then
110     export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
111     gconftool-2 --makefile-uninstall-rule \
112       %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
113 fi
114
115 %files -f %{name}.lang
116 %defattr(644,root,root,755)
117 %doc README COPYING COPYING-DOCS AUTHORS ChangeLog NEWS
118 %{_sysconfdir}/gconf/schemas/%{name}.schemas
119 %attr(755,root,root) %{_bindir}/%{name}
120 %{_libexecdir}/%{name}-launch
121
122 %dir %{_datadir}/%{name}
123 %{_datadir}/%{name}/*.glade
124 %dir %{_datadir}/%{name}/pixmaps
125 %{_datadir}/%{name}/pixmaps/*.png
126 %{_datadir}/%{name}/pixmaps/*.svg
127
128 %{_datadir}/%{name}/*.py
129 #%{_datadir}/%{name}/*.pyc
130 #%{_datadir}/%{name}/*.pyo
131
132 %dir %{_datadir}/%{name}/virtManager
133 %{_datadir}/%{name}/virtManager/*.py
134 #%{_datadir}/%{name}/virtManager/*.pyc
135 #%{_datadir}/%{name}/virtManager/*.pyo
136
137 %dir %{_datadir}/omf/%{name}
138 %dir %{_datadir}/gnome/help
139
140 %{_desktopdir}/%{name}.desktop
141 %{_datadir}/dbus-1/services/%{name}.service
142
143 %{_mandir}/man1/%{name}.1*
This page took 0.204544 seconds and 4 git commands to generate.