]> git.pld-linux.org Git - packages/virt-manager.git/blob - virt-manager.spec
- raw from spec included in sources
[packages/virt-manager.git] / virt-manager.spec
1
2 Summary:        Virtual Machine Manager
3 Name:           virt-manager
4 Version:        0.6.0
5 Release:        0.1
6 License:        GPL v2+
7 Group:          Applications/Emulators
8 URL:            http://virt-manager.et.redhat.com/
9 Source0:        http://virt-manager.et.redhat.com/download/sources/virt-manager/%{name}-%{version}.tar.gz
10 # Source0-md5:  fd0acd111f180a0766b08d5f42cf5468
11 Patch0:         %{name}-python.patch
12 BuildRequires:  atk-devel
13 BuildRequires:  cairo-devel
14 BuildRequires:  gettext
15 BuildRequires:  glib2-devel
16 #BuildRequires: gtk2-devel
17 BuildRequires:  intltool
18 BuildRequires:  pango-devel
19 BuildRequires:  python-devel >= 2.14
20 BuildRequires:  python-pygobject-devel >= 2.14
21 BuildRequires:  python-pygtk-devel >= 2.14
22 BuildRequires:  scrollkeeper
23
24 # These two are just the oldest version tested
25 Requires:       gnome-python2-gconf >= 1.99.11-7
26 Requires:       pygtk2 >= 1.99.12-6
27 # Absolutely require this version or newer
28 Requires:       libvirt-python >= 0.4.5
29 # Definitely does not work with earlier due to python API changes
30 Requires:       dbus-python >= 0.61
31 # Might work with earlier, but this is what we've tested
32 Requires:       gnome-keyring >= 0.4.9
33 # Minimum we've tested with
34 # Although if you don't have this, comment it out and the app
35 # will work just fine - keyring functionality will simply be
36 # disabled
37 Requires:       gnome-python2-gnomekeyring >= 2.15.4
38 Requires:       gnome-python2-gnomevfs >= 2.15.4
39 # Minimum we've tested with
40 # Required for loading the glade UI
41 # Required for our graphics which are currently SVG format
42 # Required to install Xen & QEMU guests
43 Requires:       librsvg2
44 Requires:       libxml2-python >= 2.6.23
45 Requires:       pygtk2-libglade
46 Requires:       python-virtinst >= 0.400.0
47 # Earlier vte had broken python binding module
48 Requires:       vte >= 0.12.2
49 # For online help
50 Requires:       scrollkeeper
51 # For console widget
52 Requires:       gtk-vnc-python >= 0.3.4
53 # For local authentication against PolicyKit
54 Requires:       PolicyKit-gnome
55
56 ExclusiveArch:  %{ix86} x86_64 ia64
57
58 Requires(post): GConf2
59 Requires(pre):  GConf2
60 Requires(preun):        GConf2
61
62 %description
63 Virtual Machine Manager provides a graphical tool for administering
64 virtual machines for KVM, Xen, and QEmu. Start, stop, add or remove
65 virtual devices, connect to a graphical or serial console, and see
66 resource usage statistics for existing VMs on local or remote
67 machines. Uses libvirt as the backend management API.
68
69 %prep
70 %setup -q
71 %patch0 -p1
72
73 %build
74 %configure
75 %{__make}
76
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 %{__make} install  DESTDIR=$RPM_BUILD_ROOT
81 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/sparkline.a
82 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/sparkline.la
83 %find_lang %{name}
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %pre
89 if [ "$1" -gt 1 ]; then
90     export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
91     gconftool-2 --makefile-uninstall-rule \
92       %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
93 fi
94
95 %post
96 export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
97 gconftool-2 --makefile-install-rule \
98   %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
99
100 update-desktop-database %{_desktopdir}
101
102 if which scrollkeeper-update>/dev/null 2>&1; then scrollkeeper-update -q -o %{_datadir}/omf/%{name}; fi
103
104 %postun
105 update-desktop-database %{_desktopdir}
106
107 if which scrollkeeper-update>/dev/null 2>&1; then scrollkeeper-update -q; fi
108
109 %preun
110 if [ "$1" -eq 0 ]; then
111     export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
112     gconftool-2 --makefile-uninstall-rule \
113       %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
114 fi
115
116 %files -f %{name}.lang
117 %defattr(644,root,root,755)
118 %doc README COPYING COPYING-DOCS AUTHORS ChangeLog NEWS
119 %{_sysconfdir}/gconf/schemas/%{name}.schemas
120 %attr(755,root,root) %{_bindir}/%{name}
121 %{_libexecdir}/%{name}-launch
122 %{_libdir}/%{name}/*
123
124 %{_datadir}/%{name}/*.glade
125 %{_datadir}/%{name}/pixmaps/*.png
126 %{_datadir}/%{name}/pixmaps/*.svg
127
128 %{_datadir}/%{name}/*.py
129 #%{_datadir}/%{name}/*.pyc
130 #%{_datadir}/%{name}/*.pyo
131
132 %{_datadir}/%{name}/virtManager/*.py
133 #%{_datadir}/%{name}/virtManager/*.pyc
134 #%{_datadir}/%{name}/virtManager/*.pyo
135
136 %{_datadir}/omf/%{name}
137 %{_datadir}/gnome/help
138
139 %{_desktopdir}/%{name}.desktop
140 %{_datadir}/dbus-1/services/%{name}.service
141
142 %{_mandir}/man1/%{name}.1*
This page took 0.113704 seconds and 3 git commands to generate.