]> git.pld-linux.org Git - packages/vim.git/blob - vim.spec
added "-l pl"
[packages/vim.git] / vim.spec
1 Summary:        Vim built with ncurses
2 Summary(pl):    Vim korzystaj±cy z bibliotek ncurses
3 Name:           vim
4 Version:        5.4k
5 Release:        3
6 ########        ftp://ftp.nl.vim.org/pub/vim/unreleased
7 Source0:        %{name}-%{version}-src.tar.gz
8 Source1:        %{name}-%{version}-rt.tar.gz
9 Source2:        %{name}-%{version}-extra.tar.gz
10 Patch0:         vim-fhs.patch
11 Copyright:      GPL
12 Group:          Applications/Editors/Vim
13 Group(pl):      Aplikacje/Edytory/Vim
14 URL:            http://www.vim.org/
15 #BuildPrereq:   ncurses-static
16 #BuildPrereq:   gpm-devel
17 Buildroot:      /tmp/%{name}-%{version}-root
18
19 %description 
20 The classic Unix text editor. This version is build with minimal
21 feature and is installed in /bin as a rescue tool. The installation of
22 this package is STRONGLY recommended.
23
24 %description -l pl
25 Pakiet zawiera vim - klasyczny (unixowy) edytor tekstowy skompilowany 
26 statycznie. Instalacja tego pakietu jest MOCNO zalecana, mo¿e on pomóc
27 Tobie uratowaæ system w czasie awarii.
28
29 %package        rt 
30 Summary:        Vim runtime files
31 Summary(pl):    Pliki przydatne edytorowi vim 
32 Group:          Applications/Editors/Vim
33 Group(pl):      Aplikacje/Edytory/Vim
34
35 %description rt
36 This package contains macros, documentation, syntax configuration and
37 manual pages for vim. If you want to take advantage of vim more powerful
38 features, you should install this package.
39
40 %description rt -l pl
41 W tym pakiecie znajdziesz dokumentacjê, makra, pliki konfiguracyjne i strony
42 podrêcznika edytora vim. Je¿eli zamierzasz korzystaæ z vim-a, powiniene¶
43 zainstalowaæ ten pakiet.
44
45 %package        ncurses
46 Summary:        Vim ncurses
47 Summary(pl):    Vim ncurses
48 Group:          Applications/Editors/Vim
49 Group(pl):      Aplikacje/Edytory/Vim
50 Obsoletes:      vim-athena
51 Obsoletes:      vim-gtk
52 Obsoletes:      vim-lesstif
53
54 %description ncurses 
55 The classic Unix text editor build with ncurses library. It adds
56 multiple windows, multi-level undo, block highliting, and many other
57 features to the standard vi program.
58
59 %description ncurses -l pl
60 Wersja edytora vim skompilowana z bibliotek± ncurses. W porownaniu z
61 edytorem vi, ta wersja oferuje dodatkowo pracê z wieloma plikami,
62 wielopoziomowe operacje cofnij, bloki, pod¶wietlanie sk³adni i wiele
63 innych usprawnieñ.
64
65 %prep
66 %setup -q -b 1 -b 2
67 %patch -p1
68
69 %build
70 cd src
71
72 LDFLAGS="-static -s"; export LDFLAGS
73 %configure \
74         --disable-gui \
75         --without-x \
76         --disable-perlinterp \
77         --disable-pythoninterp \
78         --disable-tclinterp \
79         --disable-cscope \
80         --disable-gpm \
81         --enable-min-features \
82         --datadir=/etc \
83         --with-tlib=ncurses 
84 make vim
85 make xxd/xxd
86 mv vim vim.static
87 mv xxd/xxd xxd.static
88
89 make distclean
90 LDFLAGS="-s"; export LDFLAGS
91 %configure \
92         --enable-max-features \
93         --disable-gui \
94         --without-x \
95         --disable-perlinterp \
96         --disable-pythoninterp \
97         --disable-tclinterp \
98         --disable-cscope \
99         --enable-gmp \
100         --with-tlib=ncurses 
101 make vim
102 mv vim vim.ncurses
103
104 cd ..
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 install -d $RPM_BUILD_ROOT/{bin,var/state/vim}
110 install -d $RPM_BUILD_ROOT%{_prefix}/{bin,share/{vim/{doc,tutor},man/man1}}
111
112 install -s src/vim.static $RPM_BUILD_ROOT/bin/vi
113 install -s src/xxd.static $RPM_BUILD_ROOT/bin/xxd
114
115 install -s src/vim.ncurses $RPM_BUILD_ROOT%{_bindir}/vim
116 install    src/vimtutor    $RPM_BUILD_ROOT%{_bindir}/vimtutor
117
118 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/*.1
119
120 install runtime/doc/vim.1 $RPM_BUILD_ROOT%{_mandir}/man1
121 install runtime/doc/vim.1 $RPM_BUILD_ROOT%{_mandir}/man1/vi.1
122 install runtime/doc/xxd.1 $RPM_BUILD_ROOT%{_mandir}/man1
123
124 install runtime/doc/vimtutor.1 $RPM_BUILD_ROOT%{_mandir}/man1
125
126 echo ".so vi.1" > $RPM_BUILD_ROOT%{_mandir}/man1/ex.1
127 echo ".so vi.1" > $RPM_BUILD_ROOT%{_mandir}/man1/view.1
128 echo ".so vi.1" > $RPM_BUILD_ROOT%{_mandir}/man1/rview.1
129 echo ".so vim.1" > $RPM_BUILD_ROOT%{_mandir}/man1/rvim.1
130
131 cp -a runtime/macros $RPM_BUILD_ROOT%{_datadir}/vim/macros
132 cp -a runtime/syntax $RPM_BUILD_ROOT%{_datadir}/vim/syntax
133 cp -a runtime/tutor/tutor  $RPM_BUILD_ROOT%{_datadir}/vim/tutor/tutor
134
135 install runtime/*.vim $RPM_BUILD_ROOT%{_datadir}/vim
136 install runtime/vimrc_example.vim $RPM_BUILD_ROOT%{_datadir}/vim/vimrc
137
138 touch $RPM_BUILD_ROOT%{_bindir}/vi
139
140 install runtime/doc/*.txt $RPM_BUILD_ROOT%{_datadir}/vim/doc
141 install runtime/doc/tags  $RPM_BUILD_ROOT%{_datadir}/vim/doc
142
143 ln -sf vi $RPM_BUILD_ROOT/bin/ex
144 ln -sf vi $RPM_BUILD_ROOT/bin/view
145 ln -sf vi $RPM_BUILD_ROOT/bin/rview
146 ln -sf /bin/vi $RPM_BUILD_ROOT%{_bindir}/vi
147
148 ln -sf vim $RPM_BUILD_ROOT%{_bindir}/rvim
149
150 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/*
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %files 
156 %defattr(644,root,root,755)
157 %attr(755,root,root) /bin/*
158 %attr(755,root,root) %{_bindir}/vi
159
160 %{_mandir}/man1/vi.1*
161 %{_mandir}/man1/ex.1*
162 %{_mandir}/man1/xxd.1*
163 %{_mandir}/man1/view.1*
164 %{_mandir}/man1/rview.1*
165
166 %dir /var/state/vim
167
168 %files ncurses
169 %defattr(644,root,root,755)
170
171 %attr(755,root,root) %{_bindir}/vim
172 %attr(755,root,root) %{_bindir}/rvim
173
174 %{_mandir}/man1/vim.*
175 %{_mandir}/man1/rvim.*
176
177 %files rt
178 %defattr(644,root,root,755)
179
180 %attr(755,root,root) %{_bindir}/vimtutor
181
182 %dir %{_datadir}/vim
183 %{_datadir}/vim/macros
184
185 %dir %{_datadir}/vim/syntax
186 %{_datadir}/vim/syntax/*.vim
187
188 %{_datadir}/vim/tutor
189 %{_datadir}/vim/bugreport.vim
190 %{_datadir}/vim/filetype.vim
191 %{_datadir}/vim/scripts.vim
192 %{_datadir}/vim/mswin.vim
193 %{_datadir}/vim/ftoff.vim
194 %{_datadir}/vim/doc
195
196 %config %verify(not size mtime md5) %{_datadir}/vim/menu.vim
197 %config %verify(not size mtime md5) %{_datadir}/vim/vimrc
198
199 %changelog
200 * Sun Jun 13 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
201    [5.4k-3]
202 -  added /var/state/vim -- FHS 2.0
203 -  build only vim-ncurses, vim-rt & vim (static) packages
204 -  added default symlink /usr/bin/vi -> /bin/vi
205
206 * Mon Jun 07 1999 Jan Rêkorajski <baggins@pld.org.pl>
207   [5.4k-2]
208 - fixed non-static builds
209
210 * Wed Apr 21 1999 Artur Frysiak <wiget@pld.org.pl>
211   [5.4h-1]
212 - build on rpm 3  
213
214 * Fri Mar 12 1999 Artur Frysiak <wiget@pld.org.pl>
215   [5.4f-1]
216 - removed  vim-hold_gui_events.patch and vim-CMDLINE_COMPL.patch
217 - removed Requires: lesstif gtk+
218 - added --enable-gpm to configure
219
220 * Tue Feb 23 1999 Artur Frysiak <wiget@usa.net>
221   [5.4e-1d]
222 - removed vim-clip.patch (now in 5.4e)
223 - added vim-CMDLINE_COMPL.patch (allow compile with --enable-min-features)
224 - added %%defattr macro to all subpackages
225
226 * Thu Feb 04 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
227   [5.4d-2d]
228 - symlink %{_bindir}/vi -> /bin/vi
229 - doc package moved to %{_datadir}/vim/doc (crazy cpio .. ;)
230
231 * Tue Feb  2 1999 Artur Frysiak <wiget@usa.net>
232   [5.4d-1d]
233 - upgraded to 5.4d
234 - now %{_datadir}/vim/doc is symlink to /usr/doc/%{name}-rt-%{version}
235 - added missingok option to wmconfig files
236
237 * Wed Jan 13 1999 Artur Frysiak <wiget@usa.net>
238   [5.4c-1d]
239 - upgraded to 5.4c
240 - added gtk subpackage
241 - using %%{version} makro in Summary tags
242 - some chenges in %%build section
243 - changed Group to Applications/Editors/Vim
244
245 * Sun Dec 27 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
246   [5.3-4d]
247 - fixed some errors in rt subpackage. 
248   by Ziemek Borowski <ziembor@mail.ceu.edu.pl>
249 - fixed etcdir in vim-static subpackage.
250
251 * Thu Nov 12 1998 Arkadiusz Mi¶kiewicz <misiek@misiek.eu.org>
252   [5.3-2d]
253 - added %{_datadir}/vim/doc/{help.txt,tags} to rt subpackage (was missing)
254
255 * Sun Oct 04 1998 Marcin Korzonek <mkorz@shadow.eu.org>
256   [5.3-1]
257 - completely rewritten spec, added 4 subpackages
258
259 * Thu Aug 13 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
260   [5.0-1d]
261 - build against glibc-2.1,
262 - translation modified for pl,
263 - added build-root support,
264 - added %changelog,
265 - fixed permissions fo ELF binaries.
This page took 0.060659 seconds and 4 git commands to generate.