]> git.pld-linux.org Git - SPECS.git/blob - vim-plugin-dbgp.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / vim-plugin-dbgp.spec
1 # TODO
2 # - check for security, uses fixed filename in /tmp:
3 #    self.sessfile = "/tmp/debugger_vim_saved_session." + str(os.getpid())
4 %define         plugin  dbgp
5 Summary:        DBGp client: a remote debugger interface to the DBGp protocol (XDebug/PHP)
6 Name:           vim-plugin-%{plugin}
7 Version:        1.1.1
8 Release:        0.1
9 License:        MIT
10 Group:          Applications/Editors/Vim
11 Source0:        http://www.vim.org/scripts/download_script.php?src_id=7285&/%{plugin}-%{version}.zip
12 # Source0-md5:  23d6f4ee1d7799112e4e684115c6ecfe
13 URL:            http://www.vim.org/scripts/script.php?script_id=1929
14 Requires:       vim-heavy
15 # for _vimdatadir
16 Requires:       vim-rt >= 4:7.2.170
17 Suggests:       gvim-heavy
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _vimdatadir     %{_datadir}/vim
22
23 %description
24 DBGp client: a remote debugger interface to DBGp protocol.
25
26 This script has only been tested with XDebug for PHP debugging. But it
27 may work with other debuggers. If you would like to contribute any
28 patches which would add support for other debuggers, please contact me
29 at sam at box dot net.
30
31 For a tutorial on how to use this plugin, please visit
32 <http://tech.blog.box.net/2007/06/20/how-to-debug-php-with-vim-and-xdebug-on-linux/>.
33
34 IMPORTANT: In PLD Linux you need to use vim built with '+python' and
35 '+signs', which would be provided by 'vim-heavy' or 'gvim-heavy'
36 package.
37
38 %prep
39 %setup -qc
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT%{_vimdatadir}/plugin
44 cp -p plugin/* $RPM_BUILD_ROOT%{_vimdatadir}/plugin
45
46 chmod +x $RPM_BUILD_ROOT%{_vimdatadir}/plugin/debugger.py
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %{_vimdatadir}/plugin/debugger.vim
54 %{_vimdatadir}/plugin/debugger.py
This page took 1.485656 seconds and 3 git commands to generate.