]> git.pld-linux.org Git - packages/vigra.git/blob - vigra.spec
d7e11770e16c4ebcd54f50557533ac22933f4713
[packages/vigra.git] / vigra.spec
1 Summary:        Generic Programming for Computer Vision
2 Name:           vigra
3 Version:        1.2.0
4 Release:        0.2
5 License:        The VIGRA Artistic License
6 Group:          Libraries
7 Source0:        http://kogs-www.informatik.uni-hamburg.de/~koethe/vigra/%{name}%{version}.tar.gz
8 # Source0-md5:  fbb385e93d4b40469b04af4bc7079734
9 URL:            http://kogs-www.informatik.uni-hamburg.de/~koethe/vigra/
10 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11 BuildRequires:  zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel, fftw-devel
12
13 %description
14 VIGRA stands for "Vision with Generic Algorithms". It's a novel
15 computer vision library that puts its main emphasize on customizable
16 algorithms and data structures. By using template techniques similar
17 to those in the C++ Standard Template Library, you can easily adapt
18 any VIGRA component to the needs of your application, without thereby
19 giving up execution speed.
20
21 %package devel
22 Summary:        vigra - header files
23 Group:          Development/Libraries
24 Requires:       %{name} = %{version}-%{release}
25
26 %description devel
27 Header files needed to compile programs with vigra.
28
29 %package static
30 Summary:        vigra - static library
31 Group:          Development/Libraries
32 Requires:       %{name}-devel = %{version}-%{release}
33
34 %description static
35 Static version of vigra..
36
37 %prep
38 %setup -q -c
39
40 %build
41 cd %{name}%{version}
42
43 ./configure \
44         LDFLAGS="${LDFLAGS:-%rpmldflags}" \
45         CFLAGS="${CFLAGS:-%rpmcflags}" \
46         CXXFLAGS="${CXXFLAGS:-%rpmcflags}" \
47         FFLAGS="${FFLAGS:-%rpmcflags}" \
48         CPPFLAGS="${CPPFLAGS:-}" \
49         %{?__cc:CC="%{__cc}"} \
50         %{?__cxx:CXX="%{__cxx}"} \
51         --build=%{_target_platform} \
52         --prefix=%{_prefix} \
53         --exec-prefix=%{_exec_prefix} \
54         --bindir=%{_bindir} \
55         --includedir=%{_includedir} \
56         --libdir=%{_libdir} \
57     --with-tiff \
58     --with-jpeg \
59     --with-png \
60     --with-zlib \
61     --with-fftw \
62     --enable-shared=yes \
63     --docdir=%{buildroot}%{_datadir}/doc/%{name}-%{version}
64
65
66 %{__make}
67
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 cd %{name}%{version}
72 %{__make} \
73         prefix=$RPM_BUILD_ROOT%{_prefix} \
74         exec-prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
75         bindir=$RPM_BUILD_ROOT%{_bindir} \
76         includedir=$RPM_BUILD_ROOT%{_includedir} \
77         libdir=$RPM_BUILD_ROOT%{_libdir} \
78         install
79
80 %post -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %clean
84 rm -rf %{buildroot}
85
86 %files
87 %defattr(644,root,root,755)
88 %{_docdir}/%{name}-%{version}/LICENSE
89 %{_libdir}/*.so.*.*.*
90
91 %files devel
92 %defattr(644,root,root,755)
93 %{_docdir}
94 %attr(755,root,root) %{_bindir}
95 %{_libdir}/*.la
96 %{_libdir}/*.so
97 %{_includedir}/*
98
99 %files static
100 %defattr(644,root,root,755)
101 %{_libdir}/*.a
This page took 0.050009 seconds and 2 git commands to generate.