]> git.pld-linux.org Git - packages/vigra.git/blob - vigra.spec
- pl; needs files fixes
[packages/vigra.git] / vigra.spec
1 Summary:        Generic Programming for Computer Vision
2 Summary(pl):    Ogólne programowanie obrazu komputerowego
3 Name:           vigra
4 Version:        1.2.0
5 Release:        0.2
6 License:        The VIGRA Artistic License
7 Group:          Libraries
8 Source0:        http://kogs-www.informatik.uni-hamburg.de/~koethe/vigra/%{name}%{version}.tar.gz
9 # Source0-md5:  fbb385e93d4b40469b04af4bc7079734
10 URL:            http://kogs-www.informatik.uni-hamburg.de/~koethe/vigra/
11 BuildRequires:  fftw-devel
12 BuildRequires:  libjpeg-devel
13 BuildRequires:  libpng-devel
14 BuildRequires:  libtiff-devel
15 BuildRequires:  zlib-devel
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 VIGRA stands for "Vision with Generic Algorithms". It's a novel
20 computer vision library that puts its main emphasize on customizable
21 algorithms and data structures. By using template techniques similar
22 to those in the C++ Standard Template Library, you can easily adapt
23 any VIGRA component to the needs of your application, without thereby
24 giving up execution speed.
25
26 %description -l pl
27 VIGRA to skrót od "Vision with Generic Algorithms" (widok z ogólnymi
28 algorytmami). Jest to nowa biblioteka do obrazu komputerowego k³ad±ca
29 g³ówny nacisk na algorytmy i struktury danych z mo¿liwo¶ci±
30 dostosowania do w³asnych potrzeb. Poprzez u¿ycie technik szablonów
31 podobnych do tych w standardowej bibliotece szablonów C++ (STL) mo¿na
32 ³atwo zaadaptowaæ dowolny komponent VIGRA do potrzeb w³asnej aplikacji
33 bez po¶wiêcania szybko¶ci wykonywania.
34
35 %package devel
36 Summary:        Header files for vigra library
37 Summary(pl):    Pliki nag³ówkowe biblioteki vigra
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 Header files needed to compile programs with vigra.
43
44 %description devel -l pl
45 Pliki nag³ówkowe potrzebne do budowania programów u¿ywaj±cych
46 biblioteki vigra.
47
48 %package static
49 Summary:        vigra - static library
50 Summary(pl):    Statyczna biblioteka vigra
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}-%{release}
53
54 %description static
55 Static version of vigra library.
56
57 %description static -l pl
58 Statyczna wersja biblioteki vigra.
59
60 %prep
61 %setup -q -c
62
63 %build
64 cd %{name}%{version}
65
66 ./configure \
67         LDFLAGS="${LDFLAGS:-%rpmldflags}" \
68         CFLAGS="${CFLAGS:-%rpmcflags}" \
69         CXXFLAGS="${CXXFLAGS:-%rpmcflags}" \
70         FFLAGS="${FFLAGS:-%rpmcflags}" \
71         CPPFLAGS="${CPPFLAGS:-}" \
72         %{?__cc:CC="%{__cc}"} \
73         %{?__cxx:CXX="%{__cxx}"} \
74         --build=%{_target_platform} \
75         --prefix=%{_prefix} \
76         --exec-prefix=%{_exec_prefix} \
77         --bindir=%{_bindir} \
78         --includedir=%{_includedir} \
79         --libdir=%{_libdir} \
80     --with-tiff \
81     --with-jpeg \
82     --with-png \
83     --with-zlib \
84     --with-fftw \
85     --enable-shared=yes \
86     --docdir=%{buildroot}%{_datadir}/doc/%{name}-%{version}
87
88
89 %{__make}
90
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 cd %{name}%{version}
95 %{__make} \
96         prefix=$RPM_BUILD_ROOT%{_prefix} \
97         exec-prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
98         bindir=$RPM_BUILD_ROOT%{_bindir} \
99         includedir=$RPM_BUILD_ROOT%{_includedir} \
100         libdir=$RPM_BUILD_ROOT%{_libdir} \
101         install
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %dir %{_docdir}/%{name}-%{version}
112 %{_docdir}/%{name}-%{version}/LICENSE
113 %attr(755,root,root) %{_libdir}/*.so.*.*.*
114
115 %files devel
116 %defattr(644,root,root,755)
117 #XXX: fix %{_docdir}
118 %attr(755,root,root) %{_bindir}/*
119 %attr(755,root,root) %{_libdir}/*.so
120 %{_libdir}/*.la
121 %{_includedir}/*
122
123 %files static
124 %defattr(644,root,root,755)
125 %{_libdir}/*.a
This page took 0.073194 seconds and 3 git commands to generate.