]> git.pld-linux.org Git - packages/vigra.git/blob - vigra.spec
- release 6
[packages/vigra.git] / vigra.spec
1 Summary:        Generic Programming for Computer Vision
2 Summary(pl.UTF-8):      Ogólne programowanie obrazu komputerowego
3 Name:           vigra
4 Version:        1.8.0
5 Release:        6
6 License:        MIT
7 Group:          Libraries
8 Source0:        http://hci.iwr.uni-heidelberg.de/vigra/%{name}-%{version}-src.tar.gz
9 # Source0-md5:  15c5544448e529ee60020758ab6be264
10 URL:            http://hci.iwr.uni-heidelberg.de/vigra/
11 Patch0:         vigra-1.8.0.lib_suffix.patch
12 BuildRequires:  boost-python-devel >= 1.40.0
13 BuildRequires:  cmake >= 2.6.0
14 BuildRequires:  doxygen
15 BuildRequires:  fftw3-single-devel
16 BuildRequires:  hdf5-devel >= 1.8
17 BuildRequires:  libjpeg-devel
18 BuildRequires:  libpng-devel >= 1.4.0
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libtiff-devel
21 BuildRequires:  pkgconfig
22 BuildRequires:  python
23 BuildRequires:  python-devel
24 BuildRequires:  python-numpy-devel
25 BuildRequires:  rpmbuild(macros) >= 1.586
26 BuildRequires:  sphinx-pdg
27 BuildRequires:  zlib-devel
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 VIGRA stands for "Vision with Generic Algorithms". It's a novel
32 computer vision library that puts its main emphasize on customizable
33 algorithms and data structures. By using template techniques similar
34 to those in the C++ Standard Template Library, you can easily adapt
35 any VIGRA component to the needs of your application, without thereby
36 giving up execution speed.
37
38 %description -l pl.UTF-8
39 VIGRA to skrót od "Vision with Generic Algorithms" (widok z ogólnymi
40 algorytmami). Jest to nowa biblioteka do obrazu komputerowego kładąca
41 główny nacisk na algorytmy i struktury danych z możliwością
42 dostosowania do własnych potrzeb. Poprzez użycie technik szablonów
43 podobnych do tych w standardowej bibliotece szablonów C++ (STL) można
44 łatwo zaadaptować dowolny komponent VIGRA do potrzeb własnej aplikacji
45 bez poświęcania szybkości wykonywania.
46
47 %package devel
48 Summary:        Header files for vigra library
49 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki vigra
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       fftw3-single-devel
53 Requires:       hdf5-devel >= 1.8
54 Requires:       libjpeg-devel
55 Requires:       libpng-devel
56 Requires:       libstdc++-devel
57 Requires:       libtiff-devel
58 Obsoletes:      vigra-static
59
60 %description devel
61 Header files needed to compile programs with vigra.
62
63 %description devel -l pl.UTF-8
64 Pliki nagłówkowe potrzebne do budowania programów używających
65 biblioteki vigra.
66
67 %package -n python-vigra
68 Summary:        VIGRA Python bindings
69 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki VIGRA
70 Group:          Libraries/Python
71 Requires:       %{name} = %{version}-%{release}
72 Requires:       python-numpy
73 Suggests:       python-PyQt4
74
75 %description -n python-vigra
76 VIGRA Python bindings.
77
78 %description -n python-vigra -l pl.UTF-8
79 Wiązania Pythona do biblioteki VIGRA.
80
81 %package doc
82 Summary:        Development documentation for vigra library
83 Summary(pl.UTF-8):      Dokumentacja programisty do biblioteki vigra
84 Group:          Documentation
85
86 %description doc
87 Development documentation for vigra library.
88
89 %description doc -l pl.UTF-8
90 Dokumentacja programisty do biblioteki vigra.
91
92 %prep
93 %setup -q
94 %patch0 -p1
95
96 %build
97 %cmake . \
98         -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG"
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 %py_comp $RPM_BUILD_ROOT%{py_sitedir}/vigra
109 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/vigra
110 %py_postclean
111
112 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/vigra*
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post   -p /sbin/ldconfig
118 %postun -p /sbin/ldconfig
119
120 %files
121 %defattr(644,root,root,755)
122 %doc LICENSE.txt README.txt
123 %attr(755,root,root) %{_libdir}/libvigraimpex.so.*.*
124 %attr(755,root,root) %ghost %{_libdir}/libvigraimpex.so.4
125
126 %files devel
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_bindir}/vigra-config
129 %attr(755,root,root) %{_libdir}/libvigraimpex.so
130 %{_includedir}/vigra
131 %dir %{_libdir}/vigra
132 %{_libdir}/vigra/VigraConfig*.cmake
133 %{_libdir}/vigra/vigra-targets*.cmake
134
135 %files -n python-vigra
136 %defattr(644,root,root,755)
137 %dir %{py_sitedir}/vigra
138 %attr(755,root,root) %{py_sitedir}/vigra/*.so
139 %{py_sitedir}/vigra/*.py[co]
140 %dir %{py_sitedir}/vigra/pyqt
141 %{py_sitedir}/vigra/pyqt/*.py[co]
142
143 %files doc
144 %defattr(644,root,root,755)
145 %doc doc/{vigra,vigranumpy}
This page took 0.078717 seconds and 3 git commands to generate.