]> git.pld-linux.org Git - SPECS.git/blob - verlihub.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / verlihub.spec
1 %define         subver  d-RC2
2 Summary:        DC Hub
3 Summary(pl.UTF-8):      Koncentrator DC
4 Name:           verlihub
5 Version:        0.9.8
6 Release:        0.%{subver}.4
7 License:        GPL
8 Group:          Applications
9 Source0:        http://dl.sourceforge.net/verlihub/%{name}-%{version}%{subver}.tar.gz
10 # Source0-md5:  0824be2cf3af08ccda1638c5d5d0bc4e
11 URL:            http://www.verlihub-project.org/doku.php
12 BuildRequires:  GeoIP-devel
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libtool
17 BuildRequires:  mysql-devel
18 BuildRequires:  openssl-devel
19 BuildRequires:  pcre-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 VerliHub is a Direct Connect protocol server (Hub), runs on linux,
24 written in C++, relatively low CPU & RAM usage, and several useful
25 features. Uses MySQL database.
26
27 %description -l pl.UTF-8
28 VerliHub jest koncentratorem protokołu Direct Connect. Działa pięknie
29 na linuksie, napisane jest w C++, charakteryzuje się relatywnie niskim
30 zużyciem procesora i pamięci oraz wykorzystaniem użytecznych patentów.
31 Działa wspólnie z serwerem MySQL.
32
33 %package devel
34 Summary:        Header files for verlihub
35 Summary(pl.UTF-8):      Pliki nagłówkowe dla verlihub
36 Group:          Development/Languages
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       GeoIP-devel
39 Requires:       libstdc++-devel
40 Requires:       mysql-devel
41 Requires:       openssl-devel
42 Requires:       pcre-devel
43
44 %description devel
45 This package includes the header files for developing.
46
47 %description devel -l pl.UTF-8
48 Ten pakiet zawiera pliki nagłówkowe.
49
50 %package static
51 Summary:        Static verlihub librarys
52 Summary(pl.UTF-8):      Biblioteki statyczne verlihub
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 This package contains static librarys for verlihub.
58
59 %description static -l pl.UTF-8
60 Ten pakiet zawiera statyczne biblioteki verlihub.
61
62 %prep
63 %setup -q -n %{name}
64
65 %build
66 %{__libtoolize}
67 %{__aclocal}
68 %{__autoconf}
69 %{__autoheader}
70 %{__automake}
71 %configure
72
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 install -d $RPM_BUILD_ROOT%{_datadir}/verlihub
78
79 %{__make} install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 cp -f scripts/{c*,im*,v*} $RPM_BUILD_ROOT%{_datadir}/verlihub
83
84 # remove makefile from docs
85 rm -f docs/Makefile*
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files
94 %defattr(644,root,root,755)
95 %doc AUTHORS ChangeLog README TODO docs/*
96 %attr(755,root,root) %{_bindir}/*
97 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
98 %dir %{_datadir}/verlihub
99 %attr(755,root,root) %{_datadir}/verlihub/*
100
101 %files devel
102 %defattr(644,root,root,755)
103 %attr(755,root,root) %{_libdir}/lib*.so
104 %{_libdir}/lib*.la
105 %{_includedir}/verlihub/*
106
107 %files static
108 %defattr(644,root,root,755)
109 %{_libdir}/lib*.a
This page took 0.310733 seconds and 3 git commands to generate.