]> git.pld-linux.org Git - packages/vcdimager.git/blob - vcdimager.spec
- updated to 2.0.1
[packages/vcdimager.git] / vcdimager.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        VideoCD (pre-)mastering and ripping tools
6 Summary(pl.UTF-8):      Narzędzia do tworzenia i odczytu VideoCD
7 Name:           vcdimager
8 Version:        2.0.1
9 Release:        1
10 License:        GPL v2+
11 Group:          Applications/File
12 Source0:        http://ftp.gnu.org/gnu/vcdimager/%{name}-%{version}.tar.gz
13 # Source0-md5:  3890d73da62d0607c87962c41cd33a29
14 Patch0:         %{name}-info.patch
15 URL:            http://www.gnu.org/software/vcdimager/
16 BuildRequires:  autoconf >= 2.52
17 BuildRequires:  automake >= 1.6.0
18 BuildRequires:  help2man
19 BuildRequires:  libcdio-devel >= 2.0.0
20 BuildRequires:  libtool >= 1:1.4.2-9
21 BuildRequires:  libxml2-devel >= 2.6.11
22 BuildRequires:  pkgconfig
23 BuildRequires:  popt-devel >= 1.7
24 BuildRequires:  texinfo
25 Requires(post,postun):  /sbin/ldconfig
26 Requires:       libcdio >= 0.76
27 Requires:       libxml2 >= 2.6.11
28 Requires:       popt >= 1.7
29 Obsoletes:      vcdimager-cdio
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 VCDImager allows you to create VideoCD BIN/CUE CD images from mpeg
34 files which can be burned with cdrdao or any other program capable of
35 burning BIN/CUE files. VCDRip, which comes with VCDImager, does the
36 reverse operation. That is, ripping mpeg streams from images (and
37 already burned VideoCDs) and showing some information about the
38 VideoCD.
39
40 %description -l pl.UTF-8
41 VCDImager służy do tworzenia obrazów VideoCD BIN/CUE z plików mpeg,
42 które następnie mogą być wypalone za pomocą cdrdao lub innego programu
43 zdolnego do wypalania plików BIN/CUE. VCDRip dostarczany wraz z
44 VCDImager pozwala na wykonanie odwrotnej operacji tzn. zrzucenia
45 strumienia mpeg z obrazów (oraz już wypalonych płyt VideoCD).
46
47 %package devel
48 Summary:        Header files for vcd libraries
49 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek vcd
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       libcdio-devel >= 0.76
53 Obsoletes:      vcdimager-cdio-devel
54
55 %description devel
56 Header files for vcd libraries.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe bibliotek vcd.
60
61 %package static
62 Summary:        Static vcd libraries
63 Summary(pl.UTF-8):      Statyczne biblioteki vcd
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66 Obsoletes:      vcdimager-cdio-static
67
68 %description static
69 Static vcd libraries.
70
71 %description static -l pl.UTF-8
72 Statyczne biblioteki vcd.
73
74 %prep
75 %setup -q
76 %patch0 -p1
77
78 cp -f libpopt.m4 acinclude.m4
79
80 %build
81 %{__libtoolize}
82 %{__aclocal}
83 %{__autoconf}
84 %{__autoheader}
85 %{__automake}
86 %configure \
87         --enable-maintainer-mode \
88         %{!?with_static_libs:--disable-static}
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 # obsoleted by pkg-config
98 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvcdinfo.la
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post
104 /sbin/ldconfig
105 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
106
107 %postun
108 /sbin/ldconfig
109 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
110
111 %files
112 %defattr(644,root,root,755)
113 %doc AUTHORS BUGS ChangeLog FAQ NEWS README THANKS TODO
114 %attr(755,root,root) %{_bindir}/cdxa2mpeg
115 %attr(755,root,root) %{_bindir}/vcd-info
116 %attr(755,root,root) %{_bindir}/vcdimager
117 %attr(755,root,root) %{_bindir}/vcdxbuild
118 %attr(755,root,root) %{_bindir}/vcdxgen
119 %attr(755,root,root) %{_bindir}/vcdxminfo
120 %attr(755,root,root) %{_bindir}/vcdxrip
121 %attr(755,root,root) %{_libdir}/libvcdinfo.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libvcdinfo.so.0
123 %{_mandir}/man1/cdxa2mpeg.1*
124 %{_mandir}/man1/vcd-info.1*
125 %{_mandir}/man1/vcdimager.1*
126 %{_mandir}/man1/vcdxbuild.1*
127 %{_mandir}/man1/vcdxgen.1*
128 %{_mandir}/man1/vcdxminfo.1*
129 %{_mandir}/man1/vcdxrip.1*
130 %{_infodir}/vcd-info.info*
131 %{_infodir}/vcdimager.info*
132 %{_infodir}/vcdxrip.info*
133
134 %files devel
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_libdir}/libvcdinfo.so
137 %{_includedir}/libvcd
138 %{_pkgconfigdir}/libvcdinfo.pc
139
140 %if %{with static_libs}
141 %files static
142 %defattr(644,root,root,755)
143 %{_libdir}/libvcdinfo.a
144 %endif
This page took 0.229595 seconds and 4 git commands to generate.