]> git.pld-linux.org Git - packages/vcdimager.git/blob - vcdimager.spec
- BR: help2man
[packages/vcdimager.git] / vcdimager.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        VideoCD (pre-)mastering and ripping tools
6 Summary(pl.UTF-8):      Narzędzia do tworzenia i odczytu VideoCD
7 Name:           vcdimager
8 Version:        0.7.23
9 Release:        10
10 License:        GPL v2+
11 Group:          Applications/File
12 #Source0:       http://www.vcdimager.org/pub/vcdimager/vcdimager-0.7/%{name}-%{version}.tar.gz
13 Source0:        http://ftp.gnu.org/gnu/vcdimager/%{name}-%{version}.tar.gz
14 # Source0-md5:  5e7d80fdbf0037ad20e438f2a9573253
15 Patch0:         %{name}-info.patch
16 URL:            http://www.gnu.org/software/vcdimager/
17 BuildRequires:  autoconf >= 2.52
18 BuildRequires:  automake >= 1.6.0
19 BuildRequires:  help2man
20 BuildRequires:  libcdio-devel >= 0.72
21 BuildRequires:  libtool >= 1:1.4.2-9
22 BuildRequires:  libxml2-devel >= 2.6.11
23 BuildRequires:  pkgconfig
24 BuildRequires:  popt-devel >= 1.7
25 BuildRequires:  texinfo
26 Requires(post,postun):  /sbin/ldconfig
27 Requires:       libcdio >= 0.72
28 Requires:       libxml2 >= 2.6.11
29 Requires:       popt >= 1.7
30 Obsoletes:      vcdimager-cdio
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _noautoreqdep   libvcdinfo.so.0
34
35 %description
36 VCDImager allows you to create VideoCD BIN/CUE CD images from mpeg
37 files which can be burned with cdrdao or any other program capable of
38 burning BIN/CUE files. VCDRip, which comes with VCDImager, does the
39 reverse operation. That is, ripping mpeg streams from images (and
40 already burned VideoCDs) and showing some information about the
41 VideoCD.
42
43 %description -l pl.UTF-8
44 VCDImager służy do tworzenia obrazów VideoCD BIN/CUE z plików mpeg,
45 które następnie mogą być wypalone za pomocą cdrdao lub innego programu
46 zdolnego do wypalania plików BIN/CUE. VCDRip dostarczany wraz z
47 VCDImager pozwala na wykonanie odwrotnej operacji tzn. zrzucenia
48 strumienia mpeg z obrazów (oraz już wypalonych płyt VideoCD).
49
50 %package devel
51 Summary:        Header files for vcd libraries
52 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek vcd
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 Requires:       libcdio-devel >= 0.72
56 Obsoletes:      vcdimager-cdio-devel
57
58 %description devel
59 Header files for vcd libraries.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe bibliotek vcd.
63
64 %package static
65 Summary:        Static vcd libraries
66 Summary(pl.UTF-8):      Statyczne biblioteki vcd
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69 Obsoletes:      vcdimager-cdio-static
70
71 %description static
72 Static vcd libraries.
73
74 %description static -l pl.UTF-8
75 Statyczne biblioteki vcd.
76
77 %prep
78 %setup -q
79 %patch0 -p1
80
81 cp -f libpopt.m4 acinclude.m4
82
83 %build
84 %{__libtoolize}
85 %{__aclocal}
86 %{__autoconf}
87 %{__autoheader}
88 %{__automake}
89 %configure \
90         --enable-maintainer-mode \
91         %{!?with_static_libs:--disable-static}
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post
104 /sbin/ldconfig
105 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
106
107 %postun
108 /sbin/ldconfig
109 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
110
111 %files
112 %defattr(644,root,root,755)
113 %doc AUTHORS BUGS ChangeLog FAQ NEWS README THANKS TODO
114 %attr(755,root,root) %{_bindir}/cdxa2mpeg
115 %attr(755,root,root) %{_bindir}/vcd-info
116 %attr(755,root,root) %{_bindir}/vcdimager
117 %attr(755,root,root) %{_bindir}/vcdxbuild
118 %attr(755,root,root) %{_bindir}/vcdxgen
119 %attr(755,root,root) %{_bindir}/vcdxminfo
120 %attr(755,root,root) %{_bindir}/vcdxrip
121 %attr(755,root,root) %{_libdir}/libvcdinfo.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libvcdinfo.so.0
123 %{_mandir}/man1/cdxa2mpeg.1*
124 %{_mandir}/man1/vcd-info.1*
125 %{_mandir}/man1/vcdimager.1*
126 %{_mandir}/man1/vcdxbuild.1*
127 %{_mandir}/man1/vcdxgen.1*
128 %{_mandir}/man1/vcdxminfo.1*
129 %{_mandir}/man1/vcdxrip.1*
130 %{_infodir}/vcd-info.info*
131 %{_infodir}/vcdimager.info*
132 %{_infodir}/vcdxrip.info*
133
134 %files devel
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_libdir}/libvcdinfo.so
137 %{_libdir}/libvcdinfo.la
138 %{_includedir}/libvcd
139 %{_pkgconfigdir}/libvcdinfo.pc
140
141 %if %{with static_libs}
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/libvcdinfo.a
145 %endif
This page took 0.070787 seconds and 4 git commands to generate.