]> git.pld-linux.org Git - SPECS.git/blob - vcdimager.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / vcdimager.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        VideoCD (pre-)mastering and ripping tools
6 Summary(pl.UTF-8):      Narzędzia do tworzenia i odczytu VideoCD
7 Name:           vcdimager
8 Version:        2.0.1
9 Release:        2
10 License:        GPL v2+
11 Group:          Applications/File
12 Source0:        http://ftp.gnu.org/gnu/vcdimager/%{name}-%{version}.tar.gz
13 # Source0-md5:  3890d73da62d0607c87962c41cd33a29
14 Patch0:         %{name}-info.patch
15 URL:            http://www.gnu.org/software/vcdimager/
16 BuildRequires:  autoconf >= 2.61
17 BuildRequires:  automake >= 1.6.0
18 BuildRequires:  help2man
19 BuildRequires:  libcdio-devel >= 2.0.0
20 BuildRequires:  libtool >= 1:1.4.2-9
21 BuildRequires:  libxml2-devel >= 1:2.6.11
22 BuildRequires:  pkgconfig
23 BuildRequires:  popt-devel >= 1.7
24 BuildRequires:  texinfo
25 Requires(post,postun):  /sbin/ldconfig
26 Requires:       libcdio >= 2.0.0
27 Requires:       libxml2 >= 1:2.6.11
28 Requires:       popt >= 1.7
29 Obsoletes:      vcdimager-cdio
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 VCDImager allows you to create VideoCD BIN/CUE CD images from mpeg
34 files which can be burned with cdrdao or any other program capable of
35 burning BIN/CUE files. VCDRip, which comes with VCDImager, does the
36 reverse operation. That is, ripping mpeg streams from images (and
37 already burned VideoCDs) and showing some information about the
38 VideoCD.
39
40 %description -l pl.UTF-8
41 VCDImager służy do tworzenia obrazów VideoCD BIN/CUE z plików mpeg,
42 które następnie mogą być wypalone za pomocą cdrdao lub innego programu
43 zdolnego do wypalania plików BIN/CUE. VCDRip dostarczany wraz z
44 VCDImager pozwala na wykonanie odwrotnej operacji tzn. zrzucenia
45 strumienia mpeg z obrazów (oraz już wypalonych płyt VideoCD).
46
47 %package devel
48 Summary:        Header files for vcd libraries
49 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek vcd
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       libcdio-devel >= 2.0.0
53 Obsoletes:      vcdimager-cdio-devel
54
55 %description devel
56 Header files for vcd libraries.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe bibliotek vcd.
60
61 %package static
62 Summary:        Static vcd libraries
63 Summary(pl.UTF-8):      Statyczne biblioteki vcd
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66 Obsoletes:      vcdimager-cdio-static
67
68 %description static
69 Static vcd libraries.
70
71 %description static -l pl.UTF-8
72 Statyczne biblioteki vcd.
73
74 %prep
75 %setup -q
76 %patch0 -p1
77
78 %build
79 %{__libtoolize}
80 %{__aclocal}
81 %{__autoconf}
82 %{__autoheader}
83 %{__automake}
84 %configure \
85         --enable-maintainer-mode \
86         --disable-silent-rules \
87         %{!?with_static_libs:--disable-static}
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 # obsoleted by pkg-config
97 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvcdinfo.la
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post
103 /sbin/ldconfig
104 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
105
106 %postun
107 /sbin/ldconfig
108 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
109
110 %files
111 %defattr(644,root,root,755)
112 %doc AUTHORS BUGS ChangeLog FAQ NEWS README THANKS TODO
113 %attr(755,root,root) %{_bindir}/cdxa2mpeg
114 %attr(755,root,root) %{_bindir}/vcd-info
115 %attr(755,root,root) %{_bindir}/vcdimager
116 %attr(755,root,root) %{_bindir}/vcdxbuild
117 %attr(755,root,root) %{_bindir}/vcdxgen
118 %attr(755,root,root) %{_bindir}/vcdxminfo
119 %attr(755,root,root) %{_bindir}/vcdxrip
120 %attr(755,root,root) %{_libdir}/libvcdinfo.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libvcdinfo.so.0
122 %{_mandir}/man1/cdxa2mpeg.1*
123 %{_mandir}/man1/vcd-info.1*
124 %{_mandir}/man1/vcdimager.1*
125 %{_mandir}/man1/vcdxbuild.1*
126 %{_mandir}/man1/vcdxgen.1*
127 %{_mandir}/man1/vcdxminfo.1*
128 %{_mandir}/man1/vcdxrip.1*
129 %{_infodir}/vcd-info.info*
130 %{_infodir}/vcdimager.info*
131 %{_infodir}/vcdxrip.info*
132
133 %files devel
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_libdir}/libvcdinfo.so
136 %{_includedir}/libvcd
137 %{_pkgconfigdir}/libvcdinfo.pc
138
139 %if %{with static_libs}
140 %files static
141 %defattr(644,root,root,755)
142 %{_libdir}/libvcdinfo.a
143 %endif
This page took 0.95332 seconds and 3 git commands to generate.