]> git.pld-linux.org Git - packages/varnish.git/blob - varnish.spec
- R: gcc to compile vcl rules
[packages/varnish.git] / varnish.spec
1 # TODO
2 # - user varnish
3 Summary:        Varnish - a high-performance HTTP accelerator
4 Summary(pl.UTF-8):      Varnish - wydajny akcelerator HTTP
5 Name:           varnish
6 Version:        1.0.4
7 Release:        1.5
8 License:        BSD-like
9 Group:          Daemons
10 Source0:        http://dl.sourceforge.net/varnish/%{name}-%{version}.tar.gz
11 # Source0-md5:  2a917e485700d44b28c0d0b626ea90d8
12 Source1:        %{name}.init
13 Source2:        %{name}.sysconfig
14 Source3:        %{name}.conf
15 URL:            http://www.varnish-cache.org/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libtool >= 2:1.5
20 BuildRequires:  ncurses-devel
21 Requires(post): /sbin/ldconfig
22 Requires:       gcc
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _sysconfdir     /etc/%{name}
26
27 %description
28 The goal of the Varnish project is to develop a state-of-the-art,
29 high-performance HTTP accelerator.
30
31 Varnish is targeted primarily at the FreeBSD 6 and Linux 2.6
32 platforms, and will take full advantage of the advanced I/O features
33 offered by these operating systems.
34
35 %description -l pl.UTF-8
36 Celem projektu Varnish jest stworzenie wydajnego akceleratora HTTP.
37
38 Varnish jest tworzony głównie z myślą o platformach FreeBSD 6 i Linux
39 2.6 i będzie wykorzystywał w pełni zaawansowane możliwości we/we
40 oferowane przez te systemy operacyjne.
41
42 %package devel
43 Summary:        Header files for varnish library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki varnish
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47
48 %description devel
49 Header files for varnish library.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe biblioteki varnish.
53
54 %package static
55 Summary:        Static varnish library
56 Summary(pl.UTF-8):      Statyczna biblioteka varnish
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Static varnish library.
62
63 %description static -l pl.UTF-8
64 Statyczna biblioteka varnish.
65
66 %prep
67 %setup -q
68
69 %build
70 export CPPFLAGS="-I/usr/include/ncurses"
71 %{__aclocal}
72 %{__libtoolize}
73 %{__autoheader}
74 %{__automake}
75 %{__autoconf}
76 %configure
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 # make dirs after make install to know which ones needs spec and which ones make install
86 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{rc.d/init.d,sysconfig},/var/{run,lib}/varnish}
87
88 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/varnish
89 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/varnish
90 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/default.vcl
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post
96 /sbin/ldconfig
97 /sbin/chkconfig --add varnish
98 %service %{name} restart
99
100 %postun -p /sbin/ldconfig
101
102 %preun
103 if [ "$1" = "0" ]; then
104         %service -q %{name} stop
105         /sbin/chkconfig --del %{name}
106 fi
107
108 %files
109 %defattr(644,root,root,755)
110 %doc INSTALL LICENSE README ChangeLog
111 %dir %{_sysconfdir}
112 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/default.vcl
113 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/varnish
114 %attr(754,root,root) /etc/rc.d/init.d/varnish
115 %attr(755,root,root) %{_sbindir}/varnishd
116 %attr(755,root,root) %{_bindir}/varnishhist
117 %attr(755,root,root) %{_bindir}/varnishlog
118 %attr(755,root,root) %{_bindir}/varnishncsa
119 %attr(755,root,root) %{_bindir}/varnishstat
120 %attr(755,root,root) %{_bindir}/varnishtop
121 %attr(755,root,root) %{_libdir}/libvarnish.so.*.*.*
122 %attr(755,root,root) %{_libdir}/libvarnishapi.so.*.*.*
123 %attr(755,root,root) %{_libdir}/libvcl.so.*.*.*
124 /var/lib/varnish
125 /var/run/varnish
126 %{_mandir}/man1/varnishd.1*
127 %{_mandir}/man1/varnishhist.1*
128 %{_mandir}/man1/varnishlog.1*
129 %{_mandir}/man1/varnishncsa.1*
130 %{_mandir}/man1/varnishstat.1*
131 %{_mandir}/man1/varnishtop.1*
132 %{_mandir}/man7/vcl.7*
133
134 %files devel
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_libdir}/libvarnish.so
137 %attr(755,root,root) %{_libdir}/libvarnishapi.so
138 %attr(755,root,root) %{_libdir}/libvcl.so
139 %{_libdir}/libvarnish.la
140 %{_libdir}/libvarnishapi.la
141 %{_libdir}/libvcl.la
142
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/libvarnish.a
146 %{_libdir}/libvarnishapi.a
147 %{_libdir}/libvcl.a
This page took 0.070596 seconds and 4 git commands to generate.