]> git.pld-linux.org Git - packages/varnish.git/blob - varnish.spec
- todo update
[packages/varnish.git] / varnish.spec
1 # TODO
2 # - user varnish
3 # - varnishlog initscript
4 Summary:        Varnish - a high-performance HTTP accelerator
5 Summary(pl.UTF-8):      Varnish - wydajny akcelerator HTTP
6 Name:           varnish
7 Version:        1.0.4
8 Release:        1.5
9 License:        BSD
10 Group:          Daemons
11 Source0:        http://dl.sourceforge.net/varnish/%{name}-%{version}.tar.gz
12 # Source0-md5:  2a917e485700d44b28c0d0b626ea90d8
13 Source1:        %{name}.init
14 Source2:        %{name}.sysconfig
15 Source3:        %{name}.conf
16 URL:            http://www.varnish-cache.org/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libtool >= 2:1.5
21 BuildRequires:  ncurses-devel
22 Requires(post): /sbin/ldconfig
23 Requires:       gcc
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _sysconfdir     /etc/%{name}
27
28 %description
29 The goal of the Varnish project is to develop a state-of-the-art,
30 high-performance HTTP accelerator.
31
32 Varnish is targeted primarily at the FreeBSD 6 and Linux 2.6
33 platforms, and will take full advantage of the advanced I/O features
34 offered by these operating systems.
35
36 %description -l pl.UTF-8
37 Celem projektu Varnish jest stworzenie wydajnego akceleratora HTTP.
38
39 Varnish jest tworzony głównie z myślą o platformach FreeBSD 6 i Linux
40 2.6 i będzie wykorzystywał w pełni zaawansowane możliwości we/we
41 oferowane przez te systemy operacyjne.
42
43 %package devel
44 Summary:        Header files for varnish library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki varnish
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48
49 %description devel
50 Header files for varnish library.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe biblioteki varnish.
54
55 %package static
56 Summary:        Static varnish library
57 Summary(pl.UTF-8):      Statyczna biblioteka varnish
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 Static varnish library.
63
64 %description static -l pl.UTF-8
65 Statyczna biblioteka varnish.
66
67 %prep
68 %setup -q
69
70 %build
71 export CPPFLAGS="-I/usr/include/ncurses"
72 %{__aclocal}
73 %{__libtoolize}
74 %{__autoheader}
75 %{__automake}
76 %{__autoconf}
77 %configure
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 # make dirs after make install to know which ones needs spec and which ones make install
87 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{rc.d/init.d,sysconfig},/var/{run,lib}/varnish}
88
89 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/varnish
90 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/varnish
91 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/default.vcl
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post
97 /sbin/ldconfig
98 /sbin/chkconfig --add varnish
99 %service %{name} restart
100
101 %postun -p /sbin/ldconfig
102
103 %preun
104 if [ "$1" = "0" ]; then
105         %service -q %{name} stop
106         /sbin/chkconfig --del %{name}
107 fi
108
109 %files
110 %defattr(644,root,root,755)
111 %doc LICENSE README ChangeLog
112 %dir %{_sysconfdir}
113 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/default.vcl
114 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/varnish
115 %attr(754,root,root) /etc/rc.d/init.d/varnish
116 %attr(755,root,root) %{_sbindir}/varnishd
117 %attr(755,root,root) %{_bindir}/varnishhist
118 %attr(755,root,root) %{_bindir}/varnishlog
119 %attr(755,root,root) %{_bindir}/varnishncsa
120 %attr(755,root,root) %{_bindir}/varnishstat
121 %attr(755,root,root) %{_bindir}/varnishtop
122 %attr(755,root,root) %{_libdir}/libvarnish.so.*.*.*
123 %attr(755,root,root) %{_libdir}/libvarnishapi.so.*.*.*
124 %attr(755,root,root) %{_libdir}/libvcl.so.*.*.*
125 /var/lib/varnish
126 /var/run/varnish
127 %{_mandir}/man1/varnishd.1*
128 %{_mandir}/man1/varnishhist.1*
129 %{_mandir}/man1/varnishlog.1*
130 %{_mandir}/man1/varnishncsa.1*
131 %{_mandir}/man1/varnishstat.1*
132 %{_mandir}/man1/varnishtop.1*
133 %{_mandir}/man7/vcl.7*
134
135 %files devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_libdir}/libvarnish.so
138 %attr(755,root,root) %{_libdir}/libvarnishapi.so
139 %attr(755,root,root) %{_libdir}/libvcl.so
140 %{_libdir}/libvarnish.la
141 %{_libdir}/libvarnishapi.la
142 %{_libdir}/libvcl.la
143
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/libvarnish.a
147 %{_libdir}/libvarnishapi.a
148 %{_libdir}/libvcl.a
This page took 0.044896 seconds and 4 git commands to generate.