]> git.pld-linux.org Git - packages/varnish.git/blob - varnish.spec
- tabs in preamble
[packages/varnish.git] / varnish.spec
1 Summary:        Varnish - a high-performance HTTP accelerator
2 Summary(pl.UTF-8):      Varnish - wydajny akcelerator HTTP
3 Name:           varnish
4 Version:        1.0.2
5 Release:        0.8
6 License:        BSD-like
7 Group:          Daemons
8 Source0:        http://dl.sourceforge.net/varnish/%{name}-%{version}.tar.gz
9 # Source0-md5:  d905f63a6665224c370154eb006ca4cc
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Source3:        %{name}.conf
13 URL:            http://www.varnish-cache.org/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  libtool >= 2:1.5
18 BuildRequires:  ncurses-devel
19 Requires(post): /sbin/ldconfig
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _sysconfdir     /etc/%{name}
23
24 %description
25 The goal of the Varnish project is to develop a state-of-the-art,
26 high-performance HTTP accelerator.
27
28 Varnish is targeted primarily at the FreeBSD 6 and Linux 2.6
29 platforms, and will take full advantage of the advanced I/O features
30 offered by these operating systems.
31
32 %description -l pl.UTF-8
33 Celem projektu Varnish jest stworzenie wydajnego akceleratora HTTP.
34
35 Varnish jest tworzony głównie z myślą o platformach FreeBSD 6 i Linux
36 2.6 i będzie wykorzystywał w pełni zaawansowane możliwości we/we
37 oferowane przez te systemy operacyjne.
38
39 %package devel
40 Summary:        Header files for varnish library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki varnish
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44
45 %description devel
46 Header files for varnish library.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe biblioteki varnish.
50
51 %package static
52 Summary:        Static varnish library
53 Summary(pl.UTF-8):      Statyczna biblioteka varnish
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 Static varnish library.
59
60 %description static -l pl.UTF-8
61 Statyczna biblioteka varnish.
62
63 %prep
64 %setup -q
65
66 %build
67 export CPPFLAGS="-I/usr/include/ncurses"
68 ./autogen.sh
69 %configure
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 # make dirs after make install to know which ones needs spec and which ones make install
79 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{rc.d/init.d,sysconfig},/var/lib/varnish}
80
81 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/varnish
82 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/varnish
83 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/vcl.conf
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post
89 /sbin/ldconfig
90 /sbin/chkconfig --add varnish
91 %service %{name} restart
92
93 %postun -p /sbin/ldconfig
94
95 %preun
96 if [ "$1" = "0" ]; then
97         %service -q %{name} stop
98         /sbin/chkconfig --del %{name}
99 fi
100
101 %files
102 %defattr(644,root,root,755)
103 %doc INSTALL LICENSE README ChangeLog
104 %dir %{_sysconfdir}
105 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vcl.conf
106 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/varnish
107 %attr(754,root,root) /etc/rc.d/init.d/varnish
108 %attr(755,root,root) %{_sbindir}/varnishd
109 %attr(755,root,root) %{_bindir}/varnishhist
110 %attr(755,root,root) %{_bindir}/varnishlog
111 %attr(755,root,root) %{_bindir}/varnishncsa
112 %attr(755,root,root) %{_bindir}/varnishstat
113 %attr(755,root,root) %{_bindir}/varnishtop
114 %attr(755,root,root) %{_libdir}/libvarnish.so.*.*.*
115 %attr(755,root,root) %{_libdir}/libvarnishapi.so.*.*.*
116 %attr(755,root,root) %{_libdir}/libvcl.so.*.*.*
117 /var/lib/varnish
118 %{_mandir}/man1/varnishd.1*
119 %{_mandir}/man1/varnishhist.1*
120 %{_mandir}/man1/varnishlog.1*
121 %{_mandir}/man1/varnishncsa.1*
122 %{_mandir}/man1/varnishstat.1*
123 %{_mandir}/man1/varnishtop.1*
124 %{_mandir}/man7/vcl.7*
125
126 %files devel
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_libdir}/libvarnish.so
129 %attr(755,root,root) %{_libdir}/libvarnishapi.so
130 %attr(755,root,root) %{_libdir}/libvcl.so
131 %{_libdir}/libvarnish.la
132 %{_libdir}/libvarnishapi.la
133 %{_libdir}/libvcl.la
134
135 %files static
136 %defattr(644,root,root,755)
137 %{_libdir}/libvarnish.a
138 %{_libdir}/libvarnishapi.a
139 %{_libdir}/libvcl.a
This page took 0.068207 seconds and 4 git commands to generate.