]> git.pld-linux.org Git - packages/varnish.git/blob - varnish.spec
- add /var/run/varnish
[packages/varnish.git] / varnish.spec
1 # TODO
2 # - user varnish
3 Summary:        Varnish - a high-performance HTTP accelerator
4 Summary(pl.UTF-8):      Varnish - wydajny akcelerator HTTP
5 Name:           varnish
6 Version:        1.0.4
7 Release:        1.1
8 License:        BSD-like
9 Group:          Daemons
10 Source0:        http://dl.sourceforge.net/varnish/%{name}-%{version}.tar.gz
11 # Source0-md5:  2a917e485700d44b28c0d0b626ea90d8
12 Source1:        %{name}.init
13 Source2:        %{name}.sysconfig
14 Source3:        %{name}.conf
15 URL:            http://www.varnish-cache.org/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libtool >= 2:1.5
20 BuildRequires:  ncurses-devel
21 Requires(post): /sbin/ldconfig
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _sysconfdir     /etc/%{name}
25
26 %description
27 The goal of the Varnish project is to develop a state-of-the-art,
28 high-performance HTTP accelerator.
29
30 Varnish is targeted primarily at the FreeBSD 6 and Linux 2.6
31 platforms, and will take full advantage of the advanced I/O features
32 offered by these operating systems.
33
34 %description -l pl.UTF-8
35 Celem projektu Varnish jest stworzenie wydajnego akceleratora HTTP.
36
37 Varnish jest tworzony głównie z myślą o platformach FreeBSD 6 i Linux
38 2.6 i będzie wykorzystywał w pełni zaawansowane możliwości we/we
39 oferowane przez te systemy operacyjne.
40
41 %package devel
42 Summary:        Header files for varnish library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki varnish
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46
47 %description devel
48 Header files for varnish library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki varnish.
52
53 %package static
54 Summary:        Static varnish library
55 Summary(pl.UTF-8):      Statyczna biblioteka varnish
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static varnish library.
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka varnish.
64
65 %prep
66 %setup -q
67
68 %build
69 export CPPFLAGS="-I/usr/include/ncurses"
70 ./autogen.sh
71 %configure
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 # make dirs after make install to know which ones needs spec and which ones make install
81 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{rc.d/init.d,sysconfig},/var/{run,lib}/varnish}
82
83 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/varnish
84 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/varnish
85 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/vcl.conf
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post
91 /sbin/ldconfig
92 /sbin/chkconfig --add varnish
93 %service %{name} restart
94
95 %postun -p /sbin/ldconfig
96
97 %preun
98 if [ "$1" = "0" ]; then
99         %service -q %{name} stop
100         /sbin/chkconfig --del %{name}
101 fi
102
103 %files
104 %defattr(644,root,root,755)
105 %doc INSTALL LICENSE README ChangeLog
106 %dir %{_sysconfdir}
107 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vcl.conf
108 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/varnish
109 %attr(754,root,root) /etc/rc.d/init.d/varnish
110 %attr(755,root,root) %{_sbindir}/varnishd
111 %attr(755,root,root) %{_bindir}/varnishhist
112 %attr(755,root,root) %{_bindir}/varnishlog
113 %attr(755,root,root) %{_bindir}/varnishncsa
114 %attr(755,root,root) %{_bindir}/varnishstat
115 %attr(755,root,root) %{_bindir}/varnishtop
116 %attr(755,root,root) %{_libdir}/libvarnish.so.*.*.*
117 %attr(755,root,root) %{_libdir}/libvarnishapi.so.*.*.*
118 %attr(755,root,root) %{_libdir}/libvcl.so.*.*.*
119 /var/lib/varnish
120 /var/run/varnish
121 %{_mandir}/man1/varnishd.1*
122 %{_mandir}/man1/varnishhist.1*
123 %{_mandir}/man1/varnishlog.1*
124 %{_mandir}/man1/varnishncsa.1*
125 %{_mandir}/man1/varnishstat.1*
126 %{_mandir}/man1/varnishtop.1*
127 %{_mandir}/man7/vcl.7*
128
129 %files devel
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_libdir}/libvarnish.so
132 %attr(755,root,root) %{_libdir}/libvarnishapi.so
133 %attr(755,root,root) %{_libdir}/libvcl.so
134 %{_libdir}/libvarnish.la
135 %{_libdir}/libvarnishapi.la
136 %{_libdir}/libvcl.la
137
138 %files static
139 %defattr(644,root,root,755)
140 %{_libdir}/libvarnish.a
141 %{_libdir}/libvarnishapi.a
142 %{_libdir}/libvcl.a
This page took 0.109163 seconds and 4 git commands to generate.