]> git.pld-linux.org Git - packages/vala.git/blob - vala.spec
- up to version 0.12.0
[packages/vala.git] / vala.spec
1 %define major_ver       0.12
2 Summary:        GObject-based language compiler
3 Summary(pl.UTF-8):      Kompilator języka opartego na bibliotece GObject
4 Name:           vala
5 Version:        0.12.0
6 Release:        1
7 Epoch:          1
8 License:        LGPL v2+
9 Group:          Applications
10 Source0:        http://ftp.gnome.org/pub/GNOME/sources/vala/0.12/%{name}-%{version}.tar.bz2
11 # Source0-md5:  b11fafaa705085342156312e356b6ff2
12 URL:            http://live.gnome.org/Vala
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  bison
16 BuildRequires:  flex
17 BuildRequires:  glib2-devel >= 1:2.14.0
18 BuildRequires:  libtool
19 BuildRequires:  libxslt-progs
20 BuildRequires:  pkgconfig
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Vala is a new programming language that aims to bring modern
25 programming language features to GNOME developers without imposing any
26 additional runtime requirements and without using a different ABI
27 compared to applications and libraries written in C.
28
29 valac, the Vala compiler, is a self-hosting compiler that translates
30 Vala source code into C source and header files. It uses the GObject
31 type system to create classes and interfaces declared in the Vala
32 source code. It's also planned to generate GIDL files when
33 gobject-introspection is ready.
34
35 The syntax of Vala is similar to C#, modified to better fit the
36 GObject type system.
37
38 %description -l pl.UTF-8
39 Vala to nowy język programowania, którego celem jest udostępnienie
40 cech nowoczesnych języków programowania programistom GNOME bez
41 wymuszania dodatkowych wymagań co do środowiska uruchomieniowego i
42 używania API innego niż w aplikacjach i bibliotekach napisanych w C.
43
44 valac - kompilator języka Vala - to napisany w sobie samym kompilator
45 tłumaczący kod źródłowy w języku Vala na pliki źródłowe i nagłówkowe w
46 C. Używa systemu typów GObject do tworzenia klas i interfejsów
47 zadeklarowanych w kodzie źródłowym w języku Vala. Planowane jest także
48 generowanie plików GIDL, kiedy system gobject-introspection będzie
49 gotowy.
50
51 Składnia języka Vala jest podobna do C#, zmodyfikowana tak, aby lepiej
52 pasować do systemu typów GObject.
53
54 %package apidocs
55 Summary:        vala API documentation
56 Summary(pl.UTF-8):      Dokumentacja API vala
57 Group:          Documentation
58 Requires:       devhelp
59
60 %description apidocs
61 vala API documentation.
62
63 %description apidocs -l pl.UTF-8
64 Dokumentacja API vala.
65
66 %prep
67 %setup -q
68
69 %build
70 %{__libtoolize}
71 %{__aclocal}
72 %{__autoconf}
73 %{__autoheader}
74 %{__automake}
75 %configure \
76         --disable-silent-rules \
77         --enable-vapigen
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 install -d $RPM_BUILD_ROOT%{_datadir}/vala/vapi
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_bindir}/*
99 %attr(755,root,root) %{_libdir}/libvala-%{major_ver}.so.*.*.*
100 %attr(755,root,root) %ghost %{_libdir}/libvala-%{major_ver}.so.0
101 %attr(755,root,root) %{_libdir}/libvala-%{major_ver}.so
102 %{_includedir}/vala-%{major_ver}
103 %{_pkgconfigdir}/libvala-%{major_ver}.pc
104 %dir %{_datadir}/vala
105 %dir %{_datadir}/vala/vapi
106 %dir %{_datadir}/vala-%{major_ver}
107 %dir %{_datadir}/vala-%{major_ver}/vapi
108 %{_datadir}/vala-%{major_ver}/vapi/*.vapi
109 %{_datadir}/vala-%{major_ver}/vapi/*.deps
110 %{_mandir}/man1/valac.1*
111 %{_mandir}/man1/valac-%{major_ver}.1*
112 %dir %{_libdir}/vala-%{major_ver}
113 %attr(755,root,root) %{_libdir}/vala-%{major_ver}/gen-introspect-%{major_ver}
114 %{_mandir}/man1/vala-gen-introspect.1*
115 %{_mandir}/man1/vala-gen-introspect-%{major_ver}.1*
116 %{_mandir}/man1/vapigen.1*
117 %{_mandir}/man1/vapigen-%{major_ver}.1*
118 %{_aclocaldir}/vala.m4
119
120 %files apidocs
121 %defattr(644,root,root,755)
122 %{_datadir}/devhelp/books/vala-%{major_ver}
This page took 0.066021 seconds and 4 git commands to generate.