]> git.pld-linux.org Git - packages/vala.git/blob - vala.spec
Update to 0.26.0
[packages/vala.git] / vala.spec
1 %define major_ver       0.26
2 Summary:        GObject-based language compiler
3 Summary(pl.UTF-8):      Kompilator języka opartego na bibliotece GObject
4 Name:           vala
5 Version:        0.26.0
6 Release:        1
7 Epoch:          2
8 License:        LGPL v2+
9 Group:          Development/Languages
10 Source0:        http://ftp.gnome.org/pub/GNOME/sources/vala/0.26/%{name}-%{version}.tar.xz
11 # Source0-md5:  a418f9ffacdf4ab1e2ecf52c7a73bfea
12 URL:            http://live.gnome.org/Vala
13 BuildRequires:  autoconf >= 2.50
14 BuildRequires:  automake >= 1:1.11
15 BuildRequires:  bison
16 BuildRequires:  flex
17 BuildRequires:  glib2-devel >= 1:2.24.0
18 BuildRequires:  libtool
19 BuildRequires:  libxslt-progs
20 BuildRequires:  pkgconfig
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 Requires:       glib2 >= 1:2.24.0
24 Conflicts:      gdk-pixbuf2 < 2.23.3-1
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Vala is a new programming language that aims to bring modern
29 programming language features to GNOME developers without imposing any
30 additional runtime requirements and without using a different ABI
31 compared to applications and libraries written in C.
32
33 valac, the Vala compiler, is a self-hosting compiler that translates
34 Vala source code into C source and header files. It uses the GObject
35 type system to create classes and interfaces declared in the Vala
36 source code. It's also planned to generate GIDL files when
37 gobject-introspection is ready.
38
39 The syntax of Vala is similar to C#, modified to better fit the
40 GObject type system.
41
42 %description -l pl.UTF-8
43 Vala to nowy język programowania, którego celem jest udostępnienie
44 cech nowoczesnych języków programowania programistom GNOME bez
45 wymuszania dodatkowych wymagań co do środowiska uruchomieniowego i
46 używania API innego niż w aplikacjach i bibliotekach napisanych w C.
47
48 valac - kompilator języka Vala - to napisany w sobie samym kompilator
49 tłumaczący kod źródłowy w języku Vala na pliki źródłowe i nagłówkowe w
50 C. Używa systemu typów GObject do tworzenia klas i interfejsów
51 zadeklarowanych w kodzie źródłowym w języku Vala. Planowane jest także
52 generowanie plików GIDL, kiedy system gobject-introspection będzie
53 gotowy.
54
55 Składnia języka Vala jest podobna do C#, zmodyfikowana tak, aby lepiej
56 pasować do systemu typów GObject.
57
58 %package apidocs
59 Summary:        vala API documentation
60 Summary(pl.UTF-8):      Dokumentacja API vala
61 Group:          Documentation
62 Requires:       devhelp
63
64 %description apidocs
65 vala API documentation.
66
67 %description apidocs -l pl.UTF-8
68 Dokumentacja API vala.
69
70 %prep
71 %setup -q
72
73 %build
74 %{__libtoolize}
75 %{__aclocal} -I m4
76 %{__autoconf}
77 %{__autoheader}
78 %{__automake}
79 %configure \
80         --disable-silent-rules
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT%{_datadir}/vala/vapi
86
87 %{__make} install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post   -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
97
98 %files
99 %defattr(644,root,root,755)
100 %doc AUTHORS ChangeLog MAINTAINERS NEWS README THANKS
101 %attr(755,root,root) %{_bindir}/vala
102 %attr(755,root,root) %{_bindir}/vala-%{major_ver}
103 %attr(755,root,root) %{_bindir}/vala-gen-introspect
104 %attr(755,root,root) %{_bindir}/vala-gen-introspect-%{major_ver}
105 %attr(755,root,root) %{_bindir}/valac
106 %attr(755,root,root) %{_bindir}/valac-%{major_ver}
107 %attr(755,root,root) %{_bindir}/vapicheck
108 %attr(755,root,root) %{_bindir}/vapicheck-%{major_ver}
109 %attr(755,root,root) %{_bindir}/vapigen
110 %attr(755,root,root) %{_bindir}/vapigen-%{major_ver}
111 %attr(755,root,root) %{_libdir}/libvala-%{major_ver}.so.*.*.*
112 %attr(755,root,root) %ghost %{_libdir}/libvala-%{major_ver}.so.0
113 %attr(755,root,root) %{_libdir}/libvala-%{major_ver}.so
114 %{_includedir}/vala-%{major_ver}
115 %{_pkgconfigdir}/libvala-%{major_ver}.pc
116 %{_npkgconfigdir}/vapigen-%{major_ver}.pc
117 %{_npkgconfigdir}/vapigen.pc
118 %dir %{_datadir}/vala
119 %{_datadir}/vala/Makefile.vapigen
120 %dir %{_datadir}/vala/vapi
121 %dir %{_datadir}/vala-%{major_ver}
122 %dir %{_datadir}/vala-%{major_ver}/vapi
123 %{_datadir}/vala-%{major_ver}/vapi/*.vapi
124 %{_datadir}/vala-%{major_ver}/vapi/*.deps
125 %dir %{_libdir}/vala-%{major_ver}
126 %attr(755,root,root) %{_libdir}/vala-%{major_ver}/gen-introspect-%{major_ver}
127 %{_mandir}/man1/vala-gen-introspect.1*
128 %{_mandir}/man1/vala-gen-introspect-%{major_ver}.1*
129 %{_mandir}/man1/valac.1*
130 %{_mandir}/man1/valac-%{major_ver}.1*
131 %{_mandir}/man1/vapigen.1*
132 %{_mandir}/man1/vapigen-%{major_ver}.1*
133 %{_aclocaldir}/vala.m4
134 %{_aclocaldir}/vapigen.m4
135
136 %files apidocs
137 %defattr(644,root,root,755)
138 %{_datadir}/devhelp/books/vala-%{major_ver}
This page took 0.038962 seconds and 4 git commands to generate.