]> git.pld-linux.org Git - packages/vala.git/blob - vala.spec
- up to 0.5.7
[packages/vala.git] / vala.spec
1 Summary:        GObject-based language compiler
2 Summary(pl.UTF-8):      Kompilator języka opartego na bibliotece GObject
3 Name:           vala
4 Version:        0.5.7
5 Release:        1
6 License:        LGPL v2+
7 Group:          Applications
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/vala/0.5/%{name}-%{version}.tar.bz2
9 # Source0-md5:  5e6c4ce07091725d9afdac7cf00e553c
10 URL:            http://www.paldo.org/vala/
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  bison
14 BuildRequires:  flex
15 BuildRequires:  glib2-devel >= 1:2.12.0
16 BuildRequires:  gtk+2-devel >= 2:2.10.0
17 BuildRequires:  libtool
18 BuildRequires:  libxslt-progs
19 BuildRequires:  pkgconfig
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Vala is a new programming language that aims to bring modern
24 programming language features to GNOME developers without imposing any
25 additional runtime requirements and without using a different ABI
26 compared to applications and libraries written in C.
27
28 valac, the Vala compiler, is a self-hosting compiler that translates
29 Vala source code into C source and header files. It uses the GObject
30 type system to create classes and interfaces declared in the Vala
31 source code. It's also planned to generate GIDL files when
32 gobject-introspection is ready.
33
34 The syntax of Vala is similar to C#, modified to better fit the
35 GObject type system.
36
37 %description -l pl.UTF-8
38 Vala to nowy język programowania, którego celem jest udostępnienie
39 cech nowoczesnych języków programowania programistom GNOME bez
40 wymuszania dodatkowych wymagań co do środowiska uruchomieniowego i
41 używania API innego niż w aplikacjach i bibliotekach napisanych w C.
42
43 valac - kompilator języka Vala - to napisany w sobie samym kompilator
44 tłumaczący kod źródłowy w języku Vala na pliki źródłowe i nagłówkowe w
45 C. Używa systemu typów GObject do tworzenia klas i interfejsów
46 zadeklarowanych w kodzie źródłowym w języku Vala. Planowane jest także
47 generowanie plików GIDL, kiedy system gobject-introspection będzie
48 gotowy.
49
50 Składnia języka Vala jest podobna do C#, zmodyfikowana tak, aby lepiej
51 pasować do systemu typów GObject.
52
53 %package apidocs
54 Summary:        vala API documentation
55 Summary(pl.UTF-8):      Dokumentacja API vala
56 Group:          Documentation
57 Requires:       devhelp
58
59 %description apidocs
60 vala API documentation.
61
62 %description apidocs -l pl.UTF-8
63 Dokumentacja API vala.
64
65 %prep
66 %setup -q
67
68 %build
69 %{__libtoolize}
70 %{__aclocal}
71 %{__autoconf}
72 %{__autoheader}
73 %{__automake}
74 %configure \
75         --enable-vapigen 
76 %{__make}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %{__make} install \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_bindir}/*
93 %attr(755,root,root) %{_libdir}/libvala.so.*.*.*
94 %attr(755,root,root) %ghost %{_libdir}/libvala.so.0
95 %attr(755,root,root) %{_libdir}/libvala.so
96 %{_libdir}/libvala.la
97 %{_includedir}/vala-1.0
98 %{_pkgconfigdir}/vala-1.0.pc
99 %dir %{_datadir}/vala
100 %dir %{_datadir}/vala/vapi
101 %{_datadir}/vala/vapi/*.vapi
102 %{_datadir}/vala/vapi/*.deps
103 %{_mandir}/man1/valac.1*
104 %attr(755,root,root) %{_libdir}/vala/gen-introspect
105 %{_mandir}/man1/vala-gen-introspect.1*
106 %{_mandir}/man1/vapigen.1*
107
108 %files apidocs
109 %defattr(644,root,root,755)
110 %{_datadir}/devhelp/books/vala
This page took 0.060577 seconds and 4 git commands to generate.