]> git.pld-linux.org Git - packages/vala.git/blob - vala.spec
- 0.11.2
[packages/vala.git] / vala.spec
1 %define major_ver       0.12
2 Summary:        GObject-based language compiler
3 Summary(pl.UTF-8):      Kompilator języka opartego na bibliotece GObject
4 Name:           vala
5 Version:        0.11.2
6 Release:        1
7 License:        LGPL v2+
8 Group:          Applications
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/vala/0.11/%{name}-%{version}.tar.bz2
10 # Source0-md5:  ef0b6dc4a5fe4caa57e0d029bb9ea8dd
11 URL:            http://live.gnome.org/Vala
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  bison
15 BuildRequires:  flex
16 BuildRequires:  glib2-devel >= 1:2.14.0
17 BuildRequires:  libtool
18 BuildRequires:  libxslt-progs
19 BuildRequires:  pkgconfig
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Vala is a new programming language that aims to bring modern
24 programming language features to GNOME developers without imposing any
25 additional runtime requirements and without using a different ABI
26 compared to applications and libraries written in C.
27
28 valac, the Vala compiler, is a self-hosting compiler that translates
29 Vala source code into C source and header files. It uses the GObject
30 type system to create classes and interfaces declared in the Vala
31 source code. It's also planned to generate GIDL files when
32 gobject-introspection is ready.
33
34 The syntax of Vala is similar to C#, modified to better fit the
35 GObject type system.
36
37 %description -l pl.UTF-8
38 Vala to nowy język programowania, którego celem jest udostępnienie
39 cech nowoczesnych języków programowania programistom GNOME bez
40 wymuszania dodatkowych wymagań co do środowiska uruchomieniowego i
41 używania API innego niż w aplikacjach i bibliotekach napisanych w C.
42
43 valac - kompilator języka Vala - to napisany w sobie samym kompilator
44 tłumaczący kod źródłowy w języku Vala na pliki źródłowe i nagłówkowe w
45 C. Używa systemu typów GObject do tworzenia klas i interfejsów
46 zadeklarowanych w kodzie źródłowym w języku Vala. Planowane jest także
47 generowanie plików GIDL, kiedy system gobject-introspection będzie
48 gotowy.
49
50 Składnia języka Vala jest podobna do C#, zmodyfikowana tak, aby lepiej
51 pasować do systemu typów GObject.
52
53 %package apidocs
54 Summary:        vala API documentation
55 Summary(pl.UTF-8):      Dokumentacja API vala
56 Group:          Documentation
57 Requires:       devhelp
58
59 %description apidocs
60 vala API documentation.
61
62 %description apidocs -l pl.UTF-8
63 Dokumentacja API vala.
64
65 %prep
66 %setup -q
67
68 %build
69 %{__libtoolize}
70 %{__aclocal}
71 %{__autoconf}
72 %{__autoheader}
73 %{__automake}
74 %configure \
75         --disable-silent-rules \
76         --enable-vapigen
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 install -d $RPM_BUILD_ROOT%{_datadir}/vala/vapi
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %attr(755,root,root) %{_bindir}/*
98 %attr(755,root,root) %{_libdir}/libvala-%{major_ver}.so.*.*.*
99 %attr(755,root,root) %ghost %{_libdir}/libvala-%{major_ver}.so.0
100 %attr(755,root,root) %{_libdir}/libvala-%{major_ver}.so
101 %{_includedir}/vala-%{major_ver}
102 %{_pkgconfigdir}/libvala-%{major_ver}.pc
103 %dir %{_datadir}/vala
104 %dir %{_datadir}/vala/vapi
105 %dir %{_datadir}/vala-%{major_ver}
106 %dir %{_datadir}/vala-%{major_ver}/vapi
107 %{_datadir}/vala-%{major_ver}/vapi/*.vapi
108 %{_datadir}/vala-%{major_ver}/vapi/*.deps
109 %{_mandir}/man1/valac.1*
110 %{_mandir}/man1/valac-%{major_ver}.1*
111 %dir %{_libdir}/vala-%{major_ver}
112 %attr(755,root,root) %{_libdir}/vala-%{major_ver}/gen-introspect-%{major_ver}
113 %{_mandir}/man1/vala-gen-introspect.1*
114 %{_mandir}/man1/vala-gen-introspect-%{major_ver}.1*
115 %{_mandir}/man1/vapigen.1*
116 %{_mandir}/man1/vapigen-%{major_ver}.1*
117 %{_aclocaldir}/vala.m4
118
119 %files apidocs
120 %defattr(644,root,root,755)
121 %{_datadir}/devhelp/books/vala-%{major_ver}
This page took 0.038232 seconds and 4 git commands to generate.