]> git.pld-linux.org Git - packages/vala.git/blob - vala.spec
- updated to 0.36.1
[packages/vala.git] / vala.spec
1 # Conditional build:
2 %bcond_with     bootstrap       # bootstrap build
3
4 %define major_ver       0.36
5 Summary:        GObject-based language compiler
6 Summary(pl.UTF-8):      Kompilator języka opartego na bibliotece GObject
7 Name:           vala
8 Version:        0.36.1
9 Release:        1
10 Epoch:          2
11 License:        LGPL v2+
12 Group:          Development/Languages
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/vala/0.36/%{name}-%{version}.tar.xz
14 # Source0-md5:  7453fdf15eb9a668cfc0497547ace14c
15 URL:            http://live.gnome.org/Vala
16 BuildRequires:  autoconf >= 2.65
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  bison
19 BuildRequires:  flex
20 BuildRequires:  glib2-devel >= 1:2.32.0
21 BuildRequires:  libtool >= 2:2.2.6
22 BuildRequires:  libxslt-progs
23 BuildRequires:  pkgconfig >= 1:0.21
24 BuildRequires:  tar >= 1:1.22
25 %{!?with_bootstrap:BuildRequires:       vala >= 2:0.25.1}
26 BuildRequires:  xz
27 Requires:       glib2 >= 1:2.32.0
28 Conflicts:      gdk-pixbuf2 < 2.23.3-1
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Vala is a new programming language that aims to bring modern
33 programming language features to GNOME developers without imposing any
34 additional runtime requirements and without using a different ABI
35 compared to applications and libraries written in C.
36
37 valac, the Vala compiler, is a self-hosting compiler that translates
38 Vala source code into C source and header files. It uses the GObject
39 type system to create classes and interfaces declared in the Vala
40 source code. It's also planned to generate GIDL files when
41 gobject-introspection is ready.
42
43 The syntax of Vala is similar to C#, modified to better fit the
44 GObject type system.
45
46 %description -l pl.UTF-8
47 Vala to nowy język programowania, którego celem jest udostępnienie
48 cech nowoczesnych języków programowania programistom GNOME bez
49 wymuszania dodatkowych wymagań co do środowiska uruchomieniowego i
50 używania API innego niż w aplikacjach i bibliotekach napisanych w C.
51
52 valac - kompilator języka Vala - to napisany w sobie samym kompilator
53 tłumaczący kod źródłowy w języku Vala na pliki źródłowe i nagłówkowe w
54 C. Używa systemu typów GObject do tworzenia klas i interfejsów
55 zadeklarowanych w kodzie źródłowym w języku Vala. Planowane jest także
56 generowanie plików GIDL, kiedy system gobject-introspection będzie
57 gotowy.
58
59 Składnia języka Vala jest podobna do C#, zmodyfikowana tak, aby lepiej
60 pasować do systemu typów GObject.
61
62 %package apidocs
63 Summary:        vala API documentation
64 Summary(pl.UTF-8):      Dokumentacja API vala
65 Group:          Documentation
66 Requires:       devhelp
67 %if "%{_rpmversion}" >= "5"
68 BuildArch:      noarch
69 %endif
70
71 %description apidocs
72 vala API documentation.
73
74 %description apidocs -l pl.UTF-8
75 Dokumentacja API vala.
76
77 %prep
78 %setup -q
79
80 %build
81 %{__libtoolize}
82 %{__aclocal} -I m4
83 %{__autoconf}
84 %{__autoheader}
85 %{__automake}
86 %configure \
87         --disable-silent-rules
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d $RPM_BUILD_ROOT%{_datadir}/vala/vapi
93
94 %{__make} install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post   -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
104
105 %files
106 %defattr(644,root,root,755)
107 %doc AUTHORS ChangeLog NEWS README THANKS
108 %attr(755,root,root) %{_bindir}/vala
109 %attr(755,root,root) %{_bindir}/vala-%{major_ver}
110 %attr(755,root,root) %{_bindir}/vala-gen-introspect
111 %attr(755,root,root) %{_bindir}/vala-gen-introspect-%{major_ver}
112 %attr(755,root,root) %{_bindir}/valac
113 %attr(755,root,root) %{_bindir}/valac-%{major_ver}
114 %attr(755,root,root) %{_bindir}/vapicheck
115 %attr(755,root,root) %{_bindir}/vapicheck-%{major_ver}
116 %attr(755,root,root) %{_bindir}/vapigen
117 %attr(755,root,root) %{_bindir}/vapigen-%{major_ver}
118 %attr(755,root,root) %{_libdir}/libvala-%{major_ver}.so.*.*.*
119 %attr(755,root,root) %ghost %{_libdir}/libvala-%{major_ver}.so.0
120 %attr(755,root,root) %{_libdir}/libvala-%{major_ver}.so
121 %{_includedir}/vala-%{major_ver}
122 %{_pkgconfigdir}/libvala-%{major_ver}.pc
123 %{_pkgconfigdir}/vapigen-%{major_ver}.pc
124 %{_pkgconfigdir}/vapigen.pc
125 %dir %{_datadir}/vala
126 %{_datadir}/vala/Makefile.vapigen
127 %dir %{_datadir}/vala/vapi
128 %dir %{_datadir}/vala-%{major_ver}
129 %dir %{_datadir}/vala-%{major_ver}/vapi
130 %{_datadir}/vala-%{major_ver}/vapi/*.vapi
131 %{_datadir}/vala-%{major_ver}/vapi/*.deps
132 %dir %{_libdir}/vala-%{major_ver}
133 %attr(755,root,root) %{_libdir}/vala-%{major_ver}/gen-introspect-%{major_ver}
134 %{_mandir}/man1/vala-gen-introspect.1*
135 %{_mandir}/man1/vala-gen-introspect-%{major_ver}.1*
136 %{_mandir}/man1/valac.1*
137 %{_mandir}/man1/valac-%{major_ver}.1*
138 %{_mandir}/man1/vapigen.1*
139 %{_mandir}/man1/vapigen-%{major_ver}.1*
140 %{_aclocaldir}/vala.m4
141 %{_aclocaldir}/vapigen.m4
142
143 %files apidocs
144 %defattr(644,root,root,755)
145 %{_datadir}/devhelp/books/vala-%{major_ver}
This page took 0.03457 seconds and 4 git commands to generate.