]> git.pld-linux.org Git - packages/vala.git/blob - vala.spec
Update to 0.38.4
[packages/vala.git] / vala.spec
1 #
2 # Conditional build:
3 %bcond_with     bootstrap       # bootstrap build
4
5 %define major_ver       0.38
6 Summary:        GObject-based language compiler
7 Summary(pl.UTF-8):      Kompilator języka opartego na bibliotece GObject
8 Name:           vala
9 Version:        0.38.4
10 Release:        1
11 Epoch:          2
12 License:        LGPL v2+
13 Group:          Development/Languages
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/vala/0.38/%{name}-%{version}.tar.xz
15 # Source0-md5:  aa80a591205c40c4df0333554135e3bf
16 URL:            http://live.gnome.org/Vala
17 BuildRequires:  autoconf >= 2.65
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  bison
20 BuildRequires:  flex
21 BuildRequires:  glib2-devel >= 1:2.40.0
22 BuildRequires:  graphviz-devel >= 2.16
23 BuildRequires:  libtool >= 2:2.2.6
24 BuildRequires:  libxslt-progs
25 BuildRequires:  pkgconfig >= 1:0.21
26 BuildRequires:  tar >= 1:1.22
27 %{!?with_bootstrap:BuildRequires:       vala >= 2:0.25.1}
28 BuildRequires:  xz
29 Requires:       glib2 >= 1:2.40.0
30 Conflicts:      gdk-pixbuf2 < 2.23.3-1
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Vala is a new programming language that aims to bring modern
35 programming language features to GNOME developers without imposing any
36 additional runtime requirements and without using a different ABI
37 compared to applications and libraries written in C.
38
39 valac, the Vala compiler, is a self-hosting compiler that translates
40 Vala source code into C source and header files. It uses the GObject
41 type system to create classes and interfaces declared in the Vala
42 source code. It's also planned to generate GIDL files when
43 gobject-introspection is ready.
44
45 The syntax of Vala is similar to C#, modified to better fit the
46 GObject type system.
47
48 %description -l pl.UTF-8
49 Vala to nowy język programowania, którego celem jest udostępnienie
50 cech nowoczesnych języków programowania programistom GNOME bez
51 wymuszania dodatkowych wymagań co do środowiska uruchomieniowego i
52 używania API innego niż w aplikacjach i bibliotekach napisanych w C.
53
54 valac - kompilator języka Vala - to napisany w sobie samym kompilator
55 tłumaczący kod źródłowy w języku Vala na pliki źródłowe i nagłówkowe w
56 C. Używa systemu typów GObject do tworzenia klas i interfejsów
57 zadeklarowanych w kodzie źródłowym w języku Vala. Planowane jest także
58 generowanie plików GIDL, kiedy system gobject-introspection będzie
59 gotowy.
60
61 Składnia języka Vala jest podobna do C#, zmodyfikowana tak, aby lepiej
62 pasować do systemu typów GObject.
63
64 %package apidocs
65 Summary:        vala API documentation
66 Summary(pl.UTF-8):      Dokumentacja API vala
67 Group:          Documentation
68 Requires:       devhelp
69 %if "%{_rpmversion}" >= "5"
70 BuildArch:      noarch
71 %endif
72
73 %description apidocs
74 vala API documentation.
75
76 %description apidocs -l pl.UTF-8
77 Dokumentacja API vala.
78
79 %package -n valadoc
80 Summary:        Documentation tool for Vala
81 Summary(pl.UTF-8):      Narzędzie obsługujące dokumentację dla języka Vala
82 Group:          Development/Tools
83 Requires:       %{name} = %{epoch}:%{version}-%{release}
84
85 %description -n valadoc
86 Documentation tool for Vala.
87
88 %description -n valadoc -l pl.UTF-8
89 Narzędzie obsługujące dokumentację dla języka Vala.
90
91 %package -n valadoc-devel
92 Summary:        Header file for Valadoc library
93 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki Valadoc
94 Group:          Development/Libraries
95 Requires:       glib2-devel >= 1:2.40.0
96 Requires:       graphviz-devel >= 2.16
97 Requires:       valadoc = %{epoch}:%{version}-%{release}
98
99 %description -n valadoc-devel
100 Header file for Valadoc library.
101
102 %description -n valadoc-devel -l pl.UTF-8
103 Plik nagłówkowy biblioteki Valadoc.
104
105 %package -n vala-valadoc
106 Summary:        Vala API for Valadoc library
107 Summary(pl.UTF-8):      API języka Vala do biblioteki Valadoc
108 Group:          Development/Libraries
109 Requires:       vala
110 Requires:       valadoc-devel = %{epoch}:%{version}-%{release}
111 %if "%{_rpmversion}" >= "5"
112 BuildArch:      noarch
113 %endif
114
115 %description -n vala-valadoc
116 Vala API for Valadoc library.
117
118 %description -n vala-valadoc -l pl.UTF-8
119 API języka Vala do biblioteki Valadoc.
120
121 %prep
122 %setup -q
123
124 %build
125 %{__libtoolize}
126 %{__aclocal} -I m4
127 %{__autoconf}
128 %{__autoheader}
129 %{__automake}
130 %configure \
131         --disable-silent-rules
132 %{__make}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT%{_datadir}/vala/vapi
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
142
143 # loadable modules
144 %{__rm} $RPM_BUILD_ROOT%{_libdir}/valadoc/*/*/*.la
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post   -p /sbin/ldconfig
150 %postun -p /sbin/ldconfig
151
152 %post   -n valadoc -p /sbin/ldconfig
153 %postun -n valadoc -p /sbin/ldconfig
154
155 %files
156 %defattr(644,root,root,755)
157 %doc AUTHORS ChangeLog NEWS README THANKS
158 %attr(755,root,root) %{_bindir}/vala
159 %attr(755,root,root) %{_bindir}/vala-%{major_ver}
160 %attr(755,root,root) %{_bindir}/vala-gen-introspect
161 %attr(755,root,root) %{_bindir}/vala-gen-introspect-%{major_ver}
162 %attr(755,root,root) %{_bindir}/valac
163 %attr(755,root,root) %{_bindir}/valac-%{major_ver}
164 %attr(755,root,root) %{_bindir}/vapicheck
165 %attr(755,root,root) %{_bindir}/vapicheck-%{major_ver}
166 %attr(755,root,root) %{_bindir}/vapigen
167 %attr(755,root,root) %{_bindir}/vapigen-%{major_ver}
168 %attr(755,root,root) %{_libdir}/libvala-%{major_ver}.so.*.*.*
169 %attr(755,root,root) %ghost %{_libdir}/libvala-%{major_ver}.so.0
170 %attr(755,root,root) %{_libdir}/libvala-%{major_ver}.so
171 %{_includedir}/vala-%{major_ver}
172 %{_pkgconfigdir}/libvala-%{major_ver}.pc
173 %{_pkgconfigdir}/vapigen-%{major_ver}.pc
174 %{_pkgconfigdir}/vapigen.pc
175 %dir %{_datadir}/vala
176 %{_datadir}/vala/Makefile.vapigen
177 %dir %{_datadir}/vala/vapi
178 %{_datadir}/vala/vapi/libvala-%{major_ver}.vapi
179 %dir %{_datadir}/vala-%{major_ver}
180 %dir %{_datadir}/vala-%{major_ver}/vapi
181 %{_datadir}/vala-%{major_ver}/vapi/*.vapi
182 %{_datadir}/vala-%{major_ver}/vapi/*.deps
183 %dir %{_libdir}/vala-%{major_ver}
184 %attr(755,root,root) %{_libdir}/vala-%{major_ver}/gen-introspect-%{major_ver}
185 %{_mandir}/man1/vala-gen-introspect.1*
186 %{_mandir}/man1/vala-gen-introspect-%{major_ver}.1*
187 %{_mandir}/man1/valac.1*
188 %{_mandir}/man1/valac-%{major_ver}.1*
189 %{_mandir}/man1/vapigen.1*
190 %{_mandir}/man1/vapigen-%{major_ver}.1*
191 %{_aclocaldir}/vala.m4
192 %{_aclocaldir}/vapigen.m4
193
194 %files apidocs
195 %defattr(644,root,root,755)
196 %{_datadir}/devhelp/books/vala-%{major_ver}
197
198 %files -n valadoc
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_bindir}/valadoc
201 %attr(755,root,root) %{_bindir}/valadoc-0.38
202 %attr(755,root,root) %{_libdir}/libvaladoc-0.38.so.*.*.*
203 %attr(755,root,root) %ghost %{_libdir}/libvaladoc-0.38.so.0
204 %dir %{_libdir}/valadoc
205 %dir %{_libdir}/valadoc/doclets
206 %dir %{_libdir}/valadoc/doclets/devhelp
207 %attr(755,root,root) %{_libdir}/valadoc/doclets/devhelp/libdoclet.so
208 %dir %{_libdir}/valadoc/doclets/gtkdoc
209 %attr(755,root,root) %{_libdir}/valadoc/doclets/gtkdoc/libdoclet.so
210 %dir %{_libdir}/valadoc/doclets/html
211 %attr(755,root,root) %{_libdir}/valadoc/doclets/html/libdoclet.so
212 %{_datadir}/valadoc
213 %{_mandir}/man1/valadoc-0.38.1*
214 %{_mandir}/man1/valadoc.1*
215
216 %files -n valadoc-devel
217 %defattr(644,root,root,755)
218 %attr(755,root,root) %{_libdir}/libvaladoc-0.38.so
219 %{_includedir}/valadoc-0.38
220 %{_pkgconfigdir}/valadoc-0.38.pc
221
222 %files -n vala-valadoc
223 %defattr(644,root,root,755)
224 %{_datadir}/vala/vapi/valadoc-0.38.deps
225 %{_datadir}/vala/vapi/valadoc-0.38.vapi
This page took 0.05619 seconds and 4 git commands to generate.