]> git.pld-linux.org Git - packages/uucp.git/blob - uucp.spec
c1272487338787ea71a3e5aa5fc3b739f6bbd286
[packages/uucp.git] / uucp.spec
1 Summary:        GNU uucp
2 Summary(de):    GNU-uupc 
3 Summary(fr):    uucp de GNU
4 Summary(pl):    GNU uucp
5 Summary(tr):    GNU uucp sistemi
6 Name:           uucp
7 Version:        1.06.1
8 Release:        5
9 Copyright:      GPL
10 Group:          Daemons
11 Group(pl):      Serwery
12 Source0:        ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}.tar.gz
13 Source1:        %{name}.logrotate
14 Source2:        %{name}.inetd
15 Source3:        %{name}.crontab
16 Patch0:         %{name}-misc.patch
17 Patch1:         %{name}-debian.patch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 UUCP is a Unix to Unix transfer mechanism.  It is used primarily
22 for remote sites to download and upload email and news files to local
23 machines. If you didn't already know that, you probably don't need this
24 package installed.  :-)
25
26 %description -l de
27 UUCP ist ein Unix-nach-Unix-Übertragungsprotokoll. Es wird vor allem
28 verwendet, um E-Mail- und News-Dateien von entfernten auf lokale Rechner
29 herunter- bzw. umgekehrt hochzuladen. Wie Sie wahrscheinlich wissen,
30 müssen Sie das Paket wahrscheinlich nicht installieren.  :-)
31
32 %description -l fr
33 UUCP est un mécanisme de transfert d'UNIX à UNIX. Il est principalement
34 utilisés par les sites de connexion pour télécharger ou envoyer des courriers
35 èlèctroniques et des nouvelles sur les machines locales. Si vous ne saviez
36 pas déja cela, vous n'avez probablement pas besoin d'insatller ce package.
37
38 %description -l pl
39 UUCP (Unix to Unix Copy Protocol) jest jednym z podstawowych protoko³ów systemu
40 Linux. U¿ywany jest przede wszystkim do wysy³ania i pobierania przesy³ek newsów
41 oraz poczty elektronicznej mêdzy maszynami po³±czonymi np. przez modem. 
42
43 %description -l tr
44 UUCP bir Unix'ten Unix'e iletim mekanizmasýdýr. Uzak sitelerden yerel
45 sisteme e-posta ve haber öbekleri aktarýmý için kullanýlýr. Bunun ne
46 olduðunu bilmiyorsanýz, büyük olasýlýkla iþinize de yaramayacaktýr. :-)
47
48 %prep
49 %setup -q
50 %patch0 -p1 
51 %patch1 -p1
52
53 find . -name "*.perlpath" | xargs rm -f
54
55 %build
56 autoconf && %configure
57
58 make clean; make 
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT/usr/{bin,sbin,share/{man/man{1,8},info}}
63
64 make \
65     prefix=$RPM_BUILD_ROOT%{_prefix} \
66     infodir=$RPM_BUILD_ROOT%{_infodir} \
67     bindir=$RPM_BUILD_ROOT%{_bindir} \
68     sbindir=$RPM_BUILD_ROOT%{_sbindir} \
69     man1dir=$RPM_BUILD_ROOT%{_mandir}/man1 \
70     man8dir=$RPM_BUILD_ROOT%{_mandir}/man8 \
71     owner=`id -u` \
72     install install-info 
73
74 gzip -9nf $RPM_BUILD_ROOT%{_infodir}/uucp*
75 gzip -9nf README ChangeLog MANIFEST NEWS sample/* 
76 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man{1,8}/*
77
78 install -d $RPM_BUILD_ROOT/var/spool/{uucp,uucppublic}
79 install -d $RPM_BUILD_ROOT/etc/{uucp/oldconfig,sysconfig/rc-inetd,cron.d}
80
81 install -d $RPM_BUILD_ROOT/usr/lib/uucp
82 ln -sf ../../sbin/uucico $RPM_BUILD_ROOT/usr/lib/uucp/uucico
83
84 install -d $RPM_BUILD_ROOT/etc/logrotate.d
85 install %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/uucp
86 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/uucp
87 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/uucp
88
89 install -d $RPM_BUILD_ROOT/var/log/uucp
90
91 # Create empty files
92 for n in Log Stats Debug; do
93         touch $RPM_BUILD_ROOT/var/log/uucp/$n
94 done
95
96 for i in dial passwd port dialcode sys call ; do
97 cat > $RPM_BUILD_ROOT/etc/uucp/$i <<EOF 
98 # This is an example of a $i file. This file have the syntax compatible
99 # with Taylor UUCP (not HDB, not anything else). Please check uucp
100 # documentation if you are not sure how Taylor config files are supposed to 
101 # look like. Edit it as appropriate for your system.
102
103 # Everything after a '#' character is a comment.
104 EOF
105 done
106
107 # some more documentation
108 texi2html -monolithic uucp.texi
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post
114 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
115
116 %postun
117 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
118
119 %files
120 %defattr(644,root,root,755)
121 %doc *.gz sample contrib 
122
123 %attr(750,uucp,root) %dir /etc/uucp
124 %attr(755,uucp,root) %dir /etc/uucp/oldconfig
125
126 %attr(640,uucp,root) %config %verify(not size mtime md5) /etc/uucp/ca*
127 %attr(640,uucp,root) %config %verify(not size mtime md5) /etc/uucp/di*
128 %attr(640,uucp,root) %config %verify(not size mtime md5) /etc/uucp/p*
129 %attr(640,uucp,root) %config %verify(not size mtime md5) /etc/uucp/sys
130
131 %attr(640,root,root) %config /etc/logrotate.d/uucp
132 %attr(640,root,root) %config /etc/sysconfig/rc-inetd/uucp
133
134 %attr(4711,uucp,uucp) %{_bindir}/cu
135 %attr(4711,uucp,uucp) %{_bindir}/uucp
136 %attr(0755,root,root) %{_bindir}/uulog
137 %attr(4711,uucp,uucp) %{_bindir}/uuname
138 %attr(0755,root,root) %{_bindir}/uupick
139 %attr(4711,uucp,uucp) %{_bindir}/uustat
140 %attr(0755,root,root) %{_bindir}/uuto
141 %attr(4711,uucp,uucp) %{_bindir}/uux
142
143 %{_infodir}/uucp.*
144
145 %attr(755,root,root) %dir %{_libdir}/uucp
146 %attr(755,root,root) %{_libdir}/uucp/uucico
147
148 %{_mandir}/man[18]/*
149
150 %attr(0755,uucp,uucp) %{_sbindir}/uuchk
151 %attr(4711,uucp,uucp) %{_sbindir}/uucico
152 %attr(0755,uucp,uucp) %{_sbindir}/uuconv
153 %attr(0755,root,root) %{_sbindir}/uusched
154 %attr(4711,uucp,uucp) %{_sbindir}/uuxqt
155
156 %attr(755,uucp,uucp) %dir /var/spool/uucppublic
157 %attr(755,uucp,uucp) %dir /var/spool/uucp
158
159 %attr(750,uucp,root) %dir /var/log/uucp
160 %attr(640,uucp,root) %config(noreplace) %verify(not size mtime md5) /var/log/uucp/Debug
161 %attr(640,uucp,root) %config(noreplace) %verify(not size mtime md5) /var/log/uucp/Log
162 %attr(640,uucp,root) %config(noreplace) %verify(not size mtime md5) /var/log/uucp/Stats
This page took 0.038364 seconds and 2 git commands to generate.