]> git.pld-linux.org Git - SPECS.git/blob - usage.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / usage.spec
1 Summary:        Set of programs to see which routines in a C-project are used
2 Summary(pl.UTF-8):      Zestaw programów do monitorowania wykorzystywanych funkcji w C
3 Name:           usage
4 Version:        1.0
5 Release:        3
6 License:        improve-ware
7 Group:          Development/Languages
8 # from http://members.lycos.nl/dpruimboom/usage.zip - wget doesn't work
9 Source0:        %{name}.zip
10 # Source0-md5:  6318e9bc869d551686ccab0d09fb3667
11 Source1:        %{name}.redistribution
12 URL:            http://members.lycos.nl/dpruimboom/
13 BuildRequires:  flex
14 BuildRequires:  unzip
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 This set of programs consist of 'usage' that can be used to see which
19 routines in a C-project are used and how often and what other routines
20 they call. Then there is the CallTree program, this program uses
21 output of the 'usage' program to make a call-tree of the C-project.
22
23 %description -l pl.UTF-8
24 Zestaw programów służących do monitorowania które funkcje w programach
25 C są używane i jak często inne funkcje je wywołują. Jest też program
26 CallTree, wykorzystujący wyjście z usage do stworzenia drzewa wywołań
27 w projekcie C.
28
29 %prep
30 %setup -q -n %{name}
31
32 %build
33 flex %{name}.lex
34 %{__cc} %{rpmcflags} -o %{name} lex.yy.c sys_nodelib.c -lfl
35 cd call_tree
36 %{__cc} %{rpmcflags} -o CallTree sys_nodelib.c CallTree.c
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}}
41
42 install %{name} call_tree/CallTree $RPM_BUILD_ROOT%{_bindir}
43 install %{name}.lst $RPM_BUILD_ROOT%{_sysconfdir}
44 install %{SOURCE1} $RPM_BUILD_DIR/%{name}
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %attr(755,root,root) %{_bindir}/*
52 %verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/%{name}.lst
53 %doc Readme usage.redistribution
This page took 0.630416 seconds and 3 git commands to generate.