]> git.pld-linux.org Git - SPECS.git/blob - unreal-tournament.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / unreal-tournament.spec
1 #
2 # Conditional build:
3 %bcond_with     3dfx            # prefer Glide over OpenGL in config
4 # TODO
5 # - all
6 # - use datadir
7 # - use system libs
8 Summary:        Futuristic FPS
9 Summary(pl.UTF-8):      Futurystyczna gra FPS
10 Name:           unreal-tournament
11 Version:        451
12 Release:        0.2
13 License:        as-is
14 Group:          Applications/Games
15 Source0:        ftp://ftp.lokigames.com/pub/patches/ut/ut-install-436.run
16 # Source0-md5:  b2fb7006ba2420665916739b7d9f7885
17 Source1:        http://utpg.org/patches/UTPGPatch%{version}.tar.bz2
18 # Source1-md5:  77a735a78b1eb819042338859900b83b
19 URL:            http://www.unrealtournament.com/
20 #URL:           http://utpg.org/
21 Requires:       OpenGL
22 Requires:       SDL
23 ExclusiveArch:  %{ix86} %{x8664}
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _noautoreq              Core.so Editor.so Engine.so Render.so libopenal-0.0.so libglide.so.2
27 %define         __syslibs               libSDL-1.1.so.0 libmikmod.so.2
28 %define         _noautoprov             %{__syslibs} %{_noautoreq} ALAudio.so Audio.so Fire.so GlideDrv.so IpDrv.so NullNetDriver.so NullRender.so OpenGLDrv.so SDLDrv.so SDLGLDrv.so SDLSoftDrv.so UWeb.so
29 %define         _enable_debug_packages  0
30 %define         skip_post_check_so      libSDL-1.1.so.0
31
32 %define         gamelibdir              %{_libdir}/games/%{name}
33 %define         gamedatadir             %{_datadir}/games/%{name}
34
35 %description
36 Unreal Tournament - futuristic FPS game.
37
38 %description -l pl.UTF-8
39 Unreal Tournament - futurystyczna gra FPS.
40
41 %prep
42 %setup -qcT
43 skip=$(grep -a ^skip= %{SOURCE0} | cut -d= -f2)
44 tail -n +$skip %{SOURCE0} | tar -zx
45 install -d UTPG lib
46 tar -C UTPG -xf %{SOURCE1}
47 rm -f UTPG/{checkfiles.sh,patch.md5}
48
49 tar -zxf Credits.tar.gz -C lib
50 # NetGamesUSA.com
51 tar -zxf NetGamesUSA.com.tar.gz -C lib
52
53 # System
54 %if %{with 3dfx}
55 tar -zxf Glide.ini.tar.gz -C lib
56 %else
57 tar -zxf OpenGL.ini.tar.gz -C lib
58 %endif
59 tar -zxf data.tar.gz -C lib
60
61 # not really needed to execute
62 chmod a-x lib/NetGamesUSA.com/ngStats/spawnBrowser.exe
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT{%{gamedatadir},%{gamelibdir}} \
67         $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir},%{_bindir}}
68
69 cp -a lib/* $RPM_BUILD_ROOT%{gamelibdir}
70
71 # the most important things, ucc & ut :)
72 install -p bin/x86/{ucc,ut} $RPM_BUILD_ROOT%{gamelibdir}
73
74 # install a few random files
75 cp -p README icon.{bmp,xpm} $RPM_BUILD_ROOT%{gamelibdir}
76
77 # install a menu item (closes bug #27542)
78 cp -p icon.xpm $RPM_BUILD_ROOT%{_pixmapsdir}/ut.xpm
79
80 # finally, unleash the UTPG patch
81 cp -a UTPG/* $RPM_BUILD_ROOT%{gamelibdir}
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %{_pixmapsdir}/ut.xpm
89
90 %dir %{gamelibdir}
91 %{gamelibdir}/Web
92 %{gamelibdir}/Textures
93 %{gamelibdir}/NetGamesUSA.com
94 %{gamelibdir}/Help
95 %{gamelibdir}/System
96 %{gamelibdir}/README
97 %{gamelibdir}/icon.bmp
98 %{gamelibdir}/icon.xpm
99 %{gamelibdir}/ucc
100 %{gamelibdir}/ut
101
102 %dir %{gamedatadir}
This page took 0.21804 seconds and 3 git commands to generate.