]> git.pld-linux.org Git - packages/ufoai.git/blob - ufoai.spec
- release 5
[packages/ufoai.git] / ufoai.spec
1 Summary:        "UFO: Alien Invasion" - squad-based tactical strategy game in the tradition of the old X-COM PC games
2 Summary(pl.UTF-8):      "UFO: Alien Invasion" - gra strategiczna utrzymana w tradycji starych gier X-COM z PC
3 Name:           ufoai
4 Version:        2.3.1
5 Release:        5
6 License:        GPL
7 Group:          X11/Applications/Games/Strategy
8 Source0:        http://downloads.sourceforge.net/ufoai/%{name}-%{version}-source.tar.bz2
9 # Source0-md5:  87b3e1bf3439dc6e5413936034f47d17
10 Source1:        %{name}.desktop
11 Patch0:         %{name}-link.patch
12 URL:            http://ufoai.sourceforge.net/
13 BuildRequires:  OpenAL-devel
14 BuildRequires:  OpenGL-GLU-devel
15 BuildRequires:  SDL-devel
16 BuildRequires:  SDL_image-devel
17 BuildRequires:  SDL_mixer-devel
18 BuildRequires:  SDL_ttf-devel
19 BuildRequires:  curl-devel
20 BuildRequires:  gettext-devel
21 BuildRequires:  gtkglext-devel
22 BuildRequires:  gtksourceview2-devel
23 BuildRequires:  libjpeg-devel
24 BuildRequires:  libogg-devel
25 BuildRequires:  libpng-devel
26 BuildRequires:  libtheora-devel
27 BuildRequires:  libvorbis-devel
28 BuildRequires:  ncurses-devel
29 BuildRequires:  p7zip-standalone
30 BuildRequires:  pkgconfig
31 BuildRequires:  xvid-devel
32 BuildRequires:  zlib-devel
33 Requires:       ufoai-data = %{version}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 It is the year 2084. You control a secret organisation charged with
38 defending Earth from a brutal alien enemy. Build up your bases,
39 prepare your team, and dive head-first into the fast and flowing
40 turn-based combat.
41
42 "UFO: Alien Invasion" is a squad-based tactical strategy game in the
43 tradition of the old X-COM PC games, but with a twist. This game
44 combines military realism with hard science-fiction and the weirdness
45 of an alien invasion. The carefully constructed turn-based system
46 gives you pin-point control of your squad while maintaining a sense of
47 pace and danger.
48
49 Over the long term you will need to conduct research into the alien
50 threat to figure out their mysterious goals and use their powerful
51 weapons for your own ends. You will produce unique items and use them
52 in combat against your enemies. If you like, you can even use them
53 against your friends with multiplayer functionality.
54
55 "UFO: Alien Invasion". Endless hours of gameplay -- absolutely free.
56
57 %description -l pl.UTF-8
58 Jest rok 2084. Kierujesz tajną organizacją, która ma obronić Ziemię
59 przed brutalnymi wrogami. Buduj swoje bazy, przygotuj swój zespół i
60 rzuć się w wir szybkiej turowej walki.
61
62 "UFO: Alien Invasion" to oparta o oddziały gra strategiczna utrzymana
63 w tradycji starych gier X-COM z PC, ale z pewnymi zmianami. Gra łączy
64 realizm militarny z ciężkim science-fiction i dziwnością inwazji
65 wroga. Uważnie skonstruowany system turowy daje kontrolę nad oddziałem
66 zachowując poczucie kroku i niebezpieczeństwa.
67
68 W ciągu długiego czasu gracz musi prowadzić badania narażając się
69 wrogom, aby odkryć ich tajemnicze cele i użyć ich potężnych broni dla
70 własnych potrzeb. Gracz wytworzy unikalne przedmioty i wykorzysta je w
71 walce przeciwko swoim wrogom. Można także używać ich przeciwko
72 przyjaciołom w przypadku gry dla wielu graczy.
73
74 "UFO: Alien Invasion" to niekończące się godziny gry całkowicie za
75 darmo.
76
77 %prep
78 %setup -q -n %{name}-%{version}-source
79 %patch0 -p1
80
81 # needed to build properly
82 mkdir base
83
84 %build
85 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
86 %configure \
87         --with-curses
88 %{__make} \
89         RADIANT_LIBS="-ltinfo"
90 %{__make} lang
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name}/base,%{_datadir}/%{name}/base/i18n,%{_pixmapsdir},%{_desktopdir}}
96 install base/game.so $RPM_BUILD_ROOT%{_libdir}/%{name}/base/game.so
97 install ufo $RPM_BUILD_ROOT%{_libdir}/%{name}/ufoai
98 install ufoded $RPM_BUILD_ROOT%{_libdir}/%{name}/ufoaided
99 install ufo2map $RPM_BUILD_ROOT%{_bindir}/ufoai2map
100 cp -a base/i18n $RPM_BUILD_ROOT%{_datadir}/%{name}/base
101
102 cat > ufoai << 'EOF'
103 #!/bin/sh
104 cd %{_libdir}/%{name}
105 exec ./ufoai
106 EOF
107 cat > ufoaided << 'EOF'
108 #!/bin/sh
109 cd %{_libdir}/%{name}
110 exec ./ufoaided
111 EOF
112
113 install ufoai $RPM_BUILD_ROOT%{_bindir}/ufoai
114 install ufoaided $RPM_BUILD_ROOT%{_bindir}/ufoaided
115
116 ln -s %{_datadir}/%{name}/base/i18n $RPM_BUILD_ROOT%{_libdir}/%{name}/base/i18n
117 for i in base maps materials media models music pics shaders snd ufos; do
118         ln -s %{_datadir}/%{name}/base/0$i.pk3 $RPM_BUILD_ROOT%{_libdir}/%{name}/base/0$i.pk3
119 done
120
121 # install icon and desktop file
122 install debian/ufoai.xpm $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.xpm
123 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %files
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_bindir}/ufoai
131 %attr(755,root,root) %{_bindir}/ufoaided
132 %attr(755,root,root) %{_bindir}/ufoai2map
133 %dir %{_libdir}/%{name}
134 %attr(755,root,root) %{_libdir}/%{name}/ufoai
135 %attr(755,root,root) %{_libdir}/%{name}/ufoaided
136 %dir %{_libdir}/%{name}/base
137 %attr(755,root,root) %{_libdir}/%{name}/base/game.so
138 %attr(755,root,root) %{_libdir}/%{name}/base/i18n
139 %attr(755,root,root) %{_libdir}/%{name}/base/0*.pk3
140 %dir %{_datadir}/%{name}
141 %dir %{_datadir}/%{name}/base
142 %{_datadir}/%{name}/base/i18n
143 %{_pixmapsdir}/%{name}.xpm
144 %{_desktopdir}/%{name}.desktop
This page took 0.05466 seconds and 3 git commands to generate.