]> git.pld-linux.org Git - packages/tuxpaint.git/blob - tuxpaint.spec
- tuxpaint-locale_names.patch updated, added br librsvg-devel, changed
[packages/tuxpaint.git] / tuxpaint.spec
1 #
2 %define         stamps_ver      2008.03.01
3 Summary:        Tux Paint - A simple drawing program for children
4 Summary(pl.UTF-8):      Tux Paint - Prosty program do rysowania dla dzieci
5 Name:           tuxpaint
6 Version:        0.9.19
7 Release:        0.1
8 License:        GPL v2+
9 Group:          X11/Applications/Graphics
10 Source0:        http://downloads.sourceforge.net/tuxpaint/%{name}-%{version}.tar.gz
11 # Source0-md5:  b030a20615743639360327c5af04063b
12 Source1:        http://downloads.sourceforge.net/tuxpaint/%{name}-stamps-%{stamps_ver}.tar.gz
13 # Source1-md5:  81bfb61ff7ffc467d9812f2336377c51
14 Patch0:         %{name}-Makefile.patch
15 Patch1:         %{name}-vfolders.patch
16 Patch2:         %{name}-locale_names.patch
17 URL:            http://www.tuxpaint.org/
18 BuildRequires:  SDL_Pango-devel
19 BuildRequires:  SDL_image-devel >= 1.2.2
20 BuildRequires:  SDL_mixer-devel >= 1.2.4
21 BuildRequires:  SDL_ttf-devel >= 2.0.5
22 BuildRequires:  gettext-devel
23 BuildRequires:  libpaper-devel
24 BuildRequires:  librsvg-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _sysconfdir     /etc/X11
28
29 %description
30 Tux Paint is a simple drawing program for young children (3-10 years
31 old). It is not meant as a general-purpose drawing tool. It is meant
32 to be fun and easy to use. Sound effects and a cartoon character help
33 let the user know what's going on, and keeps them entertained. There
34 are also extra-large cartoon-style mouse pointer shapes.
35
36 %description -l pl.UTF-8
37 Tux Paint jest prostym programem do rysowania dla dzieci (3-10 lat).
38 Nie jest on narzędziem służącym do nauki rysowania, lecz programem
39 łatwym w użyciu, służącym zabawie. Efekty dźwiękowe i komiksowy
40 charakter pomagają użytkownikowi w łatwym poruszaniu się po
41 programie, czyniąc go rozrywkowym. W programie jest także duży
42 wskaźnik myszki oraz przyciski utrzymane w stylu komiksowym.
43
44 %package stamps
45 Summary:        Tux Paint - Collection of "rubber stamp" images
46 Summary(pl.UTF-8):      Tux Paint - Kolekcja obrazów z "gumowej pieczątki"
47 Group:          X11/Applications/Graphics
48 Requires:       %{name} = %{epoch}:%{version}-%{release}
49
50 %description stamps
51 This is a collection of "rubber stamp" images for Tux Paint.
52
53 %description stamps -l pl.UTF-8
54 Jest to kolekcja obrazów dla Tux Painta o nazwie "gumowa pieczątka".
55
56 %prep
57 %setup -q -a 1
58 %patch0 -p1
59 %patch1 -p1
60 %patch2 -p1
61
62 %build
63 %{__make} \
64         CC="%{__cc}" \
65         PREFIX="%{_prefix}" \
66         CONFDIR="%{_sysconfdir}" \
67         DATA_PREFIX="%{_datadir}/tuxpaint" \
68         DOC_PREFIX="%{_datadir}/doc" \
69         ICON_PREFIX="%{_pixmapsdir}" \
70         X11_ICON_PREFIX="%{_pixmapsdir}" \
71         LOCALE_PREFIX="%{_datadir}/locale" \
72         OPTFLAGS="%{rpmcflags}"
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_pixmapsdir},%{_desktopdir},%{_datadir}/%{name}/stamps}
77
78 %{__make} install \
79         _prefix=$RPM_BUILD_ROOT%{_prefix}/ \
80         CONFDIR=$RPM_BUILD_ROOT%{_sysconfdir}/ \
81         MAN_PREFIX=$RPM_BUILD_ROOT%{_mandir}/ \
82         GNOME_PREFIX=$RPM_BUILD_ROOT%{_prefix}/ \
83         KDE_PREFIX=$RPM_BUILD_ROOT%{_desktopdir}/ \
84         X11_ICON_PREFIX=$RPM_BUILD_ROOT%{_pixmapsdir}/
85
86 install src/tuxpaint.conf $RPM_BUILD_ROOT%{_sysconfdir}
87 install data/images/icon48x48.png $RPM_BUILD_ROOT%{_pixmapsdir}/tuxpaint.png
88
89 %{__make} -C %{name}-stamps-%{stamps_ver} install \
90         DATA_PREFIX=$RPM_BUILD_ROOT%{_datadir}/%{name}/
91
92 chmod -R a+rwx $RPM_BUILD_ROOT
93 rm -rf $RPM_BUILD_ROOT%{_datadir}/{doc/tuxpaint,gnome/apps,tuxpaint/CVS}
94
95 #rm a lot of unwanted files and directories:
96 find docs/ -type d|grep CVS|xargs rm -rf
97 find docs/ -name "[KC]OP*" -exec rm -f "{}" ";"
98 find docs/ -name "INS*" -exec rm -f "{}" ";"
99 find docs/ -name "AUT*" -exec rm -f "{}" ";"
100 find docs/ -size -50c -type f -exec rm -f "{}" ";"
101 find docs/ -empty |xargs rm -rf
102
103 %find_lang %{name}
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %files -f %{name}.lang
109 %defattr(644,root,root,755)
110 %doc docs/*
111 %attr(755,root,root) %{_bindir}/*
112 %{_mandir}/man?/*
113 %lang(pl) %{_mandir}/pl/man?/*
114 %{_sysconfdir}/tuxpaint.conf
115 %dir %{_libdir}/%{name}
116 %{_libdir}/%{name}/plugins/
117 %dir %{_datadir}/%{name}
118 %{_datadir}/%{name}/brushes
119 %{_datadir}/%{name}/fonts
120 %{_datadir}/%{name}/images
121 %{_datadir}/%{name}/sounds
122 %{_datadir}/%{name}/starters
123 %{_desktopdir}/*.desktop
124 %{_pixmapsdir}/*
125
126 %files stamps
127 %defattr(644,root,root,755)
128 %{_datadir}/%{name}/stamps
This page took 0.033049 seconds and 3 git commands to generate.