]> git.pld-linux.org Git - SPECS.git/blob - tspc.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / tspc.spec
1 Summary:        Client to configure an IPv6 tunnel to Hexago's migration broker
2 Name:           tspc
3 Version:        2.1.1
4 Release:        0.1
5 License:        GPL v2
6 Group:          Applications/System
7 Source0:        http://ftp.debian.org/debian/pool/main/t/tspc/%{name}_%{version}.orig.tar.gz
8 # Source0-md5:  65183cae002feaacd8bc92d6a5404cc2
9 Source1:        %{name}.init
10 Patch0:         %{name}-PLD.patch
11 BuildRequires:  rpmbuild(macros) >= 1.228
12 Requires(post,preun):   /sbin/chkconfig
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 Connecting to the IPv6 Internet requires either a native connection or
17 the cooperation of a friendly server to provide you with a tunnel.
18
19 Tunnel Server Protocol Client (tspc), is a daemon to automate the
20 setup and maintenance of an IPv6 tunnel. This client will connect to
21 any migration broker which uses Hexago's implementation.
22
23 %prep
24 %setup -q -n %{name}2
25 %patch0 -p1
26
27 %build
28 %{__make} all \
29         target=linux \
30         CFLAGS="%{rpmcflags} -I../../include -I../../platform/linux" \
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_mandir},/etc/sysconfig}
35
36 %{__make} install \
37         target=linux \
38         configdir=%{_sysconfdir}/tsp \
39         install_bin=$RPM_BUILD_ROOT%{_sbindir} \
40         installdir=$RPM_BUILD_ROOT%{_prefix}
41
42 mv $RPM_BUILD_ROOT%{_prefix}/template $RPM_BUILD_ROOT%{_sysconfdir}/tsp
43 mv $RPM_BUILD_ROOT%{_sbindir}/*.conf  $RPM_BUILD_ROOT%{_sysconfdir}/tsp
44 mv $RPM_BUILD_ROOT%{_prefix}/man/*    $RPM_BUILD_ROOT%{_mandir}
45
46 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
47 touch $RPM_BUILD_ROOT/etc/sysconfig/%{name}
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %post
53 /sbin/chkconfig --add %{name}
54 %service %{name} restart
55
56 %preun
57 if [ "$1" = "0" ]; then
58         %service -q %{name} stop
59         /sbin/chkconfig --del %{name}
60 fi
61
62 %files
63 %defattr(644,root,root,755)
64 %attr(755,root,root) %{_sbindir}/%{name}
65 %attr(754,root,root) /etc/rc.d/init.d/%{name}
66 %dir %{_sysconfdir}/tsp
67 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/tsp/*.sh
68 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/tsp/*.conf
69 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
70 %{_mandir}/man?/*
This page took 0.742802 seconds and 3 git commands to generate.