]> git.pld-linux.org Git - SPECS.git/blob - travis-lint.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / travis-lint.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 Summary:        Checks your .travis.yml for possible issues, deprecations and so on
6 Name:           travis-lint
7 Version:        1.8.0
8 Release:        1
9 License:        GPL v2+ or Ruby
10 Group:          Development/Languages
11 Source0:        http://rubygems.org/downloads/%{name}-%{version}.gem
12 # Source0-md5:  c4a1e80786570ac94b10662275367701
13 URL:            https://github.com/travis-ci/travis-lint
14 BuildRequires:  rpm-rubyprov
15 BuildRequires:  rpmbuild(macros) >= 1.656
16 BuildRequires:  sed >= 4.0
17 %if %{with tests}
18 BuildRequires:  ruby-rspec < 3
19 BuildRequires:  ruby-rspec >= 2.8
20 %endif
21 Requires:       ruby-hashr < 0.1
22 Requires:       ruby-hashr >= 0.0.22
23 Requires:       ruby-safe_yaml < 0.10
24 Requires:       ruby-safe_yaml >= 0.9.0
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 travis-lint is a tool that check your .travis.yml for possible issues,
30 deprecations and so on. Recommended for all travis-ci.org users.
31
32 %prep
33 %setup -q
34 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}}
39 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
40 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(644,root,root,755)
47 %attr(755,root,root) %{_bindir}/travis-lint
48 %dir %{ruby_vendorlibdir}/travis
49 %{ruby_vendorlibdir}/travis/lint.rb
50 %{ruby_vendorlibdir}/travis/lint
This page took 0.261599 seconds and 3 git commands to generate.